rolgordijn
Posts: 8
Joined: Sun Mar 26, 2017 2:06 pm

installing gattlib for python3?

Fri Mar 15, 2019 10:58 am

Hello,
I try to run the examples for bluetooth low energy in the pybluez module, but they require the gattlib module.

I tried

Code: Select all

 'pip3 install gattlib' 
but this fails with following error:

Code: Select all

/usr/bin/ld: cannot find -lboost_python-py34
What does this mean and how can i fix it?

User avatar
ben_nuttall
Posts: 235
Joined: Sun Aug 19, 2012 11:19 am
Location: Cambridgeshire, UK
Contact: Website Twitter

Re: installing gattlib for python3?

Fri Mar 15, 2019 10:00 pm

It looks like some apt package which provides bluetooth.h will fix it. I'm tracking this in the piwheels issue tracker: https://github.com/bennuttall/piwheels/issues/129
Former RPF staff. Author of gpiozero and creator of piwheels.

Return to “Python”