murksiuke
Posts: 11
Joined: Thu Feb 15, 2018 9:33 am

Raspberry doesnt respond during openCV instalation

Sat Sep 22, 2018 1:48 pm

Im trying to install openCV using this guide https://www.alatortsev.com/2018/04/27/i ... ry-pi-3-b/ , and got to the point where the actual installation starts. Since the guide said that the installation will take a couple hours, i just left it alone. Now, about an hour in, i tried checking in, but at first the screen was completely black and wouldnt "wake up" with mouse movements. After ~5mins, the screen came alive again, but now the mouse doesnt move or maybe the screen (where the installation window should at least be be showing new output) is frozen. First instinct says to reboot it, but since the installation should still be going on im hesitant to do so. Any advice?

DirkS
Posts: 9057
Joined: Tue Jun 19, 2012 9:46 pm
Location: Essex, UK

Re: Raspberry doesnt respond during openCV instalation

Sat Sep 22, 2018 3:52 pm

Just leave it for a couple of hours...

FYI: if you're on Raspbian Stretch you can actually access pre-compiled opencv (and other) wheels with 'pip3' (IIRC they are just available for Python 3.4 and 3.5 ATM)
Both opencv-python and opencv-contrib-python are available.

It is possible to do this on other OSs but that would need some additional configuration.

murksiuke
Posts: 11
Joined: Thu Feb 15, 2018 9:33 am

Re: Raspberry doesnt respond during openCV instalation

Sun Sep 23, 2018 8:40 pm

DirkS wrote:
Sat Sep 22, 2018 3:52 pm
Just leave it for a couple of hours...

FYI: if you're on Raspbian Stretch you can actually access pre-compiled opencv (and other) wheels with 'pip3' (IIRC they are just available for Python 3.4 and 3.5 ATM)
Both opencv-python and opencv-contrib-python are available.

It is possible to do this on other OSs but that would need some additional configuration.
Thank you! Had to reboot the pi in the end (glad the pi is alright at least), and it seems the installation didnt complete & got cancelled, so i will just try to do it with pip3. Whish i knew about it from the start!

DirkS
Posts: 9057
Joined: Tue Jun 19, 2012 9:46 pm
Location: Essex, UK

Re: Raspberry doesnt respond during openCV instalation

Sun Sep 23, 2018 9:12 pm

If you're interested you could have a look at https://www.piwheels.org/
As I said it's already configured on Raspbian Stretch

User avatar
bonzadog
Posts: 214
Joined: Wed Apr 25, 2012 9:40 am
Location: Rietberg/Germany

Re: Raspberry doesnt respond during openCV instalation

Mon Sep 24, 2018 10:31 am

I had that when I compiled on a RPI3 using the number of CPUs option -J2, I changed to -J1 and the run was successfull.
One could also temporarily increase the swap space and leave the -j2. That works as well.

Return to “Python”

Who is online

Users browsing this forum: No registered users and 17 guests