lambcutlet
Posts: 14
Joined: Mon Aug 18, 2014 7:56 pm

[solved ]Warning **: Error retrieving accessibility bus address:

Tue Oct 24, 2017 8:23 pm

One issue I have always had was an error warning each time I started a python program from the commandline, for example 'python test.py'.

the warning
** (test.py:3047): WARNING **: Error retrieving accessibility bus address: org.freedesktop.DBus.Error.ServiceUnknown: The name org.a11y.Bus was not provided by any .service files
to solve I installed 'at-spi2-core'

Code: Select all

sudo apt-get install at-spi2-core
i found the answer in this thread https://github.com/NixOS/nixpkgs/issues/16327

User avatar
jbeale
Posts: 3469
Joined: Tue Nov 22, 2011 11:51 pm
Contact: Website

Re: [solved ]Warning **: Error retrieving accessibility bus address:

Sun Feb 25, 2018 5:09 am

Thanks! That got rid of the annoying message whenever I started a python program.

EdjeElectronics
Posts: 8
Joined: Mon Mar 13, 2017 1:55 am

Re: [solved ]Warning **: Error retrieving accessibility bus address:

Wed Apr 04, 2018 3:30 am

You the man! This worked for me too. Thanks for posting the solution here!
Check out my Raspberry Pi projects at www.youtube.com/c/EdjeElectronics !

User avatar
PeterO
Posts: 4873
Joined: Sun Jul 22, 2012 4:14 pm

Re: [solved ]Warning **: Error retrieving accessibility bus address:

Wed Apr 04, 2018 5:21 am

at-spi2-core is on the list of "extra packages" I always install when building a new Raspbian disk.
That warning is not just a Python problem. For me it happens with all GTK+ applications (be they in Python or in C).

PeterO
Discoverer of the PI2 XENON DEATH FLASH!
Interests: C,Python,PIC,Electronics,Ham Radio (G0DZB),1960s British Computers.
"The primary requirement (as we've always seen in your examples) is that the code is readable. " Dougie Lawson

User avatar
bonzadog
Posts: 235
Joined: Wed Apr 25, 2012 9:40 am
Location: Rietberg/Germany

Re: [solved ]Warning **: Error retrieving accessibility bus address:

Mon Jun 04, 2018 11:26 am

Using Debians STRETCH on the raspberry pi I received this error:

sudo apt-get update && apt-get dist-upgrade.....

[email protected]:~ $ sudo apt-get install at-spi2-core
Reading package lists... Done
Building dependency tree
Reading state information... Done
The following NEW packages will be installed:
at-spi2-core
0 upgraded, 1 newly installed, 0 to remove and 0 not upgraded.
Need to get 0 B/63.4 kB of archives.
After this operation, 402 kB of additional disk space will be used.
Selecting previously unselected package at-spi2-core.
dpkg: unrecoverable fatal error, aborting:

files list file for package 'libapt-inst2.0:armhf' is missing final newline
E: Sub-process /usr/bin/dpkg returned an error code (2)
[email protected]:~ $
So probably the at-spi2-core in not valid for the RPi - but I cannot find an alternative.
Any help on this please.

User avatar
billybangleballs
Posts: 142
Joined: Fri May 18, 2012 11:28 pm

Re: [solved ]Warning **: Error retrieving accessibility bus address:

Mon Nov 05, 2018 8:20 pm

[email protected]:~# uname -a
Linux sane 4.14.69-v7+ #1141 SMP Mon Sep 10 15:26:29 BST 2018 armv7l GNU/Linux
[email protected]:~# apt-get install at-spi2-core
Reading package lists... Done
Building dependency tree
Reading state information... Done
The following NEW packages will be installed:
at-spi2-core
0 upgraded, 1 newly installed, 0 to remove and 17 not upgraded.
Need to get 63.4 kB of archives.
After this operation, 402 kB of additional disk space will be used.
Get:1 http://raspbian.mirror.uk.sargasso.net/raspbian stretch/main armhf at-spi2-core armhf 2.22.0-6+deb9u1 [63.4 kB]
Fetched 63.4 kB in 0s (209 kB/s)
Selecting previously unselected package at-spi2-core.
(Reading database ... 164657 files and directories currently installed.)
Preparing to unpack .../at-spi2-core_2.22.0-6+deb9u1_armhf.deb ...
Unpacking at-spi2-core (2.22.0-6+deb9u1) ...
Setting up at-spi2-core (2.22.0-6+deb9u1) ...
[email protected]:~#

Installed Ok here, and stopped the :- ** (java:16042): WARNING **: Error retrieving accessibility bus address: org.freedesktop.DBus.Error.ServiceUnknown: The name org.a11y.Bus was not provided by any .service files
that I was getting after building angryip.
It is a fairly recent version of Raspbian.
Grumpy old man.
Ex-G0KAP - I'd rather be doing it than talking about it.
"When found, make a note of." - Captain Cuttle

Return to “Python”