XavM
Posts: 35
Joined: Thu May 31, 2012 11:29 pm

Cloud9 IDE running on the Raspberry Pi

Mon Jul 02, 2012 8:15 am

Just to let people know : It is possible to install the Web based IDE Cloud9 on the Raspberry Pi

When googling around about c9 on the Raspberry Pi , nothing poped up;
So I tried and ... it just works.

I still didn't try anything else than install, launch and test c9 with some first level browsing, and I can't tell if every thing works as expected.

More over, assuming that the R-Pi has limited CPU, Memory and IO, I am still not sure there is any kind of interest to run c9 on the Pi, but ... it is fun to know it works.

Here is what I had to do to have it to work :

sudo npm install -g sm
git clone https://github.com/ajaxorg/cloud9.git cloud9
cd cloud9
sm install

#At this step I had a HTTP 502 Error on treehugger module and had to proceed like this :

npm install treehugger
sm install --cached
sudo sm install

#At this step some modules were still missing and I had to install them manually :

npm install formidable
npm install gnu-tools
npm install xmldom

#The c9 startup script rely on "uname -a" to detect the OS and I had to edit "bin/cloud9.sh and add the following lines before "*) echo "Unknown OS"" :
Linux*raspberrypi*) echo "Linux raspberrypi ARM"
node server.js "$@" -a x-www-browser
;;
#To allow c9 on the R-pi to be accessed from a remote browser edit "configs/default.js" and adjust like this :
var host = argv.l || "0.0.0.0";

#To start Cloud9 :
bin/cloud9.sh -w ~/MySuperProject

#You can now access the c9 Web based IDE at the following URL :
http://Your_R-Pi_IP_Adress:3131

XavM

tgalonso
Posts: 4
Joined: Wed Aug 01, 2012 1:13 pm

Re: Cloud9 IDE running on the Raspberry Pi

Wed Aug 01, 2012 1:19 pm

I have been having problems with libxml and xmldom. I am getting ENOSPC errors. Could I be running out of space in a temp dir? I set TMPDIR to /home/pi/tmp in an effort to fix this problem. Any thoughts?

stefan.stoichev
Posts: 2
Joined: Sat Aug 04, 2012 8:31 pm

Re: Cloud9 IDE running on the Raspberry Pi

Wed Aug 08, 2012 12:07 pm

Which version of Node.js you used?

Thanks!
Stefan

stefan.stoichev
Posts: 2
Joined: Sat Aug 04, 2012 8:31 pm

Re: Cloud9 IDE running on the Raspberry Pi

Thu Aug 09, 2012 5:08 pm

Never mind it's running now :) (used node.js v0.6.16)

gbraad
Posts: 1
Joined: Thu Aug 16, 2012 4:54 pm

Re: Cloud9 IDE running on the Raspberry Pi

Wed Aug 22, 2012 11:52 am

You do not need to edit the default config file to change listening to 0.0.0.0. Just provide the -i 0.0.0.0 argument on the command line. (this is what argv.i means).

tgalonso
Posts: 4
Joined: Wed Aug 01, 2012 1:13 pm

Re: Cloud9 IDE running on the Raspberry Pi

Sun Aug 26, 2012 11:50 pm

How do I get v0.6.19 of Node.js?
tglonso

tgalonso
Posts: 4
Joined: Wed Aug 01, 2012 1:13 pm

Re: Cloud9 IDE running on the Raspberry Pi

Tue Aug 28, 2012 5:39 pm

I could not get libxml to install. I am about to give up. This does not work.

paul_tanner
Posts: 1
Joined: Sun Jan 06, 2013 7:20 am

Re: Cloud9 IDE running on the Raspberry Pi

Sun Jan 06, 2013 7:43 am

Hi,

This would certainly be very useful

I never got round to this install till now and in the meantime had got to this config:

Linux 3.1.9adafruit+cached (black raspberry)
node.js (version v0.9.3-pre)
npm (version 1.1.61)
sm (version 0.2.11)
(the root partition of my 4Gb SD card is 67% used)

Looks like the installation process has moved on somewhat https://github.com/ajaxorg/cloud9/blob/master/README.md

I have also updated everything else like nodejs-dev and libxml-dev
Also deleted the sourcemint caches

.. and still it won't install. Currently the first error I get is from gcc

>> cc1plus: error: unrecognized command line option ‘-msse2’

Not sure what that refers to?

Anyone tried this install with the above versions? For other reasons I can't go back

Thx Paul.

Mackiur
Posts: 2
Joined: Sun Dec 02, 2012 1:12 am

Re: Cloud9 IDE running on the Raspberry Pi

Thu Mar 07, 2013 8:57 pm

I need help

when i run cloud9 with

node ~/cloud9/bin/cloud9.sh -w ~/app/Test1

i obtain this

Code: Select all

/home/pi/cloud9/bin/cloud9.sh:4
CMD_DIR="$( cd "$( dirname "$0" )" && pwd )"
                ^
SyntaxError: Unexpected identifier
    at Module._compile (module.js:439:25)
    at Object.Module._extensions..js (module.js:474:10)
    at Module.load (module.js:356:32)
    at Function.Module._load (module.js:312:12)
    at Module.runMain (module.js:497:10)
    at process._tickCallback (node.js:427:13)
:(

i do all steps before.... include the part of add a section for this raspberry....
thx

User avatar
RIAEvangelist
Posts: 3
Joined: Fri Dec 27, 2013 2:21 am
Location: Thosand Oaks Ca

Re: Cloud9 IDE running on the Raspberry Pi

Mon Jan 13, 2014 9:50 pm

Here is how I got it working :
https://gist.github.com/RIAEvangelist/6335743

Return to “Beginners”

Who is online

Users browsing this forum: No registered users and 60 guests