jularaXD
Posts: 1
Joined: Thu Jan 15, 2015 6:41 pm

Problem installing non-crossing QT Creator

Thu Jan 15, 2015 6:52 pm

Hi!
Now, I'm trying to install qt creator to my raspberry pi, but I discovered horrified that the qt4-dev-tools repository was updated for qt creator 4.8.2, but the qt creator repository remains at version 4.8.1, and when I try to add qt version, takes me an error, saying invalid version...
I was searching for old qt4-dev-tools repositories, but I don't find nothing...

What can I do?

Thanks in advice (and sorry if my english is not very well :D )!!!

User avatar
mad-hatter
Posts: 419
Joined: Sun Feb 26, 2012 2:58 pm
Location: By the UK seaside

Re: Problem installing non-crossing QT Creator

Fri Jan 16, 2015 12:06 am

Hello,

This is what I have installed on my Pi.
Everything seems to work together.
I'm running Rasbian 'Wheezy'.
Sudo apt-get install qtcreator qtdesigner

I have these Qt extras installed, you don't need them all, it’s just what I have installed.

libntrack-qt4-1 libntrack0 libqscintilla2-8 libqt4-dbus libqt4-declarative libqt4-declarative-gestures
libqt4-declarative-particles libqt4-designer libqt4-dev libqt4-dev-bin libqt4-help libqt4-network
libqt4-opengl libqt4-opengl-dev libqt4-qt3support libqt4-script libqt4-scripttools libqt4-sql
libqt4-sql-mysql libqt4-sql-sqlite libqt4-svg libqt4-test libqt4-xml libqt4-xmlpatterns qt4-demos
qt4-dev-tools qt4-doc qt4-linguist-tools qt4-qmake qt4-qmlviewer
I used the "synaptic" package manager to install.

Regards

Return to “General programming discussion”