jord83uk
Posts: 10
Joined: Sat Jun 16, 2012 8:24 pm

File Transfer Over SSH

Wed Jun 27, 2012 5:59 pm

Hi everyone, I help some help transferring files from my laptop to my pi. I have managed to connect to my pi using both winscp and flashfxp but when I transfer after around 30 seconds it disconnects.. Ive tried using GParted to increase the partition size but am unable to increase the 75mb but there is another partition which has plenty of storage... Any help would be appreciated... Cheers

rasbeer
Posts: 242
Joined: Wed Mar 07, 2012 8:35 am

Re: File Transfer Over SSH

Wed Jun 27, 2012 6:34 pm

Can you mount the second partition? Then it should show up as a folder in /mnt or /media & you should be able to cp (or scp) files into it, I think.

jord83uk
Posts: 10
Joined: Sat Jun 16, 2012 8:24 pm

Re: File Transfer Over SSH

Wed Jun 27, 2012 7:04 pm

Hi, yeah I tried both mnt and media but both say permission denied...

deej1976
Posts: 7
Joined: Wed Jun 27, 2012 2:30 pm
Contact: Website

Re: File Transfer Over SSH

Wed Jun 27, 2012 8:23 pm

Is it a space issue if you log into your pi with putty (ssh client) and run "df -lh" how much space is reported for partition / or /dev/sda2 ?

The standard image is 2GB, and you will only be able to use 2GB unless you resize the root (/) partition, there are instructions on the wiki. example if you dd the image to a 16GB card you will only see 2GB usable, until you resize the root (/) partition.

What have you got attached to the USB ports, if you unplug mouse/keyboard does the disconnect still happen?

jord83uk
Posts: 10
Joined: Sat Jun 16, 2012 8:24 pm

Re: File Transfer Over SSH

Wed Jun 27, 2012 8:54 pm

The partition size is around 2gb and around 1gb is being used so there is space for the quake files... On the guide I followed it said to transfer the files to /var/tmp but it after 20-30 seconds it crashes... I tried disconnecting USB ports but system crashes!!

Return to “General programming discussion”

Who is online

Users browsing this forum: No registered users and 5 guests