swr
Posts: 2
Joined: Sun Aug 17, 2014 11:52 pm

wkhtmltoimage compiling

Wed Aug 20, 2014 1:00 pm

So, I'm totally new in this world, and I searched a lot but, i don't know how to do it.
For a project of mine, i need wkhtmltoimage (wkhtmltopdf package) working for the Pi.

My question is - how I can cross compile it? if you download the files, the source code has a custom build.py

fruitoftheloom
Posts: 22091
Joined: Tue Mar 25, 2014 12:40 pm
Location: Delightful Dorset

Re: wkhtmltoimage compiling

Wed Aug 20, 2014 9:02 pm

https://packages.debian.org/stable/utils/wkhtmltopdf

This is available from the Raspbian Wheezy distribution repository

Code: Select all

sudo apt-get update
sudo apt-get install wkhtmltopdf
The Arch Linux Arm distribution also has the package
Retired disgracefully.....
......to an uncomplicated life !

Rather than negativity think outside the box !

swr
Posts: 2
Joined: Sun Aug 17, 2014 11:52 pm

Re: wkhtmltoimage compiling

Thu Aug 21, 2014 12:25 am

Since the version on wheezy is 0.9.9-4, can I install the arch package 0.12.1-1 in raspbian?

Thank you :roll:

fruitoftheloom
Posts: 22091
Joined: Tue Mar 25, 2014 12:40 pm
Location: Delightful Dorset

Re: wkhtmltoimage compiling

Thu Aug 21, 2014 5:41 am

swr wrote:Since the version on wheezy is 0.9.9-4, can I install the arch package 0.12.1-1 in raspbian?

Thank you :roll:

Unfortunately not, they use different Repositories, if you want later version you have to compile from source, or update to the next version of Raspbian, which is Jessie Testing (this undergoing constant updates until it replaces Wheezy likely next year).

..for the source code download http://wkhtmltopdf.org/downloads.html but after a quick check it appears to be only for compiling on x86 & x86-64 Architecture not the Pi.s ARMv6 Architecture

?? is there any reason why you need the later version ?? https://github.com/wkhtmltopdf/wkhtmlto ... NGELOG-OLD
Retired disgracefully.....
......to an uncomplicated life !

Rather than negativity think outside the box !

Giuliano69
Posts: 9
Joined: Fri Jul 19, 2013 9:10 am

Re: wkhtmltoimage compiling

Mon Jun 15, 2015 11:21 am

Hi,
I have the same problem with and installation of Odoo server over Rasberry 2.0.

The wkhtmltopdf library required is 12.1, but we can provide onli 0,9 in Raspian.
Is there a way to get the newer version on Raspberry, or to compile it ?

I tried to install the deb package from
https://packages.debian.org/jessie/armh ... f/download

But it doesn't work... :-( (library problems..)

fruitoftheloom
Posts: 22091
Joined: Tue Mar 25, 2014 12:40 pm
Location: Delightful Dorset

Re: wkhtmltoimage compiling

Mon Jun 15, 2015 11:25 am

Giuliano69 wrote:Hi,
I have the same problem with and installation of Odoo server over Rasberry 2.0.

The wkhtmltopdf library required is 12.1, but we can provide onli 0,9 in Raspian.
Is there a way to get the newer version on Raspberry, or to compile it ?

I tried to install the deb package from
https://packages.debian.org/jessie/armh ... f/download

But it doesn't work... :-( (library problems..)
Raspbian Jessie has wkhtmltopdf 0.12.1-2
Retired disgracefully.....
......to an uncomplicated life !

Rather than negativity think outside the box !

Giuliano69
Posts: 9
Joined: Fri Jul 19, 2013 9:10 am

Re: wkhtmltoimage compiling

Tue Jun 16, 2015 10:18 pm

Thanks for your reply
As far as I know, Jessie is in testing phase and there are no binary images for it.

Does it mean that a dist-upgrade will lead to an unstable system ?

BR

User avatar
kusti8
Posts: 3439
Joined: Sat Dec 21, 2013 5:29 pm
Location: USA

Re: wkhtmltoimage compiling

Tue Jun 16, 2015 10:21 pm

Jessie is in testing. There have been some cases of a messed up install because of a upgrade (happened to me once and while back), but just back up your card and try it. But if you don't like testing software, then you're out of options. Currently, its not 100% stable.
There are 10 types of people: those who understand binary and those who don't.

Giuliano69
Posts: 9
Joined: Fri Jul 19, 2013 9:10 am

Re: wkhtmltoimage compiling

Sat Jun 27, 2015 12:15 pm

Thanks for you help
Tested Jessie 8 and wkhtml.
Got following errors

Code: Select all

Errore Wkhtmltopdf (codice errore: -6). Messaggio: The switch --header-spacing, is not support using unpatched qt, and will be ignored.The switch --header-html, is not support using unpatched qt, and will be ignored.The switch...
Where can I ask for correction in final release ?

Return to “General programming discussion”