User avatar
duberry
Posts: 379
Joined: Mon Jan 28, 2013 10:44 pm
Location: standing on a planet that's evolving. And revolving at nine hundred miles an hour

Re: Which Language to Learn?

Mon Nov 18, 2013 12:07 pm

Do take your pick
Learn X in Y minutes - http://learnxinyminutes.com/
lend me your arms, fast as thunderbolts, for a pillow on my journey.
If the environment was a bank, would it be too big to fail
so long; and thanks for all the pi

User avatar
DeeJay
Posts: 2027
Joined: Tue Jan 01, 2013 9:33 pm
Location: East Midlands, UK

Re: Which Language to Learn?

Mon Nov 18, 2013 12:24 pm

duberry wrote:what is displayed
when starting "drracket"
with in terminal ?
DeeJay wrote: if I tried to run 'drracket' (which is the recommended IDE, and is started from the link newly-installed on the Start menu) that it generated a Segmentation Fault and exited.

Code: Select all

pi@raspberrypi ~ $ racket --version
Welcome to Racket v5.2.1.
pi@raspberrypi ~ $ drracket --version
Seg fault (internal error) at 0x1142398
SIGSEGV SEGV_ACCERR SI_CODE 2 fault on 0x1142398
Aborted
pi@raspberrypi ~ $ uname -a
Linux raspberrypi 3.6.11+ #538 PREEMPT Fri Aug 30 20:42:08 BST 2013 armv6l GNU/Linux
pi@raspberrypi ~ $
(Same result if I simply run 'drracket')

This is via an ssh session from a WinXP machine. X-forwarding is set, and Xming is running as the Xserver on the PC. Invoking IDLE from the same bash shell correctly displays the basic idle ide window on the PC, so I'm confident the X-windows support between RPi and WinXP is functional.

[I don't have any personal requirement to run Racket or its IDE, I'm just helping with debugging information.]
How To Ask Questions The Smart Way: http://www.catb.org/~esr/faqs/smart-questions.html
How to Report Bugs Effectively: http://www.chiark.greenend.org.uk/~sgtatham/bugs.html

User avatar
joan
Posts: 15382
Joined: Thu Jul 05, 2012 5:09 pm
Location: UK

Re: Which Language to Learn?

Mon Nov 18, 2013 12:54 pm

The Debian version (5.3.4) runs but is painfully slow at starting (think 10 minutes). That's using
drracket on the Pi with X forwarded to an SSH session on my laptop.
racket2.png
racket2.png (48.13 KiB) Viewed 1558 times
racket1.png
racket1.png (46.39 KiB) Viewed 1558 times

milkybar_ton
Posts: 26
Joined: Fri Nov 30, 2012 8:25 pm

Re: Which Language to Learn?

Thu Nov 21, 2013 1:06 pm

i'm quite happy just using the leafpad text editor that comes with Occidentals for the time being but for the record.
If i type in racket in the terminal screen i can enter (if thats the correct term?) the language in the same way if i was to enter clisp (i have also installed common lisp)
next if i enter (exit) it take sme back to the pi@raspberrypi ~$ promt

if i try to enter drracket which i guess should start the complete IDE then i get
Seg fault (internal error) at 0x17793b0
SIGSEGV SEGV_ACCERR SI_CODE 2 fault on 0x17793b0
Aborted

Like i said it's not a problem (for now anyway)
thanks for the help

Return to “General programming discussion”