User avatar
sayhello
Posts: 88
Joined: Sat Mar 05, 2016 1:02 pm

the Visual Studio Code - i want to get it to work with the RaspBerry Pi

Wed Sep 18, 2019 3:12 pm

Dear Community,


the Visual Studio Code - i want to get it to work with the RaspBerry Pi

which extensions do i need to add?

The whole design of Visual Studio Code is so that it should be easily be configured for any development language using these extensions. Do i need to install the Arduino IDE? if i am able to go roound the Arduino IDE - i would be happy.
Like most of the IDE's I have tried, they rely on the Arduino IDE for all the libraries. - but if i am able to work with VS-Stidio-Code and Raspberry Pi directly i would be happy.

how to set it up and to make sure that i have fully configured Visual Studio Code to work with all the necessary add-on for ESP8266

which extensions i should add and install?



note: i am on Windows 7

Heater
Posts: 13611
Joined: Tue Jul 17, 2012 3:02 pm

Re: the Visual Studio Code - i want to get it to work with the RaspBerry Pi

Wed Sep 18, 2019 3:42 pm

This is a Raspberry Pi forum. Not an Arduino or ESP8266 or Windows 7 forum.

Personally I would not use VS Code for the Arduino. I would use the Arduino IDE. How simple could it be?
Memory in C++ is a leaky abstraction .

royhenderson
Posts: 55
Joined: Sat Apr 09, 2016 1:56 pm
Location: Scotland

Re: the Visual Studio Code - i want to get it to work with the RaspBerry Pi

Thu Sep 19, 2019 11:08 am

VS Code supports remote development although at this time you might still need to use the Insider version. I use it on my Mac to work on an RPi-4 and the results are pretty good. You may need to install the remote extensions, then setup ssh to the Pi and you should be ready to edit directly on the Pi with transparent connection.

DirkS
Posts: 9964
Joined: Tue Jun 19, 2012 9:46 pm
Location: Essex, UK

Re: the Visual Studio Code - i want to get it to work with the RaspBerry Pi

Thu Sep 19, 2019 11:29 am

royhenderson wrote:
Thu Sep 19, 2019 11:08 am
VS Code supports remote development although at this time you might still need to use the Insider version.
Apparently only necessary for 64-bit target environment
https://code.visualstudio.com/docs/remo ... ng-started

Return to “General programming discussion”