yash.ranadive
Posts: 2
Joined: Tue Jul 10, 2012 6:31 am

Emulator for Mac

Tue Jul 10, 2012 6:36 am

Sorry for asking a n00b question but what is the best way to set up an emulator for Debian/other OS to emulate hardware of Raspberry Pi on a Mac. I'm running Snow Leopard. I tried to follow the instructions at http://igor.gold.ac.uk/~mas01mjy/wp/?p=95 but the QEMU hangs on me.

Any help would be appreciated

gazmandev
Posts: 12
Joined: Wed Jul 11, 2012 10:12 am

Re: Emulator for Mac

Wed Jul 11, 2012 10:16 am

I've got the same problem. I start qemu-system-arm and all I get is a white screen, the magic beachball and that's it until I go all Darth Vader and force kill the whole thing. I've tried various different images, QEMU options. I even got one up and running under windows, copied it back and same result - white screen, beachball, Sith Lord. I have tried downloading and running Q to try and get it going. All to no avail.

Any suggestions would be greatly appreciated.

Thanks
Gareth

gazmandev
Posts: 12
Joined: Wed Jul 11, 2012 10:12 am

Re: Emulator for Mac

Wed Jul 11, 2012 10:23 am

In addition to my previous reply, I am running an up to date MBP/OSX10.7.4 with QEMU installed from Macports as described in the OP weblink.

kentaroyamada
Posts: 6
Joined: Mon Jun 25, 2012 11:39 am

Re: Emulator for Mac

Thu Jul 12, 2012 11:05 am

I too have exactly same problem.. sorry I am not helping..

kryounger
Posts: 4
Joined: Fri Jul 13, 2012 10:04 pm

Re: Emulator for Mac

Fri Jul 13, 2012 10:10 pm

use virtualbox

it's free and can boot most of the Pi images

yash.ranadive
Posts: 2
Joined: Tue Jul 10, 2012 6:31 am

Re: Emulator for Mac

Sat Jul 14, 2012 1:26 am

kryounger, will virtual box mimic the hardware on the Pi? I run a fast mac and want to make sure the dev I do on the virtual box will be replicated speed-wise on the Raspberry Pi.

Towabohu
Posts: 1
Joined: Wed Mar 19, 2014 7:34 am

Re: Emulator for Mac

Wed Mar 19, 2014 7:56 am

Moin, moin folks,

I have success with "QEMU emulator version 1.7.0, Copyright (c) 2003-2008 Fabrice Bellard" installed on Mac OS X 10.9.2 (Maverick) through http://www.macports.org/ (Version: 2.2.1).
I have tried the distribution which was coming with c't- Journal 7/2014 (http://www.heise.de/ct/heft/2014-7-Emul ... 35387.html). Unfortunately I don't know what "kernel-qemu" they used, but after unpacking the zip-Archive, changing in the directory the command line:
qemu-system-arm -kernel kernel-qemu -cpu arm1176 -m 256 -M versatilepb -append "root=/dev/sda2 panic=1" -hda 2013-12-20-wheezy-raspbian.img -redir tcp:2222::22
starts a RaspberryPi with redirected ssh port.

Good luck

nerfacow
Posts: 1
Joined: Sat Mar 19, 2016 9:14 am

Re: Emulator for Mac

Sat Mar 19, 2016 9:19 am

Sorry for necro-posting, but for future readers; Search sourceforge (an awesome open-source blob), or even YouTube.
SourceForge: https://sourceforge.net/directory/?q=Qemu+raspberry+Pi
(wasn't that hard...)

Return to “General programming discussion”

Who is online

Users browsing this forum: No registered users and 4 guests