Mag748
Posts: 2
Joined: Wed Oct 11, 2017 7:14 pm

[Solved] Processing - Raspbian Lite with Hyperpixel

Wed Oct 11, 2017 7:46 pm

Hello,

I have developed a simple Processing sketch on my windows machine. It runs great. I would like to run this sketch on my Raspberry Pi 3 with the Pimoroni Hyperpixel (https://shop.pimoroni.com/products/hyperpixel). I have configured the Hyperpixel without issue, and can run some X11 applications on it. I've installed Processing according to the documentation here: https://www.raspberrypi.org/blog/now-av ... rocessing/

When I try and run the sketch on the Pi, it just crashes. There are no error messages or anything. I have attached my .xinitrc script for your reference. (I have to zip it because the forum would not allow me to attached any other type of file.) The program seems to crash at "exec processing". As a test, I've tried the line "exec $(which xterm)" and that successfully launches xterm, so I know my X Server is operational.

Has anyone had any luck with this? Any suggestions would be appreciated.

Thanks,
Marcus
Attachments
dot_xinitrc.zip
(969 Bytes) Downloaded 5 times
Last edited by Mag748 on Thu Oct 12, 2017 11:45 pm, edited 1 time in total.

Mag748
Posts: 2
Joined: Wed Oct 11, 2017 7:14 pm

Re: Processing - Raspbian Lite with Hyperpixel

Thu Oct 12, 2017 11:45 pm

Problem solved:

The solution is to run "processing-java" instead of "processing". So the line in .xinitrc was changed to the following:

exec processing-java --sketch=/home/pi/processing/Client_API_Test_2017_10_12b --present

I had to change the backslashes in the program to forward slashes, but not a big deal. Also, library files need to be added to the ~/sketchbook/libraries folder.

See below image of the sketch running on the RPi with Hyperpixel.
IMG_0210 (Large).JPG
IMG_0210 (Large).JPG (243.5 KiB) Viewed 196 times
Thanks,
Marcus

Return to “General programming discussion”

Who is online

Users browsing this forum: No registered users and 9 guests