Scratch & Squeak

3 posts
by ren41 » Mon Jun 25, 2012 10:50 pm
Tonight I thought I'd take a look at Scratch & Squeak.

there are problems with both. I'm running Squeeze 19/4 with fxce4 as the GUI.

Squeak: selecting Squeak from the drop down menu brings up a dialogue which says there are several Squeak images, please select one. In fact there are no candidates to select from.
sudo apt-get install squeak gives me - unable to locate package Squeak.

Scratch: selecting from the drop down menu gives me a terminal type window. Briefly you see the Scratch name on the left of the screen header and then it becomes a normal header window. The screen perpetually refreshes, moving slightly across the desktop as it does so.
sudo apt-get install scratch returns - not available but referenced by another candidate. Package scratch has no installation candidate.

Neither appear in Synaptic.

Has anyone else encountered problems?

Posts: 99
Joined: Sat May 26, 2012 8:00 pm
by mlk » Fri Jun 29, 2012 10:04 am
Squeak - I got the same dialog. Clicked "OK" and it all worked fine. Not tried Scratch yet.
Posts: 3
Joined: Sun Aug 28, 2011 9:02 pm
by ren41 » Fri Jun 29, 2012 10:22 am
I followed this post and reinstalled squeak, which seems to work OK.

Following an RPi-update I now get the Scratch windows for about 4 seconds - then it becomes a plain black windows with Scratch.[version number, can't remember it].image on the header. This flickers and redraws itself once a second, moving slightly across the screen each time. Deeply unpleasant!

I checked the Scratch website and the only Linux version seems to be for i386 architecture so I assume the one included with the Squeeze release is specially ported.

Posts: 99
Joined: Sat May 26, 2012 8:00 pm