Help with Quanta Touch Touchscreen

10 posts
by baz4096 » Fri Jun 22, 2012 9:12 am
Hey everyone

I've been beating my head against a wall trying to get my new Iiyama ProLite T2250MTS touchscreen working in Debian/LXDE - without a great deal of success...

It enumerates as 0408:3001 Quanta Touchscreen and loads the kernel modules hid_quanta but I'm unable to get any input recognised in X or otherwise. Most of the tutorials/examples out there for Debian and Ubuntu don't seem to cut it.

I've had more success with the Wheezy beta, but I have a feeling I'm missing the hidraw module and I'm just not confident enough to recompile the kernal to include it.

Has anyone out there had any luck getting a Quanta touchscreen working under Debian? Or more specifically on the Pi?

Any advice welcome :-)
Posts: 6
Joined: Fri Apr 13, 2012 2:16 pm
by AndrewS » Fri Jun 22, 2012 10:01 am
I can't really help, other than to say there seems to be a quite comprehensive kernel compilation guide on the wiki
User avatar
Posts: 3625
Joined: Sun Apr 22, 2012 4:50 pm
Location: Cambridge, UK
by kingrolo » Mon Jun 25, 2012 10:02 am
Yeh you need to compile a kernel to get hidraw. I followed this howto and it worked like a charm.

I need hidraw for talking to a homemade USB device.
Posts: 2
Joined: Mon Jun 25, 2012 9:59 am
by dega » Sun Nov 25, 2012 9:46 pm
Hi all,
I am trying to use a Quanta touch screen too,
I have the latest wheezy firmware (2012-10-28-wheezy), and I am developing an interface using QT 5.
The kernel recognizes the touch screen:
[ 3.894495] usb 1-1.3: new full-speed USB device number 5 using dwc_otg
[ 4.183387] usb 1-1.3: New USB device found, idVendor=0408, idProduct=3001
[ 4.214240] usb 1-1.3: New USB device strings: Mfr=1, Product=2, SerialNumber=0
[ 4.246776] usb 1-1.3: Product: OpticalTouchScreen
[ 4.273118] usb 1-1.3: Manufacturer: QUANTA

but when I am running either X or a Qt program, there is no movement whatsoever.
I tried xinput_calibrator as well, but it can't detect the touch screen.
This is what I am getting when launching the Qt program, with the touch screen conncted:
evdevtouch: Using device /dev/input/event2
min X: 0 max X: 1920
min Y: 0 max Y: 1080
min pressure: 0 max pressure: 0
device name: QUANTA OpticalTouchScreen
Protocol type B
QGridLayout: Multi-cell fromCol greater than toCol
QGridLayout: Multi-cell fromCol greater than toCol

Am I missing something important?
I recompiled the kernel as well, enabling hidraw and all the USB touch screen drivers I could find.

Posts: 8
Joined: Wed Mar 07, 2012 4:44 pm
by dega » Mon Dec 03, 2012 2:24 pm
I got it working,
I started again from a fresh wheezy image and got it working recompiling the kernel adding hidraw
Posts: 8
Joined: Wed Mar 07, 2012 4:44 pm
by zarexogre » Fri Apr 05, 2013 3:23 pm
I have a quanta touch screen device, it doesnt work with rasp pi, latest weezy image. I get this if I do lsusb:
Bus 001 Device 002: ID 0424:9512 Standard Microsystems Corp.
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 001 Device 003: ID 0424:ec00 Standard Microsystems Corp.
Bus 001 Device 004: ID 0408:3001 Quanta Computer, Inc. Optical Touch Screen
So its def aware the device is there. I think I need to recompile the kernel with hidraw support I think i can recompile the kernel but not sure how to also incude hidraw support. Ideally I would love and raspbian image with hidraw, if anyone has one I would be happy to host. If not if you could possibly break down the steps or at least how to enable hidraw using menu config while recompiling kernel. Really suprise this isnt just supported? Thanks for any help been googling for hours.
Posts: 1
Joined: Fri Mar 22, 2013 7:17 am
by DaveDriesen » Mon May 06, 2013 12:20 pm

You need to also make sure xorg understands your device.
Hence, do not forget to install xorg's multitouch driver (xserver-xorg-input-multitouch)

Code: Select all
sudo apt-get install xserver-xorg-input-multitouch

This driver is not installed by default.

Also, if your screen is showing black borders, you will need to get rid of them, or your touch coordinates won't match xorg's display. This is done by disabling overscan, a simple tweak mentioned in various posts.

Modify the following in /boot/config.txt
Code: Select all

Tested and working with Iiyama ProLite T2250MTS (identical to the OP's display).

Dave Driesen
Linux dev and oldskool elite
User avatar
Posts: 112
Joined: Sun Mar 31, 2013 8:28 pm
Location: Top of the food chain
by baz4096 » Fri May 17, 2013 6:16 am

It's worth mentioning that many of my apparent problems with this screen were caused by it drawing too much power from USB (in addition to installing the relevant drivers). Once I plugged my screen into a powered USB hub, it worked straight away. I had this problem with a very early Pi (first 10,000) and also a slightly more recent 256mb Pi. I've not tried the monitor directly with my newest 512mb model.

Posts: 6
Joined: Fri Apr 13, 2012 2:16 pm
by MasterBT » Sat May 25, 2013 12:29 pm
i've plug a Prolite T2250MTS into a RaspBmc,
I've calibrate, then the cursor follow nice but hard to click. Need to touch 3 or 4x really fast to have a little chance that work.

Can we parametre the sensibility? Or any other tips.
Posts: 1
Joined: Sat May 25, 2013 12:25 pm
by joemanu » Tue May 28, 2013 8:02 pm
Hello MasterBT,
could you share how you calibrate your touch screen?

Posts: 1
Joined: Tue May 28, 2013 7:59 pm