Dual-booting the Raspberry Pi with custom OS

1 post
by tasoulis12 » Tue Oct 22, 2013 12:07 pm
Hello board,
I am new here, but I thought I'd post this in the Advanced section, because I've made two threads about this on 4chan's /g/ - technology board - and still we haven't found any solution for it .

I have a Raspberry Pi, which I want to use as both a multimedia station and a Retro console mutli-emulator which accepts controllers. In other words, I want to dual boot both Debian (Raspbian) and EmulationStation from the same SD card (16 Gigabytes - Class 4 {Does the class of the SD card give any real benefits when used with the Raspberry Pi?}).

I found a way to do this, with a software that's called BerryBoot. You boot from it and it, normally, downloads the OS's you select from the internet, partitions the SD card and installs them - but in my case, EmulationStation is a custom OS and not included, so I have to import it's image from a USB stick, along with the image of Debian.

Problem is, BerryBoot wants the images in SquashFS format, and the only way to do this is with a Linux OS. So, I installed Mint Linux in Virtual Box on my PC to do that. I have to say I am not very used to Linux (Although I'm learning) and I struggled a bit to install SquashFS, but finally did it.

Now, SquashFS needs a compressor called LZO to compress the images, and whatever I do wont get LZO to work with SquashFS.

>I know there is the option to use Gzip for compression, but this will make the OS's slower, which will have an impact at the already slow Raspberry Pi.

>I also know that it is stated that LZO is not supported in older versions of SquashFS, but I have the newest version: 4.2
(doublechecked with: mksquashfs -version)

>I have read the makefile about Building LZO support Support - I have downloaded the LZO library from the link given there, I uncommented the LZO_SUPPORT line and I also set LZO_DIR for the default LZO_DIR= /usr/local to the folder of LZO which is: /home/riel/Desktop/lzo-2.06
I also tried to run it with the LZO_DIR line commented. Still, it is telling me that LZO in not supported.

>Inbetween doing "make" and "make install" (either the Squashfs-tools or LZO) I always do "make check" and all checks are passed.

Update: I tried rebuilding once again LZO with "sudo make install" while monitoring the /usr/local/bin folder - and no new files appeared there... Maybe that has something to do with it. I'd like to uninstall everything squashfs and LZO from the virtual machine and re-attempt to do it fresh, but "make uninstall" "make remove" "make clean" wont work - it tells me the makefile doesn't have instructions to uninstall or remove the target.

I will also dumping some images with stuff that I tried. I am really stuck and don't know why this is happening, so any help would be appreciated.


Thanks in advance! ^_^
Last edited by tasoulis12 on Wed Oct 23, 2013 3:17 pm, edited 1 time in total.
Posts: 2
Joined: Tue Oct 22, 2013 11:42 am