wpballa1
Posts: 70
Joined: Sat Jun 27, 2015 12:49 am

[SOLVED] HPLIP for Buster

Sat Nov 16, 2019 6:55 pm

Has anyone succeeded in getting HPLIP working in Buster? Their standard install fails, I think because of some slight differences in names of modules in the QT4 and QT5 series. The current version of HPLIP claims not to support Debian 10.1, only 10.0, but it didn't work even when we were at version 10.0. I tried their automatic installation and building manually, but neither worked properly.

No HP printer support for Buster is a real utility killer for me.
Last edited by wpballa1 on Mon Nov 18, 2019 5:22 pm, edited 1 time in total.

fruitoftheloom
Posts: 23119
Joined: Tue Mar 25, 2014 12:40 pm
Location: Delightful Dorset

Re: HPLIP for Buster

Sat Nov 16, 2019 7:34 pm

wpballa1 wrote:
Sat Nov 16, 2019 6:55 pm
Has anyone succeeded in getting HPLIP working in Buster? Their standard install fails, I think because of some slight differences in names of modules in the QT4 and QT5 series. The current version of HPLIP claims not to support Debian 10.1, only 10.0, but it didn't work even when we were at version 10.0. I tried their automatic installation and building manually, but neither worked properly.

No HP printer support for Buster is a real utility killer for me.

Always best to install from repositories version 3.18.12.....

Code: Select all

sudo apt update
sudo apt install hplip cups system-config-printer

Yes I have a HP Envy 450O series printer !
Rather than negativity think outside the box !
RPi 4B 4GB (SSD Boot)..
Asus ChromeBox 3 Celeron is my other computer...

User avatar
scruss
Posts: 3154
Joined: Sat Jun 09, 2012 12:25 pm
Location: Toronto, ON
Contact: Website

Re: HPLIP for Buster

Sat Nov 16, 2019 9:55 pm

wpballa1 wrote:
Sat Nov 16, 2019 6:55 pm
No HP printer support for Buster is a real utility killer for me.
There's also a really good chance that your modern HP printer supports IPP. That only covers the printing side, but it's a start and needs minimal drivers.
‘Remember the Golden Rule of Selling: “Do not resort to violence.”’ — McGlashan.
Pronouns: he/him

wpballa1
Posts: 70
Joined: Sat Jun 27, 2015 12:49 am

Re: HPLIP for Buster

Sat Nov 16, 2019 11:05 pm

That worked great, though installing via the add/remove programs applet did not, nor did a direct install via the HPLIP website.

Thanks!

maxmars
Posts: 7
Joined: Mon Dec 09, 2019 11:46 am

Re: [SOLVED] HPLIP for Buster

Mon Dec 09, 2019 11:53 am

Does this apply to the RPI 4B as well?
Thanks

fruitoftheloom
Posts: 23119
Joined: Tue Mar 25, 2014 12:40 pm
Location: Delightful Dorset

Re: [SOLVED] HPLIP for Buster

Mon Dec 09, 2019 12:40 pm

maxmars wrote:
Mon Dec 09, 2019 11:53 am
Does this apply to the RPI 4B as well?
Thanks

My post above applies to Raspbian Operating System with Desktop running on any Raspberry Pi SBC.

Though always undertake a full update of Raspbian first:

Code: Select all

sudo apt update
sudo apt full-upgrade
sudo reboot

You should have hplip version 3.18.12 from Raspbian Buster repositories
Rather than negativity think outside the box !
RPi 4B 4GB (SSD Boot)..
Asus ChromeBox 3 Celeron is my other computer...

maxmars
Posts: 7
Joined: Mon Dec 09, 2019 11:46 am

Re: [SOLVED] HPLIP for Buster

Mon Dec 09, 2019 4:41 pm

Thank you very much!

Return to “Advanced users”