gubertoli
Posts: 4
Joined: Sun Jul 07, 2019 2:44 pm

Re: Pi4 64-bit raspbian kernel for testing - Focus on Pi4

Sat Oct 19, 2019 6:10 am

Kendek wrote:
Fri Oct 18, 2019 7:31 am

Compile 64-bit kernel on Raspbian:

Prepare for compilation:

Compile and install the kernel:
Followed the instructions but after reboot...
mice, keyboard, wireless adapter and sound is not working, so I got a freeze Desktop :cry:

Comments to the instructions: mount required sudo to successfully be performed.

Kendek
Posts: 265
Joined: Thu Jul 25, 2019 4:39 pm
Location: Kaposvár, Hungary

Re: Pi4 64-bit raspbian kernel for testing - Focus on Pi4

Sat Oct 19, 2019 8:50 am

hawk_ing wrote:
Sat Oct 19, 2019 5:37 am

Code: Select all

pi@rpi:~ $ sudo dpkg --add-architecture aarch64
pkg-config-dpkghook: Warning: Architecture aarch64 not defined in architecture tables, ignored

Code: Select all

sudo dpkg --add-architecture arm64
But there are no arm64 packages in the Raspbian repository. So the libc6 and other arm64 libraries cannot be installed.

ShiftPlusOne
Raspberry Pi Engineer & Forum Moderator
Raspberry Pi Engineer & Forum Moderator
Posts: 6258
Joined: Fri Jul 29, 2011 5:36 pm
Location: The unfashionable end of the western spiral arm of the Galaxy

Re: Pi4 64-bit raspbian kernel for testing - Focus on Pi4

Sat Oct 19, 2019 10:44 am


Kendek
Posts: 265
Joined: Thu Jul 25, 2019 4:39 pm
Location: Kaposvár, Hungary

Re: Pi4 64-bit raspbian kernel for testing - Focus on Pi4

Sat Oct 19, 2019 11:29 am

gubertoli wrote:
Sat Oct 19, 2019 6:10 am
Followed the instructions but after reboot...
mice, keyboard, wireless adapter and sound is not working, so I got a freeze Desktop :cry:
Yeah, sorry. I just edited my post, added some missed commands and package. Please try again, this time I tested it. :)

incognitum
Posts: 574
Joined: Tue Oct 30, 2018 3:34 pm

Re: Pi4 64-bit raspbian kernel for testing - Focus on Pi4

Sat Oct 19, 2019 12:00 pm

Seems something up with USB when running 64-bit kernel on model 3B+


If I attach Pi Zero and rpiboot gpioexpander image, rpiboot does complete, but gadget Ethernet network interface never shows up afterwards.

Code: Select all

pi@raspberrypi:~ $ uname -a
Linux raspberrypi 4.19.79-v8+ #1273 SMP PREEMPT Fri Oct 11 18:35:44 BST 2019 aarch64 GNU/Linux
pi@raspberrypi:~ $ sudo rpiboot -d /usr/share/rpiboot/gpioexpand/
Waiting for BCM2835/6/7
Sending bootcode.bin
Successful read 4 bytes 
Waiting for BCM2835/6/7
Second stage boot server
File read: config.txt
File read: start.elf
File read: fixup.dat
File read: config.txt
File read: config.txt
File read: kernel.img
File read: gpioexpand.img
File read: bcm2708-rpi-0-w.dtb
File read: config.txt
File read: overlays/dwc2.dtbo
Second stage boot server done
Last dmesg:

Code: Select all

[   26.492449] usb 1-1.1.2: USB disconnect, device number 8
[   27.739472] usb 1-1.1.2: new full-speed USB device number 9 using dwc_otg
[   27.842888] usb 1-1.1.2: not running at top speed; connect to a high speed hub
[   27.853405] usb 1-1.1.2: New USB device found, idVendor=0a5c, idProduct=2764, bcdDevice= 0.00
[   27.853431] usb 1-1.1.2: New USB device strings: Mfr=1, Product=2, SerialNumber=1
[   27.853447] usb 1-1.1.2: Product: BCM2710 Boot
[   27.853463] usb 1-1.1.2: Manufacturer: Broadcom
[   27.853478] usb 1-1.1.2: SerialNumber: Broadcom
With 32-bit kernel on same device it does work properly.

Code: Select all

[  120.047007] usb 1-1.1.2: USB disconnect, device number 8
[  121.367750] usb 1-1.1.2: new full-speed USB device number 9 using dwc_otg
[  121.501086] usb 1-1.1.2: not running at top speed; connect to a high speed hub
[  121.511088] usb 1-1.1.2: New USB device found, idVendor=0a5c, idProduct=2764, bcdDevice= 0.00
[  121.511106] usb 1-1.1.2: New USB device strings: Mfr=1, Product=2, SerialNumber=1
[  121.511116] usb 1-1.1.2: Product: BCM2710 Boot
[  121.511127] usb 1-1.1.2: Manufacturer: Broadcom
[  121.511136] usb 1-1.1.2: SerialNumber: Broadcom
[  137.711014] usb 1-1.1.2: USB disconnect, device number 9
[  139.027527] usb 1-1.1.2: new high-speed USB device number 10 using dwc_otg
[  139.158657] usb 1-1.1.2: New USB device found, idVendor=f055, idProduct=0001, bcdDevice= 4.04
[  139.158677] usb 1-1.1.2: New USB device strings: Mfr=1, Product=2, SerialNumber=3
[  139.158686] usb 1-1.1.2: Product: Pi Zero - GPIO expansion board
[  139.158695] usb 1-1.1.2: Manufacturer: Raspberry Pi
[  139.158706] usb 1-1.1.2: SerialNumber: 000000006099b31e
[  139.223038] cdc_acm 1-1.1.2:1.0: ttyACM0: USB ACM device
[  139.223946] usbcore: registered new interface driver cdc_acm
[  139.223959] cdc_acm: USB Abstract Control Model driver for USB modems and ISDN adapters
[  139.232433] cdc_ether 1-1.1.2:1.2 usb0: register 'cdc_ether' at usb-3f980000.usb-1.1.2, CDC Ethernet Device, fa:00:60:99:b3:1e
[  139.233605] usbcore: registered new interface driver cdc_ether
Just Pi 3+ with 64-bit kernel that has this problem, so probably specific to dwc module.
Pi 4 with 64-bit kernel does work properly.

leggazoid
Posts: 35
Joined: Sun Apr 07, 2013 6:58 pm

Re: Pi4 64-bit raspbian kernel for testing - Focus on Pi4

Sun Oct 20, 2019 3:54 pm

I noticed some apps don't work with 64-bit kernel.

Sonic-Pi
Minecraft-Pi (It quit working on 32-bit as well)

I realize this is a test and not meant for everyone.

gubertoli
Posts: 4
Joined: Sun Jul 07, 2019 2:44 pm

Re: Pi4 64-bit raspbian kernel for testing - Focus on Pi4

Mon Oct 21, 2019 5:48 am

Kendek wrote:
Sat Oct 19, 2019 11:29 am

Yeah, sorry. I just edited my post, added some missed commands and package. Please try again, this time I tested it. :)
The build was fine... I was able to use the Raspbian.

I just had bad times to compile kernel modules once source and build folders on /lib/modules/4.19.79-v8 are not correctly linked.

Once I still require a functional 64-bit OS to work with eBPF and this approach did not worked, I decided to give a try to Ubuntu 19.10 (now with 64-bit support for RPi).

@Kendek, thank you so much! I learned a lot with these attempts.

Kendek
Posts: 265
Joined: Thu Jul 25, 2019 4:39 pm
Location: Kaposvár, Hungary

Re: Pi4 64-bit raspbian kernel for testing - Focus on Pi4

Mon Oct 21, 2019 7:56 am

gubertoli wrote:
Mon Oct 21, 2019 5:48 am
I just had bad times to compile kernel modules once source and build folders on /lib/modules/4.19.79-v8 are not correctly linked.
Modules also can only be compiled within Ubuntu chroot. Just keep the ubuntu64 directory. :)

gishten
Posts: 3
Joined: Sun Oct 20, 2019 12:06 pm

Re: Pi4 64-bit raspbian kernel for testing - Focus on Pi4

Tue Oct 22, 2019 2:04 pm

I'm having trouble running rtorrent 0.9.7 on this kernel. It crashes intermittently, though never running longer than ~4 hours.

Code: Select all

Caught SIGBUS, dumping stack:
rtorrent() [0x1ed84]
/lib/arm-linux-gnueabihf/libc.so.6(__default_rt_sa_restorer+0) [0xf75a3130]
/usr/lib/arm-linux-gnueabihf/libtorrent.so.20(+0xb9f9c) [0xf7a39f9c]
/usr/lib/arm-linux-gnueabihf/libtorrent.so.20(_ZN7torrent9PollEPoll7performEv+0xdc) [0xf79af4e8]
/usr/lib/arm-linux-gnueabihf/libtorrent.so.20(_ZN7torrent9PollEPoll7do_pollExi+0xa8) [0xf79af69c]
/usr/lib/arm-linux-gnueabihf/libtorrent.so.20(_ZN7torrent11thread_base10event_loopEPS0_+0x17c) [0xf79e8b7c]
rtorrent() [0x1d8f4]
/lib/arm-linux-gnueabihf/libc.so.6(__libc_start_main+0x10c) [0xf758d718]

Error: Success
Signal code '1': Invalid address alignment.
Fault address: 0xe8ad91
The fault address is not part of any chunk.
Aborted

k3lt
Posts: 23
Joined: Sat Jul 07, 2018 4:42 pm
Location: Kraków, Poland

Re: Pi4 64-bit raspbian kernel for testing - Focus on Pi4

Mon Oct 28, 2019 9:32 pm

On Raspberry pi3b+ is booting into blank screen, but i can connect with SSH. Any suggestions?

Code: Select all

uname -a
Linux raspberrypi 4.19.80-v8+ #1274 SMP PREEMPT Mon Oct 21 16:45:40 BST 2019 aarch64 GNU/Linux
My /boot/config.txt

Code: Select all

# For more options and information see
# http://rpf.io/configtxt
# Some settings may impact device functionality. See link above for details

# uncomment if you get no picture on HDMI for a default "safe" mode
#hdmi_safe=1

# uncomment this if your display has a black border of unused pixels visible
# and your display can output without overscan
disable_overscan=1

# uncomment the following to adjust overscan. Use positive numbers if console
# goes off screen, and negative if there is too much border
#overscan_left=16
#overscan_right=16
#overscan_top=16
#overscan_bottom=16

# uncomment to force a console size. By default it will be display's size minus
# overscan.
#framebuffer_width=1280
#framebuffer_height=720

# uncomment if hdmi display is not detected and composite is being output
#hdmi_force_hotplug=1

# uncomment to force a specific HDMI mode (this will force VGA)
#hdmi_group=1
#hdmi_mode=1

# uncomment to force a HDMI mode rather than DVI. This can make audio work in
# DMT (computer monitor) modes
#hdmi_drive=2

# uncomment to increase signal to HDMI, if you have interference, blanking, or
# no display
config_hdmi_boost=4

# uncomment for composite PAL
#sdtv_mode=2

#uncomment to overclock the arm. 700 MHz is the default.
#arm_freq=800

# Uncomment some or all of these to enable the optional hardware interfaces
#dtparam=i2c_arm=on
#dtparam=i2s=on
#dtparam=spi=on

# Uncomment this to enable infrared communication.
#dtoverlay=gpio-ir,gpio_pin=17
#dtoverlay=gpio-ir-tx,gpio_pin=18

# Additional overlays and parameters are documented /boot/overlays/README

# Enable audio (loads snd_bcm2835)
dtparam=audio=on

[pi4]
# Enable DRM VC4 V3D driver on top of the dispmanx display stack
dtoverlay=vc4-fkms-v3d
max_framebuffers=2

[all]
#dtoverlay=vc4-fkms-v3d
arm_64bit=1

User avatar
dickon
Posts: 1796
Joined: Sun Dec 09, 2012 3:54 pm
Location: Home, just outside Reading

Re: Pi4 64-bit raspbian kernel for testing - Focus on Pi4

Mon Oct 28, 2019 9:41 pm

k3lt wrote:
Mon Oct 28, 2019 9:32 pm

Code: Select all

# uncomment if you get no picture on HDMI for a default "safe" mode
#hdmi_safe=1
Tried that? Why not?

k3lt
Posts: 23
Joined: Sat Jul 07, 2018 4:42 pm
Location: Kraków, Poland

Re: Pi4 64-bit raspbian kernel for testing - Focus on Pi4

Mon Oct 28, 2019 9:46 pm

dickon wrote:
Mon Oct 28, 2019 9:41 pm
k3lt wrote:
Mon Oct 28, 2019 9:32 pm

Code: Select all

# uncomment if you get no picture on HDMI for a default "safe" mode
#hdmi_safe=1
Tried that? Why not?
Yeah tried it, also config_hdmi_boost=4.. still blank screen unfortunately.
Is there something else i can try since i have SSH connection?

Edit:
I just tried switching to boot into CLI by default instead of Desktop in raspi-config and it works, CLI is displayed correctly.
startlxde-pi gives me following output:

Code: Select all

** Message: 22:56:55.001: main.vala:101: Session is LXDE-pi
** Message: 22:56:55.001: main.vala:102: DE is LXDE

(lxsession:602): Gtk-WARNING **: 22:56:55.113: cannot open display:
startx output:

Code: Select all

X.Org X Server 1.20.4
X Protocol Version 11, Revision 0
Build Operating System: Linux 4.15.0-48-generic armv8l Raspbian
Current Operating System: Linux raspberrypi 4.19.80-v8+ #1274 SMP PREEMPT Mon Oct 21 16:45:40 BST 2019 aarch64
Kernel command line: coherent_pool=1M 8250.nr_uarts=0 bcm2708_fb.fbwidth=1920 bcm2708_fb.fbheight=1080 bcm2708_fb.fbswap=1 vc_mem.mem_base=0x3ec00000 vc_mem.mem_size=0x40000000  console=ttyS0,115200 console=tty1 root=PARTUUID=5e3da3da-02 rootfstype=ext4 elevator=deadline fsck.repair=yes rootwait usbhid.mousepoll=0 quiet splash plymouth.ignore-serial-consoles
Build Date: 05 June 2019  12:49:54PM
xorg-server 2:1.20.4-1+rpt1 (https://www.debian.org/support)
Current version of pixman: 0.36.0
        Before reporting problems, check http://wiki.x.org
        to make sure that you have the latest version.
Markers: (--) probed, (**) from config file, (==) default setting,
        (++) from command line, (!!) notice, (II) informational,
        (WW) warning, (EE) error, (NI) not implemented, (??) unknown.
(==) Log file: "/home/pi/.local/share/xorg/Xorg.0.log", Time: Mon Oct 28 23:03:15 2019
(==) Using system config directory "/usr/share/X11/xorg.conf.d"
(EE)
Fatal server error:
(EE) parse_vt_settings: Cannot open /dev/tty0 (Permission denied)
(EE)
(EE)
Please consult the The X.Org Foundation support
         at http://wiki.x.org
 for help.
(EE) Please also check the log file at "/home/pi/.local/share/xorg/Xorg.0.log" for additional information.
(EE)
(EE) Server terminated with error (1). Closing log file.
xinit: giving up
xinit: unable to connect to X server: Connection refused
xinit: server error
cat /home/pi/.local/share/xorg/Xorg.0.log output:

Code: Select all

[   595.985]
X.Org X Server 1.20.4
X Protocol Version 11, Revision 0
[   595.985] Build Operating System: Linux 4.15.0-48-generic armv8l Raspbian
[   595.985] Current Operating System: Linux raspberrypi 4.19.80-v8+ #1274 SMP PREEMPT Mon Oct 21 16:45:40 BST 2019 aarch64
[   595.985] Kernel command line: coherent_pool=1M 8250.nr_uarts=0 bcm2708_fb.fbwidth=1920 bcm2708_fb.fbheight=1080 bcm2708_fb.fbswap=1 vc_mem.mem_base=0x3ec00000 vc_mem.mem_size=0x40000000  console=ttyS0,115200 console=tty1 root=PARTUUID=5e3da3da-02 rootfstype=ext4 elevator=deadline fsck.repair=yes rootwait usbhid.mousepoll=0 quiet splash plymouth.ignore-serial-consoles
[   595.985] Build Date: 05 June 2019  12:49:54PM
[   595.985] xorg-server 2:1.20.4-1+rpt1 (https://www.debian.org/support)
[   595.985] Current version of pixman: 0.36.0
[   595.985]    Before reporting problems, check http://wiki.x.org
        to make sure that you have the latest version.
[   595.985] Markers: (--) probed, (**) from config file, (==) default setting,
        (++) from command line, (!!) notice, (II) informational,
        (WW) warning, (EE) error, (NI) not implemented, (??) unknown.
[   595.986] (==) Log file: "/home/pi/.local/share/xorg/Xorg.0.log", Time: Mon Oct 28 23:03:15 2019
[   595.988] (==) Using system config directory "/usr/share/X11/xorg.conf.d"
[   595.990] (==) No Layout section.  Using the first Screen section.
[   595.990] (==) No screen section available. Using defaults.
[   595.990] (**) |-->Screen "Default Screen Section" (0)
[   595.990] (**) |   |-->Monitor "<default monitor>"
[   595.997] (==) No device specified for screen "Default Screen Section".
        Using the first device section listed.
[   595.997] (**) |   |-->Device "Allwinner A10/A13 FBDEV"
[   595.997] (==) No monitor specified for screen "Default Screen Section".
        Using a default monitor configuration.
[   595.997] (==) Automatically adding devices
[   595.997] (==) Automatically enabling devices
[   595.997] (==) Automatically adding GPU devices
[   595.997] (==) Max clients allowed: 256, resource mask: 0x1fffff
[   595.997] (WW) The directory "/usr/share/fonts/X11/misc" does not exist.
[   595.997]    Entry deleted from font path.
[   595.997] (WW) The directory "/usr/share/fonts/X11/cyrillic" does not exist.
[   595.997]    Entry deleted from font path.
[   595.998] (WW) The directory "/usr/share/fonts/X11/75dpi/" does not exist.
[   595.998]    Entry deleted from font path.
[   595.998] (WW) The directory "/usr/share/fonts/X11/Type1" does not exist.
[   595.998]    Entry deleted from font path.
[   595.998] (WW) The directory "/usr/share/fonts/X11/75dpi" does not exist.
[   595.998]    Entry deleted from font path.
[   595.998] (==) FontPath set to:
        /usr/share/fonts/X11/100dpi/:unscaled,
        /usr/share/fonts/X11/100dpi,
        built-ins
[   595.998] (==) ModulePath set to "/usr/lib/xorg/modules"
[   595.998] (II) The server relies on udev to provide the list of input devices.
        If no devices become available, reconfigure udev or disable AutoAddDevices.
[   595.998] (II) Loader magic: 0x1fcf80
[   595.998] (II) Module ABI versions:
[   595.998]    X.Org ANSI C Emulation: 0.4
[   595.998]    X.Org Video Driver: 24.0
[   595.998]    X.Org XInput driver : 24.1
[   595.998]    X.Org Server Extension : 10.0
[   596.005] (II) systemd-logind: took control of session /org/freedesktop/login1/session/c2
[   596.006] (II) no primary bus or device found
[   596.006] (II) LoadModule: "glx"
[   596.009] (II) Loading /usr/lib/xorg/modules/extensions/libglx.so
[   596.070] (II) Module glx: vendor="X.Org Foundation"
[   596.070]    compiled for 1.20.4, module version = 1.0.0
[   596.070]    ABI class: X.Org Server Extension, version 10.0
[   596.070] (II) LoadModule: "fbturbo"
[   596.070] (II) Loading /usr/lib/xorg/modules/drivers/fbturbo_drv.so
[   596.074] (II) Module fbturbo: vendor="X.Org Foundation"
[   596.074]    compiled for 1.20.3, module version = 0.5.1
[   596.074]    Module class: X.Org Video Driver
[   596.074]    ABI class: X.Org Video Driver, version 24.0
[   596.074] (II) FBTURBO: driver for framebuffer: fbturbo
[   596.074] (EE)
Fatal server error:
[   596.075] (EE) parse_vt_settings: Cannot open /dev/tty0 (Permission denied)
[   596.076] (EE)
[   596.076] (EE)
Please consult the The X.Org Foundation support
         at http://wiki.x.org
 for help.
[   596.077] (EE) Please also check the log file at "/home/pi/.local/share/xorg/Xorg.0.log" for additional information.
[   596.078] (EE)
[   596.078] (WW) xf86CloseConsole: KDSETMODE failed: Bad file descriptor
[   596.078] (WW) xf86CloseConsole: VT_GETMODE failed: Bad file descriptor
[   596.080] (EE) Server terminated with error (1). Closing log file.
sudo startx:

Code: Select all

X.Org X Server 1.20.4
X Protocol Version 11, Revision 0
Build Operating System: Linux 4.15.0-48-generic armv8l Raspbian
Current Operating System: Linux raspberrypi 4.19.80-v8+ #1274 SMP PREEMPT Mon Oct 21 16:45:40 BST 2019 aarch64
Kernel command line: coherent_pool=1M 8250.nr_uarts=0 bcm2708_fb.fbwidth=1920 bcm2708_fb.fbheight=1080 bcm2708_fb.fbswap=1 vc_mem.mem_base=0x3ec00000 vc_mem.mem_size=0x40000000  console=ttyS0,115200 console=tty1 root=PARTUUID=5e3da3da-02 rootfstype=ext4 elevator=deadline fsck.repair=yes rootwait usbhid.mousepoll=0 quiet splash plymouth.ignore-serial-consoles
Build Date: 05 June 2019  12:49:54PM
xorg-server 2:1.20.4-1+rpt1 (https://www.debian.org/support)
Current version of pixman: 0.36.0
        Before reporting problems, check http://wiki.x.org
        to make sure that you have the latest version.
Markers: (--) probed, (**) from config file, (==) default setting,
        (++) from command line, (!!) notice, (II) informational,
        (WW) warning, (EE) error, (NI) not implemented, (??) unknown.
(==) Log file: "/var/log/Xorg.0.log", Time: Mon Oct 28 23:07:14 2019
(==) Using system config directory "/usr/share/X11/xorg.conf.d"
modprobe: FATAL: Module g2d_23 not found in directory /lib/modules/4.19.80-v8+
/usr/lib/xorg/Xorg: symbol lookup error: /usr/lib/xorg/modules/drivers/fbturbo_drv.so: undefined symbol: shadowUpdatePackedWeak
xinit: giving up
xinit: unable to connect to X server: Connection refused
xinit: server error

k3lt
Posts: 23
Joined: Sat Jul 07, 2018 4:42 pm
Location: Kraków, Poland

Re: Pi4 64-bit raspbian kernel for testing - Focus on Pi4

Tue Oct 29, 2019 10:45 am

I just fixed blank screen on boot by adding this into /boot/config.txt, now display works when booting to Desktop with Raspberry Pi 3b+.

Code: Select all

[all]
dtoverlay=vc4-fkms-v3d
max_framebuffers=2
framebuffer_priority=2

dom
Raspberry Pi Engineer & Forum Moderator
Raspberry Pi Engineer & Forum Moderator
Posts: 5658
Joined: Wed Aug 17, 2011 7:41 pm
Location: Cambridge

Re: Pi4 64-bit raspbian kernel for testing - Focus on Pi4

Tue Oct 29, 2019 11:45 am

k3lt wrote:
Tue Oct 29, 2019 10:45 am
I just fixed blank screen on boot by adding this into /boot/config.txt, now display works when booting to Desktop with Raspberry Pi 3b+.
Can you describe exactly what you have been doing.
Did you start with a clean raspbian buster image, with no changes to config.txt which has a working display and display stopped working after rpi-update and adding arm_64bit=1? Does display work without arm_64bit=1?
If not, what did you start with.

k3lt
Posts: 23
Joined: Sat Jul 07, 2018 4:42 pm
Location: Kraków, Poland

Re: Pi4 64-bit raspbian kernel for testing - Focus on Pi4

Tue Oct 29, 2019 11:53 am

dom wrote:
Tue Oct 29, 2019 11:45 am
k3lt wrote:
Tue Oct 29, 2019 10:45 am
I just fixed blank screen on boot by adding this into /boot/config.txt, now display works when booting to Desktop with Raspberry Pi 3b+.
Can you describe exactly what you have been doing.
Did you start with a clean raspbian buster image, with no changes to config.txt which has a working display and display stopped working after rpi-update and adding arm_64bit=1? Does display work without arm_64bit=1?
If not, what did you start with.
I started with clean (full) image of buster image i got from https://www.raspberrypi.org/downloads/raspbian/ with no changes to config.txt , it booted fine and everything worked. (armv7 kernel)
Then i did rpi-update and added arm_64bit=1 to /boot/config.txt which resulted in blank screen on boot. Display works fine without arm_64bit=1.

But as i've said above i got it to work with arm_64bit=1 (armv8 kernel) after adding these lines to config.txt:

Code: Select all

[all]
dtoverlay=vc4-fkms-v3d
max_framebuffers=2
framebuffer_priority=2
I found the solution here: https://github.com/raspberrypi/firmware/issues/1204 (i know it's not the same issue but it worked nonetheless)

dom
Raspberry Pi Engineer & Forum Moderator
Raspberry Pi Engineer & Forum Moderator
Posts: 5658
Joined: Wed Aug 17, 2011 7:41 pm
Location: Cambridge

Re: Pi4 64-bit raspbian kernel for testing - Focus on Pi4

Tue Oct 29, 2019 12:01 pm

k3lt wrote:
Tue Oct 29, 2019 11:53 am
But as i've said above i got it to work with arm_64bit=1 (armv8 kernel) after adding these lines to config.txt:
I found the solution here: https://github.com/raspberrypi/firmware/issues/1204 (i know it's not exactly the same issue but it worked nonetheless)
The comment on the link was:
Note, just setting max_framebuffers avoids the problem,
Is that enough to fix your issue?

k3lt
Posts: 23
Joined: Sat Jul 07, 2018 4:42 pm
Location: Kraków, Poland

Re: Pi4 64-bit raspbian kernel for testing - Focus on Pi4

Tue Oct 29, 2019 12:07 pm

dom wrote:
Tue Oct 29, 2019 12:01 pm
k3lt wrote:
Tue Oct 29, 2019 11:53 am
But as i've said above i got it to work with arm_64bit=1 (armv8 kernel) after adding these lines to config.txt:
I found the solution here: https://github.com/raspberrypi/firmware/issues/1204 (i know it's not exactly the same issue but it worked nonetheless)
The comment on the link was:
Note, just setting max_framebuffers avoids the problem,
Is that enough to fix your issue?
I'm getting blank screen with:

Code: Select all

[all]
max_framebuffers=2
arm_64bit=1
Disply is working with:

Code: Select all

[all]
dtoverlay=vc4-fkms-v3d
max_framebuffers=2
arm_64bit=1
Not sure what framebuffer_priority=2 does, but i guess it's not required then.

dom
Raspberry Pi Engineer & Forum Moderator
Raspberry Pi Engineer & Forum Moderator
Posts: 5658
Joined: Wed Aug 17, 2011 7:41 pm
Location: Cambridge

Re: Pi4 64-bit raspbian kernel for testing - Focus on Pi4

Tue Oct 29, 2019 12:22 pm

k3lt wrote:
Tue Oct 29, 2019 12:07 pm
Not sure what framebuffer_priority=2 does, but i guess it's not required then.
Is max_framebuffers=2 required?

k3lt
Posts: 23
Joined: Sat Jul 07, 2018 4:42 pm
Location: Kraków, Poland

Re: Pi4 64-bit raspbian kernel for testing - Focus on Pi4

Tue Oct 29, 2019 12:26 pm

dom wrote:
Tue Oct 29, 2019 12:22 pm
k3lt wrote:
Tue Oct 29, 2019 12:07 pm
Not sure what framebuffer_priority=2 does, but i guess it's not required then.
Is max_framebuffers=2 required?
Tried without it and display is fine, so looks like just dtoverlay=vc4-fkms-v3d is required.
Here is my full config.txt which is booting with working display.

Edit:
Forgot to mention, the TV i'm using is LG 50UK6950PLB connected with HDMI if that makes any difference.

Code: Select all

# For more options and information see
# http://rpf.io/configtxt
# Some settings may impact device functionality. See link above for details

# uncomment if you get no picture on HDMI for a default "safe" mode
#hdmi_safe=1

# uncomment this if your display has a black border of unused pixels visible
# and your display can output without overscan
disable_overscan=1

# uncomment the following to adjust overscan. Use positive numbers if console
# goes off screen, and negative if there is too much border
#overscan_left=16
#overscan_right=16
#overscan_top=16
#overscan_bottom=16

# uncomment to force a console size. By default it will be display's size minus
# overscan.
#framebuffer_width=1280
#framebuffer_height=720

# uncomment if hdmi display is not detected and composite is being output
#hdmi_force_hotplug=1

# uncomment to force a specific HDMI mode (this will force VGA)
#hdmi_group=1
#hdmi_mode=1

# uncomment to force a HDMI mode rather than DVI. This can make audio work in
# DMT (computer monitor) modes
#hdmi_drive=2

# uncomment to increase signal to HDMI, if you have interference, blanking, or
# no display
#config_hdmi_boost=4

# uncomment for composite PAL
#sdtv_mode=2

#uncomment to overclock the arm. 700 MHz is the default.
#arm_freq=800

# Uncomment some or all of these to enable the optional hardware interfaces
#dtparam=i2c_arm=on
#dtparam=i2s=on
#dtparam=spi=on

# Uncomment this to enable infrared communication.
#dtoverlay=gpio-ir,gpio_pin=17
#dtoverlay=gpio-ir-tx,gpio_pin=18

# Additional overlays and parameters are documented /boot/overlays/README

# Enable audio (loads snd_bcm2835)
dtparam=audio=on

[pi4]
# Enable DRM VC4 V3D driver on top of the dispmanx display stack
dtoverlay=vc4-fkms-v3d
max_framebuffers=2

[all]
dtoverlay=vc4-fkms-v3d
arm_64bit=1

dom
Raspberry Pi Engineer & Forum Moderator
Raspberry Pi Engineer & Forum Moderator
Posts: 5658
Joined: Wed Aug 17, 2011 7:41 pm
Location: Cambridge

Re: Pi4 64-bit raspbian kernel for testing - Focus on Pi4

Tue Oct 29, 2019 1:08 pm

k3lt wrote:
Tue Oct 29, 2019 12:26 pm
Tried without it and display is fine, so looks like just dtoverlay=vc4-fkms-v3d is required.
I've done a quick check and Pi3 with arm_64bit=1 and no fkms overlay has a display as expected here.
As this problem is probably unique to your setup (possibly the display), can you open as issue here:
https://github.com/raspberrypi/linux/firmware
(it's actually currently unclear if it's a firmware or kernel issue, but my initial guess is firmware)

Describe what we've tested and include the edid (tvservice -d edid.dat and attach a zip file of the edid to the issue),
and perhaps some of the other devs will have some ideas.

k3lt
Posts: 23
Joined: Sat Jul 07, 2018 4:42 pm
Location: Kraków, Poland

Re: Pi4 64-bit raspbian kernel for testing - Focus on Pi4

Tue Oct 29, 2019 1:12 pm

dom wrote:
Tue Oct 29, 2019 1:08 pm
k3lt wrote:
Tue Oct 29, 2019 12:26 pm
Tried without it and display is fine, so looks like just dtoverlay=vc4-fkms-v3d is required.
I've done a quick check and Pi3 with arm_64bit=1 and no fkms overlay has a display as expected here.
As this problem is probably unique to your setup (possibly the display), can you open as issue here:
https://github.com/raspberrypi/linux/firmware
(it's actually currently unclear if it's a firmware or kernel issue, but my initial guess is firmware)

Describe what we've tested and include the edid (tvservice -d edid.dat and attach a zip file of the edid to the issue),
and perhaps some of the other devs will have some ideas.
I'm using Pi3 b+ not Pi3, https://github.com/raspberrypi/linux/firmware gives me 404. :)

jamesh
Raspberry Pi Engineer & Forum Moderator
Raspberry Pi Engineer & Forum Moderator
Posts: 27385
Joined: Sat Jul 30, 2011 7:41 pm

Re: Pi4 64-bit raspbian kernel for testing - Focus on Pi4

Tue Oct 29, 2019 1:15 pm

k3lt wrote:
Tue Oct 29, 2019 1:12 pm
dom wrote:
Tue Oct 29, 2019 1:08 pm
k3lt wrote:
Tue Oct 29, 2019 12:26 pm
Tried without it and display is fine, so looks like just dtoverlay=vc4-fkms-v3d is required.
I've done a quick check and Pi3 with arm_64bit=1 and no fkms overlay has a display as expected here.
As this problem is probably unique to your setup (possibly the display), can you open as issue here:
https://github.com/raspberrypi/linux/firmware
(it's actually currently unclear if it's a firmware or kernel issue, but my initial guess is firmware)

Describe what we've tested and include the edid (tvservice -d edid.dat and attach a zip file of the edid to the issue),
and perhaps some of the other devs will have some ideas.
I'm using Pi3 b+ not Pi3, https://github.com/raspberrypi/linux/firmware gives me 404. :)
https://github.com/raspberrypi/firmware
Principal Software Engineer at Raspberry Pi (Trading) Ltd.
Contrary to popular belief, humorous signatures are allowed.
I've been saying "Mucho" to my Spanish friend a lot more lately. It means a lot to him.

k3lt
Posts: 23
Joined: Sat Jul 07, 2018 4:42 pm
Location: Kraków, Poland

Re: Pi4 64-bit raspbian kernel for testing - Focus on Pi4

Tue Oct 29, 2019 1:39 pm

jamesh wrote:
Tue Oct 29, 2019 1:15 pm
https://github.com/raspberrypi/firmware
Ok done https://github.com/raspberrypi/firmware/issues/1278 , hopefully i didn't screw up something. ;)

f0rd0prefect
Posts: 28
Joined: Fri May 17, 2013 11:58 am

Re: Pi4 64-bit raspbian kernel for testing - Focus on Pi4

Fri Nov 01, 2019 12:38 pm

dom wrote:
Tue Sep 03, 2019 11:56 pm

Code: Select all

pi@pi4:~ $ uname -a
Linux domnfs 4.19.69-v8+ #1261 SMP PREEMPT Tue Sep 3 20:27:16 BST 2019 aarch64 GNU/Linux
Is 'uname -a' the only method to detect the 64-Bit-Kernel? I would appreciate a kernelmessage, which can be parsed with dmesg, e.g.

Code: Select all

dmesg | grep -i cpu
This is behaviour from current 32-Bit-Kernel:

Code: Select all

 CPU: ARMv7 Processor [410fd083] revision 3 (ARMv7)
When using 64-Bit-Kernel, I don't get any message like this.

User avatar
dickon
Posts: 1796
Joined: Sun Dec 09, 2012 3:54 pm
Location: Home, just outside Reading

Re: Pi4 64-bit raspbian kernel for testing - Focus on Pi4

Fri Nov 01, 2019 12:48 pm

dmesg has a limited buffer which makes it unsuitable for that sort of thing. You can trivially grep the 'CPU architecture' field of /proc/cpuinfo ('7' for 32b on a Pi 3B, '8' for the 64b kernel), however.

Return to “Advanced users”