vr34
Posts: 5
Joined: Thu May 30, 2019 2:13 pm

Mono 4.5.01 on Buster

Tue Jul 16, 2019 8:58 am

Hello,

To run CumulusMX with my weather station, I need to install an old version of Mono (version 4.5.0.1) as the lasts versions are not compatible.
It is ok with my RPi3b Stretch. Procedure is :
1. Create the file /etc/apt/sources.list.d/mono-xamarin.list with the line
deb http://download.mono-project.com/repo/debian wheezy/snapshots/4.0.5 main
2. sudo apt-get update
3. Install the compatible version of Mono: sudo aptitude install mono-complete=4.0.5.1-0xamarin1

But with my new RPi4 Buster, there is an error message on step 2 alerting that this deposit is not signed.
Step 3 thus cannot be completed.

How can I fix it ?

Good day,
vr34

fruitoftheloom
Posts: 20427
Joined: Tue Mar 25, 2014 12:40 pm
Location: Delightful Dorset

Re: Mono 4.5.01 on Buster

Tue Jul 16, 2019 9:43 am

vr34 wrote:
Tue Jul 16, 2019 8:58 am
Hello,

To run CumulusMX with my weather station, I need to install an old version of Mono (version 4.5.0.1) as the lasts versions are not compatible.
It is ok with my RPi3b Stretch. Procedure is :
1. Create the file /etc/apt/sources.list.d/mono-xamarin.list with the line
deb http://download.mono-project.com/repo/debian wheezy/snapshots/4.0.5 main
2. sudo apt-get update
3. Install the compatible version of Mono: sudo aptitude install mono-complete=4.0.5.1-0xamarin1

But with my new RPi4 Buster, there is an error message on step 2 alerting that this deposit is not signed.
Step 3 thus cannot be completed.

How can I fix it ?

Good day,
vr34

The download states Debian Wheezy which is an ancient release, there are fundamental differences between Wheezy & Buster

https://www.debian.org/releases/


RPi4 Buster, that is incorrect as Raspbian Buster is suitable for ALL Raspberry Pi models
adieu

Asus CS10 Chromebit / HP Envy 4500 Wireless Printer / Raspberry Pi Model 2B v1.1 / RealVNC Software...

vr34
Posts: 5
Joined: Thu May 30, 2019 2:13 pm

Re: Mono 4.5.01 on Buster

Tue Jul 16, 2019 3:40 pm

Sure, but there are also fundamental differences between Wheezy & Jessie & Stretch.
And Mono 4.5.0.1 is working great on Jessie and Stretch even if the deposit is for Wheezy …
So how can I make it running on Buster?

Second possibility: as this version of Mono is working well on Stretch, can I install Stretch on RPi4? If yes, will USB3 and ethernet 1000 be functionnal?

fruitoftheloom
Posts: 20427
Joined: Tue Mar 25, 2014 12:40 pm
Location: Delightful Dorset

Re: Mono 4.5.01 on Buster

Tue Jul 16, 2019 4:34 pm

vr34 wrote:
Tue Jul 16, 2019 3:40 pm
Sure, but there are also fundamental differences between Wheezy & Jessie & Stretch.
And Mono 4.5.0.1 is working great on Jessie and Stretch even if the deposit is for Wheezy …
So how can I make it running on Buster?

Second possibility: as this version of Mono is working well on Stretch, can I install Stretch on RPi4? If yes, will USB3 and ethernet 1000 be functionnal?

The RPi 4B only supports Raspbian Buster !
adieu

Asus CS10 Chromebit / HP Envy 4500 Wireless Printer / Raspberry Pi Model 2B v1.1 / RealVNC Software...

Return to “Advanced users”