Page 1 of 1

Disable all boot text in Buster

Posted: Wed Jul 10, 2019 5:13 am
by c4n1
I was able to get all boot text disabled in Stretch but Buster isn't taking the same config, can anyone suggest what needs to change to remove all the boot text?

Current /boot/cmdline.txt that's not working

Code: Select all

dwc_otg.lpm_enable=0 console=serial0,115200 console=tty3 root=PARTUUID=4df3c5f0-02 rootfstype=ext4 elevator=deadline fsck.repair=yes rootwait quiet loglevel=0 rd.systemd.show_status=false udev.log_priority=0 plymouth.ignore-serial-consoles logo.nologo vt.global_cursor_default=0

Re: DIsable all boot text in Buster

Posted: Wed Jul 10, 2019 10:47 am
by gordon77
Are you booting to GUI or CLI ?

When I wrote the SD card I left it to automatically boot to GUI, and there was no text at boot up.

BUT after going into 'Preferences' and choosing boot to CLI, booting and then changing back to boot to GUI it now shows all the text at boot !!

Re: DIsable all boot text in Buster

Posted: Wed Jul 10, 2019 12:27 pm
by PeterO
This behaviour existed on previous releases as well.... Swaping from GUI to CLI and back to GUI does not get back to the same state.
PeterO

Re: DIsable all boot text in Buster

Posted: Tue Jul 16, 2019 11:52 pm
by c4n1
Annoyingly less fun work caught up with me. I'm booting into the GUI with the intention of running a kiosk style application on chrome. The reason I need the text gone is that I want a logo / loading screen up whilst the device starts chrome. I had been doing this using fbi but with the boot text the image gets overwritten with the text. I hadn't swapped between CLI and GUI boots on this write of the OS so I don't think that should have affected it.

Re: Disable all boot text in Buster

Posted: Wed Jul 17, 2019 7:43 pm
by timg236
It's a bit fiddly but for an internal test we did this on a buildroot image so something similar should work in a Buster image on Pi4

The workaround was to completely disable tty1 in inittab as well as quiet etc

sed -i "s,^tty1::respawn:.*$,," ${TARGET_DIR}/etc/inittab

Re: Disable all boot text in Buster

Posted: Wed Jul 17, 2019 8:37 pm
by DougieLawson
There's no /etc/inittab with Systemd.

Think again.

Re: Disable all boot text in Buster

Posted: Wed Jul 17, 2019 8:58 pm
by Andyroo
There are a few notes for Debian to add quiet systemd.show_status=0 to cmdline.txt but it will not address any fsck messages.

I do not have a monitored Pi at the mo to test for you...

Re: Disable all boot text in Buster

Posted: Fri Jul 19, 2019 3:05 am
by c4n1
Unfortunately none of the suggestions so far have got rid of all the text. I've decided to go a different way and instead of using fbi /fmi to swap through several images on boot I've replaced the image in /usr/share/plymouth/themes/pix/splash.png with some full screen branding, removed the panel by commenting everything in the below file (sed included for ease)

Code: Select all

sudo sed -i 's/^\([^#]\)/#\1/g' /etc/xdg/lxpanel/LXDE-pi/panels/panel
and lastly used the same branding image I swapped the splash for as the desktop image. This keeps things looking clean until chromium starts for my kiosk application. It would be nice to keep using fbi / fmi for the loading spinner I had previously but for now I'm happy to have something that looks clean and works.