cmdshft
Posts: 1
Joined: Wed May 22, 2019 11:24 pm

Silent boot instructions are not working properly

Wed May 22, 2019 11:39 pm

I am attempting to do a completely silent boot but retain the plymouth splash screen. I have gotten it to be mostly silent, with only this remaining

Image

I have tried doing the following:

sudo nano /etc/systemd/system/autologin\@.service

I changed ExecStart to the following:

ExecStart=-/sbin/agetty --skip-login --noclear --noissue --login-options "-f pi" %I $TERM

Which is supposed to remove the text in the image above. It obviously does not.

Here are the contents of /etc/systemd/system/autologin\@.service, /boot/cmdline.txt and config.txt

autologin\@.service

Code: Select all

# This file is part of systemd.
#
# systemd is free software; you can redistribute it and/or modify it
# under the terms of the GNU Lesser General Public License as published by
# the Free Software Foundation; either version 2.1 of the License, or
# (at your option) any later version.

[Unit]
Description=Getty on %I
Documentation=man:agetty(8) man:systemd-getty-generator(8)
Documentation=http://0pointer.de/blog/projects/serial-console.html
After=systemd-user-sessions.service plymouth-quit-wait.service
After=rc-local.service

# If additional gettys are spawned during boot then we should make
# sure that this is synchronized before getty.target, even though
# getty.target didn't actually pull it in.
Before=getty.target
IgnoreOnIsolate=yes

# On systems without virtual consoles, don't start any getty. Note
# that serial gettys are covered by [email protected], not this
# unit.
ConditionPathExists=/dev/tty0

[Service]
# the VT is cleared by TTYVTDisallocate
ExecStart=-/sbin/agetty --skip-login --noclear --noissue --login-options "-f pi" %I $TERM
Type=idle
Restart=always
RestartSec=0
UtmpIdentifier=%I
TTYPath=/dev/%I
TTYReset=yes
TTYVHangup=yes
TTYVTDisallocate=yes
KillMode=process
IgnoreSIGPIPE=no
SendSIGHUP=yes
# Unset locale for the console getty since the console has problems
# displaying some internationalized messages.
Environment=LANG= LANGUAGE= LC_CTYPE= LC_NUMERIC= LC_TIME= LC_COLLATE= LC_MONETARY= LC_MESSAGES= LC_PAPER= LC_NAME= LC_ADDRESS= LC_TELEPHONE= LC_MEASUREMENT= LC_IDENTIFICATION=

[Install]
WantedBy=getty.target
DefaultInstance=tty1
cmdline.txt (yes, this is all on one line)

Code: Select all

dwc_otg.lpm_enable=0 console=serial0,115200 console=tty3 root=PARTUUID=735626bf-02 rootfstype=ext4 elevator=deadline fsck.repair=yes rootwait quiet splash plymouth.enable=1 plymouth.ignore-serial-consoles vt.global_cursor_default=0 loglevel=3
config.txt

Code: Select all

# For more options and information see
# http://rpf.io/configtxt
# Some settings may impact device functionality. See link above for details

# uncomment if you get no picture on HDMI for a default "safe" mode
#hdmi_safe=1

# uncomment this if your display has a black border of unused pixels visible
# and your display can output without overscan
#disable_overscan=1

# uncomment the following to adjust overscan. Use positive numbers if console
# goes off screen, and negative if there is too much border
#overscan_left=16
#overscan_right=16
#overscan_top=16
#overscan_bottom=16

# uncomment to force a console size. By default it will be display's size minus
# overscan.
#framebuffer_width=1280
#framebuffer_height=720

# uncomment if hdmi display is not detected and composite is being output
#hdmi_force_hotplug=1

# uncomment to force a specific HDMI mode (this will force VGA)
#hdmi_group=1
#hdmi_mode=1

# uncomment to force a HDMI mode rather than DVI. This can make audio work in
# DMT (computer monitor) modes
#hdmi_drive=2

# uncomment to increase signal to HDMI, if you have interference, blanking, or
# no display
#config_hdmi_boost=4

# uncomment for composite PAL
#sdtv_mode=2

#uncomment to overclock the arm. 700 MHz is the default.
#arm_freq=800

# Uncomment some or all of these to enable the optional hardware interfaces
#dtparam=i2c_arm=on
#dtparam=i2s=on
#dtparam=spi=on

# Uncomment this to enable the lirc-rpi module
#dtoverlay=lirc-rpi

# Additional overlays and parameters are documented /boot/overlays/README

# Enable audio (loads snd_bcm2835)
dtparam=audio=on

dtoverlay=hyperpixel4
overscan_left=0
overscan_right=0
overscan_top=0
overscan_bottom=0
framebuffer_width=800
framebuffer_height=480
enable_dpi_lcd=1
display_default_lcd=1
dpi_group=2
dpi_mode=87
dpi_output_format=0x7f216
display_rotate=1
hdmi_timings=480 0 10 16 59 800 0 15 113 15 0 0 0 60 0 32000000 6
Any ideas? I am on the latest release of Raspbian Stretch.

User avatar
topguy
Posts: 5466
Joined: Tue Oct 09, 2012 11:46 am
Location: Trondheim, Norway

Re: Silent boot instructions are not working properly

Thu May 23, 2019 8:54 am

But since the text on the screen mentions "PiHole" I would say its not a completely standard Raspbian. And also that the issue most likely is in PiHole somewhere.

molul
Posts: 11
Joined: Mon Jun 11, 2018 5:42 am

Re: Silent boot instructions are not working properly

Fri May 24, 2019 6:53 am

I'm also running the latest Stretch (Stretch Lite, downloaded and burnt to the SD card), and the "ExecStart=-/sbin/agetty --skip-login --noclear --noissue --login-options "-f pi" %I $TERM" doesn't hide the autologin message for me either.

Any hint is greatly appreciated.

molul
Posts: 11
Joined: Mon Jun 11, 2018 5:42 am

Re: Silent boot instructions are not working properly

Fri May 24, 2019 9:03 pm

Found the solution.
cmdshft wrote:
Wed May 22, 2019 11:39 pm
sudo nano /etc/systemd/system/autologin\@.service

I changed ExecStart to the following:

ExecStart=-/sbin/agetty --skip-login --noclear --noissue --login-options "-f pi" %I $TERM
Dont type

Code: Select all

sudo nano /etc/systemd/system/autologin\@.service
Type

Code: Select all

sudo nano /etc/systemd/system/[email protected]/autologin.conf
This did the trick for me. Hope it helps :)

Return to “Advanced users”