digitalwiz
Posts: 5
Joined: Thu Jan 24, 2019 6:35 pm

kernel option in config.txt doesn't work

Wed May 08, 2019 6:09 pm

I built a new kernel for my R Pi 3 and copied it over to the boot partition of the SD card as zImage and edited config.txt to change #kernel="" to kernel="zImage". Reboot and it's still the original kernel7.img.

BespokeTech
Posts: 40
Joined: Thu Apr 04, 2019 8:14 pm

Re: kernel option in config.txt doesn't work

Thu May 09, 2019 11:09 am

Have you tried following the official guide? Works fine for me.

https://www.raspberrypi.org/documentati ... uilding.md

stuartiannaylor

Re: kernel option in config.txt doesn't work

Thu May 09, 2019 11:44 am

Dont you have to update the initramfs also?

sudo mkinitramfs -o /boot/initramfs.gz 4.14.98-v7+

That might be me using arch too much of late

6by9
Raspberry Pi Engineer & Forum Moderator
Raspberry Pi Engineer & Forum Moderator
Posts: 6684
Joined: Wed Dec 04, 2013 11:27 am
Location: ZZ9 Plural Z Alpha, aka just outside Cambridge.

Re: kernel option in config.txt doesn't work

Thu May 09, 2019 12:31 pm

Have you got the quotes in there? You shouldn't have.

Code: Select all

kernel=zImage
Software Engineer at Raspberry Pi Trading. Views expressed are still personal views.
I'm not interested in doing contracts for bespoke functionality - please don't ask.

digitalwiz
Posts: 5
Joined: Thu Jan 24, 2019 6:35 pm

Re: kernel option in config.txt doesn't work

Tue May 14, 2019 8:55 pm

OK, removing the quotes did the trick. I must say though that I find it somewhat misleading to have the quotes in the default config.txt if they really shouldn't be there.

Return to “Advanced users”