itheo92
Posts: 10
Joined: Thu Nov 08, 2012 8:10 am
Location: India

Connecting RPi directly to PC ethernet port

Mon Nov 12, 2012 11:52 am

I'm struggling for a few days to connect my two-week-old RPi to my PC for SSH connection. I've no router, so I've connected the RPi directly to my PC Ethernet port through an usual ethernet cable, no crossover/patch cable. The RPi user guide says that the RPi is clever enough to detect direct connection to clients without need of special cables due to its auto-MDI feature.

I'm running on the Raspbian OS which starts the SSH service by default. Well. I've configured the RPi networking interface to be a static one. My /etc/network/interface reads:

Code: Select all

auto lo

iface lo inet loopback
iface eth0 inet static
	address 192.168.1.5
	netmask 255.255.255.0
	gateway 192.168.1.254

allow-hotplug wlan0
iface wlan0 inet manual
wpa-roam /etc/wpa_supplicant/wpa_supplicant.conf
iface default inet dhcp

On the PC side I'm using Ubuntu 12.04. At default "Wired connection 1" settings (i.e. auto/DHCP), the RPi isn't automatically configured. It tries to connect then fails, retries over and over and fails.

I've tried manually entering the IP address etc specified in the RPi's /etc/network/interfaces eth0 entry. It says then connection established. But putty says connection refused. I could successfully ping the IP from PC side but not from the RPi side. What's wrong there?

User avatar
joan
Posts: 12705
Joined: Thu Jul 05, 2012 5:09 pm
Location: UK

Re: Connecting RPi directly to PC ethernet port

Mon Nov 12, 2012 1:08 pm

You have a gateway of 192.168.1.254.

Is that the IP address of your PC?

itheo92
Posts: 10
Joined: Thu Nov 08, 2012 8:10 am
Location: India

Re: Connecting RPi directly to PC ethernet port

Mon Nov 12, 2012 1:54 pm

joan wrote:You have a gateway of 192.168.1.254.

Is that the IP address of your PC?
I've just changed the RPi side eth0 config to the following as Ubuntu was assigning an IP 192.xx.xx.xxx
to the connected tethered android device.

So, now my RPi eth0 config reads

Code: Select all

   address 112.168.1.5
   netmask 255.255.255.0
   gateway 112.168.1.254
And on the Ubuntu side, I thought setting a DHCP would work as it was supposed to detect the config of the RPi. But it didn't. Now I've changed Ubuntu side eth0 (i.e. "Wired Connection 1") config to manual with the following settings in network manager:

Code: Select all

address 112.168.1.254
   netmask 255.255.255.0
   gateway 112.168.1.5


What's wrong? A little to add, I'm basically a newbie in setting up a network. I never did set up any network except a DSL modem two years ago :) and never studied TCP/IP too.

User avatar
RaTTuS
Posts: 9365
Joined: Tue Nov 29, 2011 11:12 am
Location: North West UK

Re: Connecting RPi directly to PC ethernet port

Mon Nov 12, 2012 2:06 pm

1) what is the ip info of your internet access device
2) what is the ip info of your PC
3) what is the ip info of your RPi

where ip info
tells you the IP / net mask / gateway

how are all the things attached
How To ask Questions :- http://www.catb.org/esr/faqs/smart-questions.html
WARNING - some parts of this post may be erroneous YMMV

1QC43qbL5FySu2Pi51vGqKqxy3UiJgukSX
Covfefe

itheo92
Posts: 10
Joined: Thu Nov 08, 2012 8:10 am
Location: India

Re: Connecting RPi directly to PC ethernet port

Mon Nov 12, 2012 2:27 pm

1) what is the ip info of your internet access device
-No internet access device/router etc, RPi is directly connected to PC ethernet port.
2) what is the ip info of your PC

Code: Select all

 static
   address 112.168.1.254
   netmask 255.255.255.0
   gateway 112.168.1.5
3) what is the ip info of your RPi

Code: Select all

  static
    address 112.168.1.5
   netmask 255.255.255.0
   gateway 112.168.1.254

obcd
Posts: 908
Joined: Sun Jul 29, 2012 9:06 pm

Re: Connecting RPi directly to PC ethernet port

Mon Nov 12, 2012 3:47 pm

Dhcp can only work if you have a dhcp server on your network.
Normally a router has such a buildin dhcp server.
In your case, using static ip's is a good choice.
Are your pc or your Pi having other network connections besides the cable between the pc and the Pi?
Can you ping your Pi from your pc and your pc from your Pi?
Are the network led's on your pi showing activity?

User avatar
tedhale
Posts: 114
Joined: Thu Sep 20, 2012 4:52 pm
Location: Williamsburg, VA, USA
Contact: Website

Re: Connecting RPi directly to PC ethernet port

Mon Nov 12, 2012 3:55 pm

As the above post points out, DHCP only works when there is a DHCP server on the network.
Since you are connecting the Pi and the PC directly, there is no DHCP, so your PC does not get an address.
You will have to set your PC to a static address.

Also, if you have a wireless connection on the PC, be sure to define the wired network to be different or the PC won't know which device to send the packets through.
- Ted B. Hale
http://raspberrypihobbyist.blogspot.com

salts633
Posts: 9
Joined: Sat Sep 01, 2012 7:37 pm

Re: Connecting RPi directly to PC ethernet port

Mon Nov 12, 2012 4:28 pm

Hi itheo92

There's something wrong with your gateway settings there. On a normal home network both machines should have the same gateway ip address, which should be the ip address of the device which connects to the internet.

Assuming that neither of these devices connects to the internet the following setup should allow the machines to ping each other and connect via ssh if you use the ip address directly (i.e. not the machine name).

on your pc

address 192.168.1.100
netmask 255.255.255.0
gateway 192.168.1.100

on your pi

address 192.168.1.5
netmask 255.255.255.0
gateway 192.168.1.100

note that your previous ip address 112.xx.xx.xx is not in the ranges reserved for private networks

User avatar
penguintutor
Posts: 356
Joined: Tue May 08, 2012 9:11 am
Location: UK
Contact: Website

Re: Connecting RPi directly to PC ethernet port

Mon Nov 12, 2012 4:35 pm

Firstly I'm guessing you made up the 112.* IP addresses?
Not a good idea as they are registered to someone else in this case the address is managed by Korea Telecom. As long as you are not routing your network via Korea or want to connect to a site in Korea you are probably OK, but you can get strange problems.

The following ranges are all reserved for local networks and I recommend you use one of those:

Class A 10.0.0.0 to 10.255.255.255
Class B 172.16.0.0 to 172.31.255.255
Class C 192.168.0.0 to 192.168.255.255

Although you are already using a 192.168.*.* address - that can be split into 253 subnets as long as using a 24 bit subnet mask (ie 192.168.1.* is a different network to 192.168.2.* - assuming mask of 255.255.255.0). But if you want to avoid that you can just use the 10.*.*.* address range for your connection to the Pi instead.

If you are only able to ping in one direction then I'd first look at what routes are setup on both ends of the connection.

Whilst you have a gateway entry, if you are not using a router then you should not need a gateway address as the network expects that address to be a router. Furthermore if you are adding a second gateway to a device which already has a network connection then that could cause problems with knowing which is the real gateway. I'd suggest removing the gateway from any interfaces that do not actually have a router connected.

To check your routes you can use netstat -rn (see below)

Code: Select all

pi@raspberrypi:~$ netstat -rn
Kernel IP routing table
Destination     Gateway         Genmask         Flags   MSS Window  irtt Iface
0.0.0.0         192.168.0.1     0.0.0.0         UG        0 0          0 eth0
192.168.0.0     0.0.0.0         255.255.255.0   U         0 0          0 eth0
This shows a fairly typical setup using a router. The last line is the one we are interested in and is an implied route based on the address of the network interface. It is saying that to get to the network 192.168.0.* then it is directly connected to eth0.

I suggest you change the ip addresses to a reserved address (eg. 10.*) and remove then gateway entries. If it still isn't working then provide the output from ifconfig and netstat -rn which may show where the problem is.

User avatar
tedhale
Posts: 114
Joined: Thu Sep 20, 2012 4:52 pm
Location: Williamsburg, VA, USA
Contact: Website

Re: Connecting RPi directly to PC ethernet port

Mon Nov 12, 2012 8:05 pm

Everyone seems to be missing the fact that the OP said he is connecting the RasPi DIRECTLY to the PC.

No switch, hub, router, etc. is involved.

With that set up, you can use any any IP address you like as long as both systems are on the same subnet.
(with the caveat that if the PC has WIFI, don't use that subnet or the PC gets confused.)
- Ted B. Hale
http://raspberrypihobbyist.blogspot.com

User avatar
penguintutor
Posts: 356
Joined: Tue May 08, 2012 9:11 am
Location: UK
Contact: Website

Re: Connecting RPi directly to PC ethernet port

Mon Nov 12, 2012 9:07 pm

Everyone seems to be missing the fact that the OP said he is connecting the RasPi DIRECTLY to the PC.
No. I didn't miss that. Whilst the address doesn't matter if there are only two computers in the network - the Ubuntu computer is also tethered to an Android device. I'm guessing this is using the Android for an Internet connection - so it should therefore be using private network addresses.
Ubuntu was assigning an IP 192.xx.xx.xxx
to the connected tethered android device.


Whilst using a non-private address range is unlikely to be the problem on it's own (unless attempting to contact another computer in that address) it is a good idea to instead use a private network address range. I did also say this is unlikely to be the problem, but best practice to set this up using the network range designed for such networks. Using the same subnet as the next network hop / DNS entries etc. can cause significant network problems for the Internet connection.

Normally a connection refused from ssh does not necessarily indicate an underlying network problem, but in this case there is also a problem with pinging between the computers, but only in one direction.
I could successfully ping the IP from PC side but not from the RPi side.
I think it is worth therefore trying to fix what appears to be network problem first. One issue you can get where you can ping in one direction, but not the other is either a duplicate IP address, in this case it's physically connected so unless there is another interface one of the computers that is unlikely. Another is that routing is not set-up on one side of the route, although this is more likely to result in pings failing in the other direction (ie the computer with multiple interfaces sends it request in the wrong direction, but when responding from a request on a known network learns the arp entry of that computer). It may be the case that the implied route hasn't been added to the routing table for some reason. It may therefore also be worth looking at the arp table "arp -an" (duplicate arp entries / outdated arp entries can cause these sort of symptoms as well)

Looking at the routing tables and the ifconfig outputs can at least identify some potential problems / eliminate these (also show us packet loss etc which could be due to a faulty cable / network interface) .

Another reason for ping not working could be that the PC is configured to not respond to ICMP echo requests (perhaps a firewall). I am trying to keep the information we are investigating as simple as possible at this stage - so sticking to basic network commands.

It could be that there is nothing wrong with the network other than the PC refusing the ICMP ping, and that the problem with ssh is that the Pi is refusing the ssh connection, but with the potential network problems indicated by the ping it's worth checking network levels 1 to 3 prior to investigating the application layer.

User avatar
joan
Posts: 12705
Joined: Thu Jul 05, 2012 5:09 pm
Location: UK

Re: Connecting RPi directly to PC ethernet port

Mon Nov 12, 2012 9:28 pm

I'd bung the cable in between the Pi and the Ubuntu machine.

At the ubuntu do

ifconfig eth0

to find its address.

Say its eth0 address is 192.168.1.5

On the Pi do

sudo ifconfig eth0 192.168.1.6

to ensure they are on the same network.

Then try pinging between the machines.

andrum99
Posts: 369
Joined: Fri Jul 20, 2012 2:41 pm

Re: Connecting RPi directly to PC ethernet port

Mon Nov 12, 2012 11:04 pm

Don't set the devices to be gateway for each other. All you need is something like this:

IP address of PC: 192.168.1.1
IP address of Rasperberry Pi: 192.168.1.2
Subnet mask on both: 255.255.255.0
Default gateway on both: 192.168.1.254

The ping from the Pi to the PC will be failing because of a firewall setting on the PC. The Pi does not come with a firewall by default. The above should allow you to connect to the Pi via SSH using a direct ethernet connection between your PC and Pi.

Cheers

Andrew.

itheo92
Posts: 10
Joined: Thu Nov 08, 2012 8:10 am
Location: India

Re: Connecting RPi directly to PC ethernet port

Tue Nov 13, 2012 9:12 am

Thank you everybody for your very early and helpful replies, your replies not only fixed the issue alone, also inspired me a bit to do some wikipedia on networking basics.

The IP address that I assigned earlier without thinking that much, i.e.
RPi:
address 112.168.1.5
netmask 255.255.255.0
gateway 112.168.1.254

and at ubuntu side
address 112.168.1.254
netmask 255.255.255.0
gateway 112.168.1.5

That actually worked after rebooting the Pi and I could establish an SSH connection in putty. Later I changed it to one of the private IP address as suggested by penguintutor.
Firstly I'm guessing you made up the 112.* IP addresses?
Not a good idea as they are registered to someone else in this case the address is managed by Korea Telecom. As long as you are not routing your network via Korea or want to connect to a site in Korea you are probably OK, but you can get strange problems.


Then I changed the IP addresses to something like:

Code: Select all

Rpi
ip 172.16.1.1
mask 255.255.255.0
gateway 172.16.1.2  //172.16.1.1 works too

ubuntu
ip 172.16.1.21
sub 255.255.255.0
gateway 172.16.1.1 //172.16.1.10 works too
That worked too. And now I understood why it is a good idea to use private IP addresses. I didn't used the 192.168.* IPs because they were already assigned to my tethered android device on usb0 for internet connection. But I don't understand why I can not connect to the internet through usb0 while the eth0 is connected. Can you point the issue out of it? Or is it unlikely a ubuntu side problem? I think there should not be any conflict between 192.168.* IP (usb0) and 172.16.* (eth0) IP addresses.
Whilst you have a gateway entry, if you are not using a router then you should not need a gateway address as the network expects that address to be a router
Exactly true. As I learned from wikipedia "a gateway is a node (a router) on a TCP/IP network that serves as an access point to another network". In this setup there is only a single network and so the gateway address is not necessary to let it connect to "another" network when the IP address doesn't match any other route in the routing table. So,
You have a gateway of 192.168.1.254.

Is that the IP address of your PC?

It is not necessarily needed.
Don't set the devices to be gateway for each other. All you need is something like this:

IP address of PC: 192.168.1.1
IP address of Rasperberry Pi: 192.168.1.2
Subnet mask on both: 255.255.255.0
Default gateway on both: 192.168.1.254
Yes. I did it before you've written ;) And I think as long as the PC and the RPi is connected directly, setting an IP address having same network part and different node is just good. And we need static IP on the both as there is no DHCP server.

Twinkletoes
Posts: 210
Joined: Fri May 25, 2012 9:44 pm

Re: Connecting RPi directly to PC ethernet port

Tue Nov 13, 2012 9:29 am

Also google zeroconf - there is a group of ip addresses reserved for "connecting without rules". It's called link-local addressing.

andrum99
Posts: 369
Joined: Fri Jul 20, 2012 2:41 pm

Re: Connecting RPi directly to PC ethernet port

Tue Nov 13, 2012 11:37 am

itheo92 wrote:Thank you everybody for your very early and helpful replies
You're welcome - glad I could help. :-)
itheo92 wrote:As I learned from wikipedia "a gateway is a node (a router) on a TCP/IP network that serves as an access point to another network". In this setup there is only a single network and so the gateway address is not necessary to let it connect to "another" network when the IP address doesn't match any other route in the routing table.
That's right. A gateway is used to communicate with a node outwith the current subnet. For example, if your subnet uses the address range 192.168.1.1 to 192.168.1.254, which has a subnet mask of 255.255.255.0, then you would only need to contact the gateway for addresses beyond this range, e.g. 192.168.0.5 or 32.6.2.153.

The address range 192.168.1.1 to 192.168.1.254 with subnet mask 255.255.255.0 is sometimes written as 192.168.1.0/24, where 24 denotes the number of bits in the subnet mask (each 255 is 8 bits).

Cheers

Andrew.

User avatar
penguintutor
Posts: 356
Joined: Tue May 08, 2012 9:11 am
Location: UK
Contact: Website

Re: Connecting RPi directly to PC ethernet port

Tue Nov 13, 2012 3:12 pm

But I don't understand why I can not connect to the internet through usb0 while the eth0 is connected. Can you point the issue out of it? Or is it unlikely a ubuntu side problem? I think there should not be any conflict between 192.168.* IP (usb0) and 172.16.* (eth0) IP addresses.
There will not be any conflict from those network ranges both are reserved ranges and very different.

Do you still have the gateway entry to the eth0 network on the Ubuntu computer - if so then that will be causing the problem? Reboot to make sure it isn't still in place.

netstat -rn will show any routes defined and the default - ie network address of 0.0.0.0 - should be pointing to your Android phone (which will be acting as the router in this case).


Once you have your network connection up and running properly you may like to look at using IP masquerading on your Ubuntu machine so that your Raspberry Pi can use that to connect to the network (assuming the usb0 interface is up on Ubuntu). You can do that using shorewall (you could manually edit the IPtables, but that is complicated). I suggest you make sure that the connections are working as required first (ie. Ubuntu can connect to Internet and Raspberry Pi) then see: http://www.shorewall.net/two-interface.htm
If using this you will then need to add the gateway address back to your Pi to point at Ubuntu. Ubuntu will be acting as a router - it isn't at the moment.

itheo92
Posts: 10
Joined: Thu Nov 08, 2012 8:10 am
Location: India

Re: Connecting RPi directly to PC ethernet port

Wed Nov 14, 2012 5:07 am

penguintutor wrote:
But I don't understand why I can not connect to the internet through usb0 while the eth0 is connected. Can you point the issue out of it? Or is it unlikely a ubuntu side problem? I think there should not be any conflict between 192.168.* IP (usb0) and 172.16.* (eth0) IP addresses.
There will not be any conflict from those network ranges both are reserved ranges and very different.

Do you still have the gateway entry to the eth0 network on the Ubuntu computer - if so then that will be causing the problem? Reboot to make sure it isn't still in place.
Yes, changed the gateway to 0.0.0.0 and now I can use usb0 and eth0 simultaneously.
Once you have your network connection up and running properly you may like to look at using IP masquerading on your Ubuntu machine so that your Raspberry Pi can use that to connect to the network (assuming the usb0 interface is up on Ubuntu). You can do that using shorewall (you could manually edit the IPtables, but that is complicated). I suggest you make sure that the connections are working as required first (ie. Ubuntu can connect to Internet and Raspberry Pi) then see: http://www.shorewall.net/two-interface.htm
If using this you will then need to add the gateway address back to your Pi to point at Ubuntu. Ubuntu will be acting as a router - it isn't at the moment.
Certainly everyone will look for exactly this after configuring the RPi and the internet connection on PC. I looked at the shorewall link you have given, but, I found it too complicated to follow for a novice like me in networking.

I was searching for how to share internet connection in ubuntu 12.04. I was fortunate enough to find http://raspberrypi.org/phpBB3/viewtopic.php?f=26&t=6997. It sets up the DNS servers and modifies the iptable manually for port forwarding. I followed this with some minor modifications for my 172.16.* IPs. This works perfectly. And now I can ping google.com from Pi.

Meanwhile, here is the netstat -rn output:
Kernel IP routing table
Destination Gateway Genmask Flags MSS Window irtt Iface
0.0.0.0 192.168.42.129 0.0.0.0 UG 0 0 0 usb0
169.254.0.0 0.0.0.0 255.255.0.0 U 0 0 0 eth0
172.16.1.0 0.0.0.0 255.255.255.0 U 0 0 0 eth0
192.168.42.0 0.0.0.0 255.255.255.0 U 0 0 0 usb0
192.168.* is associated with the tethered android device, 172.16.* is for the Pi. And I've never have written the IP address 169.254.0.0 anywhere!

User avatar
dliloch
Posts: 159
Joined: Wed Jun 27, 2012 6:28 pm
Location: cleveland, ohio usa

Re: Connecting RPi directly to PC ethernet port

Fri Nov 16, 2012 2:12 pm

first off I am a complete noob to networking.. but would it be possible
to have dhcp server running on the pi so that if I connect it directly to
a pc linux/windows etc .. the pi would "serve" an address dynamically
and no configuration would be necessary on the pi or the computer??
If I plugged it into a real network I would not want the dhcp server on the
pi to do anything in that case...
the reason for this is if I wanted to demo the pi .. I would not have to
configure anything .. just plug the ethernet cable into the machine..
then ssh to the pi...

Twinkletoes
Posts: 210
Joined: Fri May 25, 2012 9:44 pm

Re: Connecting RPi directly to PC ethernet port

Fri Nov 16, 2012 2:30 pm

The 169.254... address is a link-local address - about the most useful thing you can have in your situation:

http://en.wikipedia.org/wiki/Link-local_address

User avatar
dliloch
Posts: 159
Joined: Wed Jun 27, 2012 6:28 pm
Location: cleveland, ohio usa

Re: Connecting RPi directly to PC ethernet port

Sun Nov 18, 2012 1:45 am

so it appears that the IPV6 local link address will work ..
It does with my mac but I have no success with windows or linux ubuntu 12.04
on linux the avahi-browse gives me this ..
+ eth0 IPv6 raspberrypi1 Remote Disk Management local
+ eth0 IPv6 raspberrypi1 [b8:27:eb:9e:40:cc] Workstation local
= eth0 IPv6 raspberrypi1 Remote Disk Management local
hostname = [raspberrypi1.local]
address = [fe80::ba27:ebff:fe9e:40cc]
port = [22]
txt = []
= eth0 IPv6 raspberrypi1 [b8:27:eb:9e:40:cc] Workstation local
hostname = [raspberrypi1.local]
address = [fe80::ba27:ebff:fe9e:40cc]

but I can't ping6 raspberrypi1.local or ssh -6 raspberrypi1.local
also my ethernet keeps disconnecting and reconnecting
this is with linux now .. what am I doing wrong .. apple was so easy...
thanks..
the browse finds the stuff but unusable..

sdjf
Posts: 1388
Joined: Fri Mar 16, 2012 5:20 am
Location: California
Contact: Website

Re: Connecting RPi directly to PC ethernet port

Mon Nov 19, 2012 3:57 pm

I am rather lost, I need to find out what the default IP addresses are that are already on the RPi at initial boot without any tweaking as I expect to perform that initial boot over ethernet without a router.

Are the following the right settings? I will be running Arch if that makes any difference.
andrum99 wrote: All you need is something like this:
IP address of PC: 192.168.1.1
IP address of Rasperberry Pi: 192.168.1.2
Subnet mask on both: 255.255.255.0
Default gateway on both: 192.168.1.254
I will be accessing from a system that has no firewall, that will not be an issue.

But will not be able to query the Pi's defaults on my own Pi until after that initial boot using ssh over ethernet, and do not want to buy a router when I would have no other need for one.

Thanks!
FORUM TIP: To view just one person's posting history, sign in, click on their user name, then click on "Search User's Posts." || My 512MB Model B only runs Arch.

sdjf
Posts: 1388
Joined: Fri Mar 16, 2012 5:20 am
Location: California
Contact: Website

Re: Connecting RPi directly to PC ethernet port

Mon Nov 19, 2012 4:13 pm

@dliloch: It would be so much easier to figure out what is going on and fix things if you had command line access. Does your system have a terminal or console you can use? Which distribution are you running?

Also, if your ethernet keeps cutting in and out, it could be your power supply is not adequate.
FORUM TIP: To view just one person's posting history, sign in, click on their user name, then click on "Search User's Posts." || My 512MB Model B only runs Arch.

lelopi
Posts: 4
Joined: Tue Jan 08, 2013 12:19 pm

Re: Connecting RPi directly to PC ethernet port

Wed Jan 09, 2013 10:42 am

I have encountered a problem connecting the RPi to a Windows 7 laptop.

After connecting together, I checked the Network and Sharing and found out that the PC can connect but unable to display RPi when I clicked on the show full map option.

It says that it is on public network therefore windows is unable to show the RPi.

I input 'ifconfig' command on RPi's LXTerminal, it isn't showing the inet addr in the eth0 option.

When I put a router in between them, 'ifconfig' command would show that the RPi has an inet addr of 192.168.2.65.

But the laptop is still unable to show RPi connected to the router.

Any help is gladly appreciated.

-rst-
Posts: 1316
Joined: Thu Nov 01, 2012 12:12 pm
Location: Dublin, Ireland

Re: Connecting RPi directly to PC ethernet port

Wed Jan 09, 2013 4:59 pm

Not sure if you should even see RPi in the Windows network if you haven't set up samba...

Can you ping the RPi from the laptop when both connected to the router (open command prompt and type: ping 192.168.2.65 or whatever the RPi ip address is at that moment)?

For connecting directly between RPI and laptop, you must manually assign the ip address and net mask for both (should be covered in this or other threads here).
http://raspberrycompote.blogspot.com/ - Low-level graphics and 'Coding Gold Dust'

Return to “Advanced users”

Who is online

Users browsing this forum: IanS, nebogeo and 27 guests