piercedfreak
Posts: 5
Joined: Tue Apr 12, 2016 11:48 am

[SOLVED]Overscan issue

Thu Oct 18, 2018 9:33 am

With disable_overscan=1 set, the text is off the edge of the screen, but when I change it to 0, I have a black border around the edge of the screen. I even tried setting overscan_left=0, top, bottom, etc, and the border still persist. I even tried negative values which seemed to have no effect. Can someone help me get rid of these damn borders? They are about .25 inch/6.35mm on the sides, and .50+ inch/12.5mm top, and bottom. This is all on a RPI 3B, using a Canal Kit 5v 2.5a power supply, running OSMC.

Here is my current config.txt

Code: Select all

gpu_mem_1024=256
hdmi_ignore_cec_init=1
start_x=1
disable_splash=1
gpu_mem_256=128
gpu_mem_512=256
overscan_scale=1
dtoverlay=pi3-disable-bt
sdtv_aspect=1
disable_overscan=0
overscan_left=1
overscan_right=1
overscan_top=1
overscan_bottom=1

EDIT: This also happens when running RetroPie(I used RetrOSMC to install under OSMC).



EDIT 2: Turns out the negative numbers I tried were not big enough, after a second attempt with larger negative numbers the issue is resolved.
Last edited by piercedfreak on Thu Oct 18, 2018 12:05 pm, edited 1 time in total.

drgeoff
Posts: 8627
Joined: Wed Jan 25, 2012 6:39 pm

Re: Overscan issue

Thu Oct 18, 2018 11:00 am

The number in the overscan_left type statements has units of pixels. Setting that to 1 will produce such a small shift that you are unlikely to notice it. Try using larger numbers eg 100 to get a feel for the effect.

piercedfreak
Posts: 5
Joined: Tue Apr 12, 2016 11:48 am

Re: Overscan issue

Thu Oct 18, 2018 11:10 am

drgeoff wrote:
Thu Oct 18, 2018 11:00 am
The number in the overscan_left type statements has units of pixels. Setting that to 1 will produce such a small shift that you are unlikely to notice it. Try using larger numbers eg 100 to get a feel for the effect.
The directive overscan_left means it shifts the image from the left to the right that many pixels, if there is a gap between the left side of the screen, and the image, increasing the amount will just make the gap larger, hence why I tried negative amounts.

Return to “Advanced users”