Page 1 of 1

Can't manually enable experimental OpenGL driver on "clean" installation

Posted: Thu Aug 23, 2018 3:30 pm
by antiriad
Hello,

I'm trying to get a clean installation of Raspian Stretch with hardware acceleration.
Starting from latest release of Raspbian LITE, I updated everything (apt-get update, dist-upgrade etc.).

I installed Xorg Display Server and Xinit

Code: Select all

sudo apt-get install --no-install-recommends xserver-xorg xinit

...then Raspbian Desktop (RPD)

Code: Select all

sudo apt-get install raspberrypi-ui-mods

... the experimental OpenGL driver

Code: Select all

sudo apt-get install xcompmgr libgl1-mesa-dri

...but when I activate OpenGL driver in raspi-config, I get very low performance on glxgears, as if driver it's not activated (or however as if it's much much slower than default Raspbian image available for download).

So it's seems that something is missing... any help?
THANKS

MORE DETAILS:
- memory split is set to 128Mb
- firmware is updated via rpi-update
- I launched apt-get update / upgrade also after the OpenGL driver activation
- color (or "shading") of glxgears is strangely different than that in the default Raspbian (non-Lite) ISO publicly available
- after compiling chocolate-doom (V3 with SDL2-dev etc.) in both contexts, I get 60fps on default Raspbian (non-Lite) ISO and 1 (one!) FPS on custom Raspbian Lite + RPD + OpenGL driver.

Re: Can't manually enable experimental OpenGL driver on "clean" installation

Posted: Thu Aug 23, 2018 10:01 pm
by Imperf3kt
Which model Pi are you using?

Re: Can't manually enable experimental OpenGL driver on "clean" installation

Posted: Fri Aug 24, 2018 5:05 am
by antiriad
Hello, I'm using a Raspberry Pi 3.

Re: Can't manually enable experimental OpenGL driver on "clean" installation

Posted: Fri Aug 24, 2018 11:27 am
by antiriad
Found this old comment by Simon Long...
https://www.raspberrypi.org/blog/anothe ... nt-1252967

Perhaps the reason why the driver is not activated depends on one of these factors...

Re: Can't manually enable experimental OpenGL driver on "clean" installation

Posted: Fri Aug 24, 2018 11:33 am
by PeterO
antiriad wrote:
Fri Aug 24, 2018 11:27 am
Found this old comment by Simon Long...
https://www.raspberrypi.org/blog/anothe ... nt-1252967

Perhaps the reason why the driver is not activated depends on one of these factors...
Maybe , but that is over 2 years ago and many things have changed in that time...... I don't know anything more I'm afraid.
PeterO

Re: Can't manually enable experimental OpenGL driver on "clean" installation

Posted: Fri Aug 24, 2018 12:10 pm
by antiriad
Thank you for your feedback.

Maybe there is a way to forward this to someone of the Staff (or Simon Long himself) without "stalking"? It would be extremely useful to put on a "clean" Raspbian installation with hardware acceleration.

Re: Can't manually enable experimental OpenGL driver on "clean" installation

Posted: Mon Sep 03, 2018 11:50 am
by antiriad
I've done it! 8-)

After enabling the experimental OpenGL driver in raspi-config, manually delete /usr/share/X11/xorg.conf.d/99-fbturbo.conf and reboot.