jofori
Posts: 23
Joined: Sat May 19, 2018 1:29 pm
Location: London-Accra

Wifi Hotspot used to connect internal Local Lan PCS with no Router

Tue Jun 19, 2018 1:05 pm

Hi

********** PLEASE NOTE in this scenario this LAN network is not supposed to have access to the internet **********

I have an internal network of 3 x Raspberry PI3B+ machines and NO router is allowed to be connected to the network because it's supposed to be a closed portable network of Pi3B+(s), utilising a Wifi Hotspot and an Ethernet Lan (with USB powered Ethernet HUB).

Pi 1 is configured with dnsmasq (dhcp/DNS server) issuing IP(s) to other client machines (3B+ and laptops etc.).

Pi 1 is also a Wifi Hotspot - followed this tutorial - https://www.raspberrypi.org/documentati ... s-point.md

**** I don't know what to change (including the format of IP Ranges and where to make the change) to make the following scenario happen....

With my Macbook Pro Laptop I can connect to the Wifi hotspot and I get an IP address and that's fine , but I cannot browse or connect to any other machine on the LAN ethernet network. (I don't mean the Wifi network)

I am aware there may be a security risk , but ignoring that for my demo network, Is there a technical restriction that prevents this ?
....OR is it just a matter of ensuring the Wifi Hotspot is issued a set of IPs that correspond to the same subnet as my Ethernet Lan ?
Or Am I missing some fundamental networking concept ?

1) My (dnsmasq) Ethernet Lan has IP Range = 192.168.5.x/24 and needs to remain in this format. i.e it issues IP addresses in this format and has a few fixed based on MAC addresses of other Pi 3B+(s)

2) My working Wifi Hotspot:

a) sudo nano /etc/dhcpcd.conf has the configuration:
interface wlan0
static ip_address=192.168.12.1/24

b) sudo nano /etc/dnsmasq.conf has the configuration:
interface=wlan0 # Use the require wireless interface - usually wlan0
dhcp-range=192.168.12.2,192.168.12.20,255.255.255.0,24h

(I tried to change this dhcp-range to something like dhcp-range=192.168.5.30, 192.168.5.50, 255.255.255.0, 24h
which is similar to my ethernet ranges, but this does not work, and I am not up-to-date on how to set IP ranges any other way, or where to even make the change)

c) sudo nano /etc/network/interfaces
# Bridge setup
auto br0
iface br0 inet manual
bridge_ports eth0 wlan0

Can some explain how I can get this "Bridged" scenario to work.
i.e From Mac Laptop to my Raspberry Pi3B+ Hotspot, and then connect to a local Raspberry Pi3B+ which is on the Ethernet part of the LAN network.

Many thanks
J

epoch1970
Posts: 2075
Joined: Thu May 05, 2016 9:33 am
Location: Paris, France

Re: Wifi Hotspot used to connect internal Local Lan PCS with no Router

Tue Jun 19, 2018 6:50 pm

I understand you want 3 Pi's wired together and one access point for wireless clients.

Everything needs to happen on Pi 1 which will do AP and DHCP server:
  • Choose a single network range. E.g 192.168.5.0/24
  • Give static addresses to hosts that need a static config.
    Your DHCP server is the first (and possibly single one) of these. Give br0 the address 192.168.5.1 on Pi 1. This is done in /etc/network/interfaces
  • Bridge eth0 to br0. This is done in /etc/network/interfaces
  • Make the DHCP server listen on br0 and define a range for DHCP clients, say 192.168.5.100-192.168.5.200. This is done in /etc/dnsmasq.conf
  • Make hostapd use wlan0 and bridge it to br0. This is done in /etc/hostapd.conf
  • Bridge eth0 to br0. This is done in /etc/network/interfaces
  • Deactivate dhcpcd on all interfaces: br0, eth0, wlan0. This is done in /etc/dhcpcd.conf
Keep the other Pis stock, they will use DHCP. So will the wifi clients.
"S'il n'y a pas de solution, c'est qu'il n'y a pas de problème." Les Shadoks, J. Rouxel

jofori
Posts: 23
Joined: Sat May 19, 2018 1:29 pm
Location: London-Accra

Re: Wifi Hotspot used to connect internal Local Lan PCS with no Router

Wed Jun 20, 2018 5:12 pm

Hi
thanks for the helpful reply, however I was looking for something a little more specific regarding the details...
I cannot get your configuration to work i.e connect from Mac OSX laptop machine to the Wireless hotspot on Pi 1 and then logon onto a PC on the Ethernet LAN..
==============================================================================================
To be clear: Say you have an Ethernet network of Raspberry Pi 3B+(s) with NO other equipment connected by Ethernet.
(Pi 1 Or RSPi Server = 1 , ethernet connected to RSPi Clients = 3) , (Laptop client =1 , not ethernet connected)


Now Network all the RSPi machines together using a usb powered Ethernet hub. (not the laptop)

Add to the RSPi (server) Wifi Hotspot functionailty.

Now disable all client wifi connectivity except for the RSPi (server) - that needs to stay on because it provides the WifiHotspot.

Now from your Laptop (Mac Osx) connect to the WIFI Hotspot ( RSPi - server ).

Now that your LAPTOP is connected via Wifi Hotspot, Launch your (network browser) i.e Finder --> GO -->Connect To Server (smb://192.168.5.7/) and connect to an Ethernet Lan based RSPi i.e any of the 3 clients) and browse it's/their shared folders etc...

The result is that I have used my WIFI hotspot, as a way to browse my local LAN without connecting directly to any RSPi-client but just through the bridge provided by my hotspot on the RSPi (server).

Scenario: Why would anyone want this: In my case, I am building portable classrooms for young/vunerable people... They are protected from the outside world's distractions(Facebook, youtube etc) and inappropriate content. All the skills required like connecting to a web site, downloading, uploading, build websites(wordpress), coding etc is all simulated using Raspberry Pi 3B+ machines and Raspbian pre-loaded software.

The Wifi HotSpot part, is to demonstrate how to work with Wifi hotspots and learn the benefits/vulnerabilities that come with it.
===============================================================================================================

With That in mind:
https://www.raspberrypi.org/documentati ... s-point.md
Can anyone please clarify / please be a little more specific :-): and relate to the "recommended" tutorial mentioned in 1st post)
Based on the last reply I received

1) Choose a single network range. E.g 192.168.5.0/24
===============================================
Where and which interface should this apply, we have 3 to choose from Br0=bridge , eth0=ethernet lan and wlan0=wifi hotspot ?

2) Give static addresses to hosts that need a static config.
Your DHCP server is the first (and possibly single one) of these. Give br0 the address 192.168.5.1 on Pi 1. This is done in /etc/network/interfaces

================================================
I am using Raspbian Stretch (9.x) on Raspberry Pi 3B+ , so I am not so sure if I should be assigning an IP address to the Bridge in /etc/network/interfaces ... should it not be in /etc/dhcpdcd.conf and if so exactly how should it look ?
interface br0
static ip_address=192.168.5,100/24
static routers=192.168.5.1
static domain_name_servers=127.0.0.1

3) Bridge eth0 to br0. This is done in /etc/network/interfaces
===================================================
Should this not be bridging br0 to eth0 and wlan0 ?

4) Make the DHCP server listen on br0 and define a range for DHCP clients, say 192.168.5.100-192.168.5.200. This is done in /etc/dnsmasq.conf
====================================================
(as per the "recommended "tutorial mentioned in 1st post), I have :

interface=eth0
dhcp-range = eth0, 192,192.168.5.3, 192.168.5.23, 24h
interface=wlan0
dhcp-range= 192.168.5.100, 192.168.5.200 , 255.255.255.0 , 24h
===================================================
note, the format does not use ' - ' as a separator as suggested in previous reply.

5) Make hostapd use wlan0 and bridge it to br0. This is done in /etc/hostapd.conf
==================================================================
My Raspian stretch host config file is in /etc/hostapd/hostapd.conf (as per the "recommended" tutorial mentioned in 1st post)

6) Bridge eth0 to br0. This is done in /etc/network/interfaces
===================================================
(as per the "recommended" tutorial mentioned in 1st post) bridge_ports eth0 and wlan0

7) Deactivate dhcpcd on all interfaces: br0, eth0, wlan0. This is done in /etc/dhcpcd.conf
=========================================================================
If I disable all interfaces(br0, eth0 and wlan0), how will client machines locate and connect to the RSPi-Server on the ethernet LAN network ? What does it really mean to disable the interfaces, why am I doing that if I want to connect to those interfaces from both WifiHotspot and Ethernet Lan?

Really confused: I wish there was a "Wiki" where we could see it actually broken down i.e all parameters and Networking formats and their purpose for each significant file in-regards to Networking the Raspberry Pi 3B+ machines (using stretch only config). Stretch seems have a whole set of different rules compared to a vast amount of internet examples for networking a RPi zero or RPi 2 which is heavily based on the interface file (with wheezy OR Jessie)?

Networking Setup in Raspbian Stretch including a Bridge tutorial -
https://www.raspberrypi.org/documentati ... s-point.md

regards
J

epoch1970
Posts: 2075
Joined: Thu May 05, 2016 9:33 am
Location: Paris, France

Re: Wifi Hotspot used to connect internal Local Lan PCS with no Router

Wed Jun 20, 2018 7:05 pm

jofori wrote:
Wed Jun 20, 2018 5:12 pm
1) Choose a single network range. E.g 192.168.5.0/24
===============================================
Where and which interface should this apply, we have 3 to choose from Br0=bridge , eth0=ethernet lan and wlan0=wifi hotspot ?
Bridge member interfaces (eth0, wlan0) never have IP addresses. They are the same as a cable plugged into a network switch port.
Bridge interfaces may have IP addresses. They are like a network switch. Some are simple switches you can't manage from a computer, others have an IP address so that you can manage them.
=> Give 192.168.5.1 to br0
2) Give static addresses to hosts that need a static config.
...should it not be in /etc/dhcpdcd.conf and if so exactly how should it look ?
interface br0
static ip_address=192.168.5,100/24
static routers=192.168.5.1
static domain_name_servers=127.0.0.1
That is logical, but the answer is no. Unfortunately, dhcpcd does not know how to manage bridge interfaces. Stick to the documentation.
3) Bridge eth0 to br0. This is done in /etc/network/interfaces
===================================================
Should this not be bridging br0 to eth0 and wlan0 ?
That is logical, but the answer is no. Unfortunately, the wifi standard disallows bridging wifi interfaces in client mode. By default your machine sets the wifi interface in client mode. You can add the wifi interface to the bridge, that does nothing but produce a harmless -but worrisome- error message.
Only hostapd can bridge the wlan0 interface to br0 when you ask it to, because it has set the wifi interface to Access Point mode by then.
4) Make the DHCP server listen on br0 and define a range for DHCP clients, say 192.168.5.100-192.168.5.200. ...
Yes, stick to the documentation. These are configuration files, each program expects a certain format.
7) Deactivate dhcpcd on all interfaces: br0, eth0, wlan0. This is done in /etc/dhcpcd.conf
=========================================================================
If I disable all interfaces(br0, eth0 and wlan0), how will client machines locate and connect to the RSPi-Server on the ethernet LAN network ?
What this means is: block dhcpcd from trying to manage any of these 3 interfaces. You have configured them elsewhere or they need no configuration at all. "denyinterfaces" is the option that tells dhcpcd to leave some interfaces alone. It is in the documentation you refer to.

I find your posts a little difficult to read. Concision does help. Using [ quote] and [code ] structures too.
"S'il n'y a pas de solution, c'est qu'il n'y a pas de problème." Les Shadoks, J. Rouxel

jofori
Posts: 23
Joined: Sat May 19, 2018 1:29 pm
Location: London-Accra

Re: Wifi Hotspot used to connect internal Local Lan PCS with no Router

Thu Jun 21, 2018 5:58 am

Hi
for Raspberry Pi3B+ running stretch:

" Give static addresses to hosts that need a static config.
Your DHCP server is the first (and possibly single one) of these. Give br0 the address 192.168.5.1 on Pi 1. This is done in /etc/network/interfaces "

What exactly is the format, please give an example ? it is not written the same as dhcpcd.conf is it?

jofori
Posts: 23
Joined: Sat May 19, 2018 1:29 pm
Location: London-Accra

Re: Wifi Hotspot used to connect internal Local Lan PCS with no Router

Thu Jun 21, 2018 6:28 am

Hi,
For Raspberry Pi3B+ with stretch, from these comments I still can't understand what works? and why?

https://raspberrypi.stackexchange.com/q ... ip-address
https://raspberrypi.stackexchange.com/q ... interfaces

regards
J

jofori
Posts: 23
Joined: Sat May 19, 2018 1:29 pm
Location: London-Accra

Re: Wifi Hotspot used to connect internal Local Lan PCS with no Router

Thu Jun 21, 2018 8:11 am

Hi

If I follow your example regarding your answer...
3) Bridge eth0 to br0. This is done in /etc/network/interfaces
===================================================
me: Should this not be bridging br0 to eth0 and wlan0 ?
You: That is logical, but the answer is no. Unfortunately, the wifi standard disallows bridging wifi interfaces in client mode. By default your machine sets the wifi interface in client mode. You can add the wifi interface to the bridge, that does nothing but produce a harmless -but worrisome- error message.
Only hostapd can bridge the wlan0 interface to br0 when you ask it to, because it has set the wifi interface to Access Point mode by then.

*****************************************************************************
Then please explain why Raspberry Pi Documentation saids the opposite in the example I have been giving:
https://www.raspberrypi.org/documentati ... s-point.md

it clearly states:
=========================================================================================
Now the interfaces file needs to be edited to adjust the various devices to work with bridging. sudo nano /etc/network/interfaces make the following edits.

Add the bridging information at the end of the file.

# Bridge setup
auto br0
iface br0 inet manual
bridge_ports eth0 wlan0

********************************************************************************

epoch1970
Posts: 2075
Joined: Thu May 05, 2016 9:33 am
Location: Paris, France

Re: Wifi Hotspot used to connect internal Local Lan PCS with no Router

Thu Jun 21, 2018 10:12 am

epoch1970 wrote:
Wed Jun 20, 2018 7:05 pm
You can add the wifi interface to the bridge, that does nothing but produce a harmless -but worrisome- error message.
In /etc/network/interfaces, this:

Code: Select all

# Bridge setup
auto br0
iface br0 inet manual
bridge_ports eth0 wlan0
and that:

Code: Select all

# Bridge setup
auto br0
iface br0 inet manual
bridge_ports eth0
are functionally identical in this specific case, except for the error message I mention.
In hostapd.conf the "bridge=br0" statement adds wlan0 to the bridge.

And generally speaking, https://www.raspberrypi.org/documentati ... s-point.md is the right document, published by RPF.
Follow this one and you'll get a working AP, you're not the first and you won't be the last to do so.
Other authors/sites are responsible for the information they publish.
"S'il n'y a pas de solution, c'est qu'il n'y a pas de problème." Les Shadoks, J. Rouxel

jofori
Posts: 23
Joined: Sat May 19, 2018 1:29 pm
Location: London-Accra

Re: Wifi Hotspot used to connect internal Local Lan PCS with no Router

Thu Jun 21, 2018 10:48 am

Hi
and thank you for taking the time to answer my questions...

Just a quick note: the link you added in your last answer is the same link that I have been asking everyone to compare their answers to, from the very first post.
The answers you have given, did not relate to the link, so that is why I have had to break it down multiple times...

For example when you say:
Your DHCP server is the first (and possibly single one) of these. Give br0 the address 192.168.5.1 on Pi 1. This is done in /etc/network/interfaces

I ask: What does it look like in the interfaces file ?
In your last reply you mention the interfaces file like this, but there is no IP address init...So I'll ask again..what should the IP address look like?

# Bridge setup
auto br0
iface br0 inet manual
bridge_ports eth0

address 192.168.5.1

If this is what it looks like, then unfortunately that does NOT work either.

************************** Also *********************
7) Deactivate dhcpcd on all interfaces: br0, eth0, wlan0. This is done in /etc/dhcpcd.conf
=========================================================================
If I disable all interfaces(br0, eth0 and wlan0), how will client machines locate and connect to the RSPi-Server on the ethernet LAN network ? What does it really mean to disable the interfaces, why am I doing that if I want to connect to those interfaces from both WifiHotspot and Ethernet Lan?

This disables all communication, and I end up with NO Ethernet, or Wifi at all...
denyinterfaces br0
denyinterfaces eth0
denyinterfaces wlan0


related Problem almost identical:
viewtopic.php?f=28&t=198905&p=1268387&h ... h#p1268387
regards
J

epoch1970
Posts: 2075
Joined: Thu May 05, 2016 9:33 am
Location: Paris, France

Re: Wifi Hotspot used to connect internal Local Lan PCS with no Router

Thu Jun 21, 2018 12:20 pm

OK. We're getting there.
In my 1st reply I did not make clear enough that what you needed to do was to cherry-pick parts of the linked documentation.
Rationale:
  1. The 1st half of said documentation page offers to create a secondary network for wifi, with DHCP.
  2. The 2nd half of that page offers to create an AP in the strictest sense: wifi-ethernet bridge, but no DHCP at all.
  3. You want to create an island network with DHCP, wifi and ethernet bridged. To achieve this goal you need mostly 2), and a bit of 1) on the top.
So. Where are we now??
  • I'll start from the 2nd half of the page, title: Using the Raspberry Pi as an access point to share an internet connection (bridge) and only note where you have to diverge from the document.
    Add denyinterfaces wlan0 and denyinterfaces eth0 to the end of the file (but above any other added interface lines) and save the file.
    Too little, possibly too late. Instead, in the very first line of that file, put this line:

    Code: Select all

    denyinterfaces br0 eth0 wlan0
    Now the interfaces file needs to be edited to adjust the various devices to work with bridging. sudo nano /etc/network/interfaces make the following edits.
    You need to replace what's in the document with this:

    Code: Select all

    # Bridge setup
    auto br0
    iface br0 inet static
    bridge-stp on
    bridge-maxwait 2
    bridge-fd 2
    # With wlan0 or not, as you like.
    bridge_ports eth0 wlan0
    # RPI1's IP conf
    address 192.168.5.1
    network 192.168.5.0
    broadcast 192.168.5.255
    netmask 255.255.255.0
    # This is an island, no gateway. With a router at 192.168.5.254, you would need
    # this to access the Internet: gateway 192.168.5.254
    # Dnsmasq is installed on the same host. It serves as DHCP and DNS server, so
    # our DNS server is the localhost, 127.0.0.1
    dns-nameservers 127.0.0.1
    Note "inet static" instead of "inet manual". The "bridge-" stanzas are not absolutely necessary but they might help.
    I've chosen to set "RPI1" to 192.168.5.1, you are free to choose another address (as long as it doesn't clash with the DHCP IP pool defined later.)

    Continue reading and setup hostapd.conf as directed, save your changes and stop there. (don't reboot, it's too early for that.)
  • Now go to the top of the page, and scroll down to title Configuring the DHCP server (dnsmasq)
    Type or copy the following information into the dnsmasq configuration file and save it:
    You need to replace what's in the document with this:

    Code: Select all

    # Listen on the bridge and serve wifi and ethernet clients
    interface=br0
    # Our island network, some addresses set aside for future needs
    dhcp-range=192.168.5.50,192.168.5.200,255.255.255.0,24h
    # Local-only domains answered from static hosts file or DHCP leases.
    local=/islandnet/
    no-negcache
    local-ttl=300
    # Activate these 2 if you want wifi clients like mobiles to use their data link to access the Internet
    # since wifi does not provide a route to the Internet.
    #dhcp-option=3
    #dhcp-option=6
    # Activate this if you have installed an NTP server on 192.168.5.254 and you want DHCP clients to 
    # synchronise their system clock with that server
    #dhcp-option=42,192.168.5.254
    # For debugging purposes, enable to log to syslog.
    #log-queries
    #log-dhcp
    You really only need the first 2 lines. The rest is niceties and FYI.

    Now save, stop your reading and reboot.
I have not tested these exact files obviously but I believe it should work.
HTH
"S'il n'y a pas de solution, c'est qu'il n'y a pas de problème." Les Shadoks, J. Rouxel

jofori
Posts: 23
Joined: Sat May 19, 2018 1:29 pm
Location: London-Accra

Re: Wifi Hotspot used to connect internal Local Lan PCS with no Router

Thu Jun 21, 2018 4:06 pm

Hi

thanks for the last reply , however it did not work, no network interfaces were created/initialised, i.e no Ethernet or Wifi
sudo service hostapd status = no errors at all
sudo service dnsmasq status = no errors at all
sudo service networking status = no errors at all

sudo service dhcpcd status = failed error

" Not Running dhcpcd because /etc/network/interfaces
defines some interfaces that will use a
DHCP client or static address
dhcpcd.service: control process exited, code=exited status=6
Failed to start dhcpcd on all interfaces
Warning: dhcpd.service changed on disk. Run 'systemctl daemon-reload' to reload units. "

regards
J

epoch1970
Posts: 2075
Joined: Thu May 05, 2016 9:33 am
Location: Paris, France

Re: Wifi Hotspot used to connect internal Local Lan PCS with no Router

Thu Jun 21, 2018 5:16 pm

Sorry for the kinks.
Let me run that conf on the lastest Raspbian Stretch Lite. I'll get back to you.

Update. Really no so sure there was a kink, but anyway this is better and tested to work. Here goes:

We're starting with a new Raspbian Lite system, with ssh enabled. I strongly advise you start by installing a fresh copy of Raspbian on your SD.
This is what needs to happen once user pi has logged into the new machine.
- A new [ code] block is started each time you have to re-locate to a different directory.
- There are blank lines separating logical groups of commands. I recommend you copy-paste in your shell block by block, or at least group by group.

This is tested to work on Raspbian Lite "2018-04-18-raspbian-stretch-lite.img", Raspberry Pi 3B.
Good luck.

Code: Select all

sudo apt-get update && sudo apt-get install dnsmasq bridge-utils hostapd

Code: Select all

cd /etc

sudo cp dhcpcd.conf dhcpcd.conf.O
sudo sed -e "4idenyinterfaces br0 wlan0 eth0\n" -i /etc/dhcpcd.conf

sudo sed -e 's/^\#DAEMON_CONF=.*/DAEMON_CONF="\/etc\/hostapd.conf"/' -i /etc/default/hostapd 
sudo bash -c "cat > hostapd.conf" <<EOF
interface=wlan0
bridge=br0
ssid=RPI1
wpa_passphrase=longpassword
hw_mode=g
channel=7
wmm_enabled=0
macaddr_acl=0
auth_algs=1
ignore_broadcast_ssid=0
wpa=2
wpa_key_mgmt=WPA-PSK
wpa_pairwise=TKIP
rsn_pairwise=CCMP
EOF

sudo cp dnsmasq.conf dnsmasq.conf.O
sudo bash -c "cat > dnsmasq.conf" <<EOF
interface=br0
domain=rpinet,192.168.5.0/24,local
dhcp-range=192.168.5.50,192.168.5.200,255.255.255.0,12h
expand-hosts
localise-queries
EOF

Code: Select all

cd /etc/network/interfaces.d/

sudo bash -c "cat > br0" <<EOF
# Bridge setup
auto br0
iface br0 inet static
bridge-stp on
bridge-maxwait 2
bridge-fd 2
# With wlan0 or not, as you like.
bridge_ports eth0 wlan0
# RPI1's IP conf
address 192.168.5.1
network 192.168.5.0
broadcast 192.168.5.255
netmask 255.255.255.0
# This is an island, no gateway. With a router at 192.168.5.254, you would need
# this to access the Internet: gateway 192.168.5.254
# Dnsmasq is installed on the same host. It serves as DHCP and DNS server, so
# our DNS server is the localhost, 127.0.0.1
dns-nameservers 127.0.0.1
dns-domain rpinet
EOF

sudo sed -e "s/^127\.0\.1\.1.*/127\.0\.1\.1\trpi1/" -i /etc/hosts
sudo sed -e "\$a192.168.5.1\trpi1\.rpinet" -i /etc/hosts
sudo bash -c "echo rpi1 > /etc/hostname"

Code: Select all

sudo reboot
"S'il n'y a pas de solution, c'est qu'il n'y a pas de problème." Les Shadoks, J. Rouxel

jofori
Posts: 23
Joined: Sat May 19, 2018 1:29 pm
Location: London-Accra

Re: Wifi Hotspot used to connect internal Local Lan PCS with no Router

Tue Jun 26, 2018 10:04 am

Hi
once again thank you for your help...

OK, so I have tried several combinations of the setup and this is what I have...

If I have a clean install and follow your instructions it works on a standard RPI3 B+ with a full/standard raspbian stretch install (NOT the Raspbian Lite "2018-04-18-raspbian-stretch-lite.img", Raspberry Pi 3B).

However when you combine it with all the other services needed to use the RPI in a classroom setting it fails completely.

What I get are these things...

1) The wifi no longer broadcasts i.e does not appear in the list to select on other machines trying to connect to the Wifi hotspot of RPI1
2) dhcpcd status - errors = "no valid interface found"
3) hostapd status - errors = "hostapderror: unexpectedly disconnected from boot status daemon failed!"
4) dnsmasq status - errors = "no servers found in /run/dnsmasq/resolv.conf, will retry"
5) networking status = No errors.

It is taking me some time to work out why... the funny thing was for a short while (about half a day 12 hours aprox) it was working, Samba, Mac OSX connected, shared files, Mysql, phpmyadmin, LAMP web server and it was great... etc

Any ideas of where I should look?


regards
J

Return to “Advanced users”