User avatar
manawyrm
Posts: 34
Joined: Mon Apr 15, 2013 6:18 am
Location: Alfeld (Leine), Germany
Contact: Website Twitter YouTube

[Pi 3B+] WiFi 433Mbit/s - VHT80 / 802.11ac

Mon Mar 19, 2018 7:26 am

Hi,

I'm currently testing the wifi capability of the new Pi 3B+ and it's CYW43455.

My access point is a Ubiquiti AC AP Lite, that can do 2x2 MIMO at VHT80, already properly tested with other 11ac capable devices, like my phone or laptop. The AP can do 700 MBit/s+.
Image

This is the situation on the Pi:
Image
It only syncs to about 200 MBit/s, which would be exactly fitting for it only using a 40 MHz channel, instead of an 80MHz one.
(I strongly hope that the TX power is just a wrong report, or else I'm properly breaking german law ;) )


The regulatory domain is properly set to germany, which allows 80MHz channels:
Image

The chip (http://www.cypress.com/file/358916/download ) also supports 80MHz wide channels.

What is limiting the WiFi bandwidth here?

EDIT: Some more information for reference:

Code: Select all

brcmfmac: brcmf_fw_map_chip_to_name: using brcm/brcmfmac43455-sdio.bin for chip 0x004345(17221) rev 0x000006
brcmfmac: brcmf_c_preinit_dcmds: Firmware version = wl0: Feb 27 2018 03:15:32 version 7.45.154 (r684107 CY) FWID 01-4fbe0b04
brcmfmac: brcmf_c_preinit_dcmds: CLM version = API: 12.2 Data: 9.10.105 Compiler: 1.29.4 ClmImport: 1.36.3 Creation: 2018-03-09 18:56:28

Code: Select all

[email protected]:~# uname -r
4.14.27-v7+

Best wishes,
Tobias

Seketh
Posts: 8
Joined: Mon Mar 11, 2019 1:16 pm

Re: [Pi 3B+] WiFi 433Mbit/s - VHT80 / 802.11ac

Mon Mar 11, 2019 1:22 pm

I'm reviving this thread as I have the exact same issue, my region is set to PT, and my Raspberry 3 A+ is only using 40MHz, syncs to 200mb/s.

If I set the region to US, either using iw reg set US or modifying wpa_supplicant.conf, the raspberry correctly uses 80MHz, however, wifi seems to restart every 10 seconds or so. Maybe I'm just looking in the wrong place, but I can't understand why it restarts.

Is there any solution for this? Double the bandwith would be very welcome!

Mushoz
Posts: 1
Joined: Thu Mar 28, 2019 9:53 am

Re: [Pi 3B+] WiFi 433Mbit/s - VHT80 / 802.11ac

Thu Mar 28, 2019 9:54 am

I have the exact same issue with the NL region set.

Return to “Advanced users”