Ionic
Posts: 8
Joined: Sun Jun 04, 2017 4:56 pm

Audio HISS: disable_audio_dither or audio_pwm_mode???

Fri Jan 19, 2018 8:57 am

I don't understand which method I have to use for removing audio HISS on analog output.

I have to set disable_audio_dither=1 as stated here
https://www.raspberrypi.org/documentati ... t/audio.md

or audio_pwm_mode=2 from here?
viewtopic.php?f=29&t=195178

I have a RPi 3 and my system is updated with kernel 4.9.35-v7+, the latest official kernel from Raspbian.

Thanks

epoch1970
Posts: 2290
Joined: Thu May 05, 2016 9:33 am
Location: Paris, France

Re: Audio HISS: disable_audio_dither or audio_pwm_mode???

Sat Jan 20, 2018 3:12 pm

I’d recommend you add audio_pwm_mode=2 only.
This is a recent addition, AQ on analog out is truly good with this new driver.
It supports concurrent access, ie 2 (or more) separate programs outputting at the same time.
I’m not sure it is out of beta yet? For me, playing audio only with ALSA works a treat.

EDIT: As offered by jdb in his thread, I would recommend using SKIP_KERNEL=1 rpi-update if you don’t want to upgrade your kernel at the same time. I’ve used recent firmware with an older kernel (on piCore OS) and it just worked fine.
"S'il n'y a pas de solution, c'est qu'il n'y a pas de problème." Les Shadoks, J. Rouxel

Ionic
Posts: 8
Joined: Sun Jun 04, 2017 4:56 pm

Re: Audio HISS: disable_audio_dither or audio_pwm_mode???

Sat Jan 20, 2018 9:34 pm

epoch1970 wrote:
Sat Jan 20, 2018 3:12 pm
I’d recommend you add audio_pwm_mode=2 only.
This is a recent addition, AQ on analog out is truly good with this new driver.
It supports concurrent access, ie 2 (or more) separate programs outputting at the same time.
I’m not sure it is out of beta yet? For me, playing audio only with ALSA works a treat.

EDIT: As offered by jdb in his thread, I would recommend using SKIP_KERNEL=1 rpi-update if you don’t want to upgrade your kernel at the same time. I’ve used recent firmware with an older kernel (on piCore OS) and it just worked fine.
Thanks but If I use audio_pwm_mode=2 option I still hear "HISS" from speaker, so maybe this driver is not present on the latest kernel as I wrote here ;-)

P.S.: Can we use both options? By the way with both options "HISS" is present, so disable_audio_dither is not so good

epoch1970
Posts: 2290
Joined: Thu May 05, 2016 9:33 am
Location: Paris, France

Re: Audio HISS: disable_audio_dither or audio_pwm_mode???

Sun Jan 21, 2018 10:47 am

You should check AQ with headphones, too. Maybe the noise you're getting with speakers come from the amplifier or the line out cable.
"S'il n'y a pas de solution, c'est qu'il n'y a pas de problème." Les Shadoks, J. Rouxel

neckTwi
Posts: 3
Joined: Fri May 23, 2014 10:18 am

Re: Audio HISS: disable_audio_dither or audio_pwm_mode???

Wed Jan 09, 2019 11:52 am

RPi Foundation better document the audio_pwm_mode. How to put some sense into them!

LTolledo
Posts: 924
Joined: Sat Mar 17, 2018 7:29 am

Re: Audio HISS: disable_audio_dither or audio_pwm_mode???

Tue Jan 15, 2019 1:00 pm

I used disable_audio_dither only, the other one I have not used yet.

the "hiss" that I encountered came from several sources, the main causes were the amplifier, the audio cable and the power supply. the USB wireless mouse also contributed some to the "hiss".

1. setting disable_audio_dither removed some of the hiss, but not all
2. changing the amplifier (then a DIY 2W [1W+1W] IC amplifier) to PAM8403 reduced the hiss better
3. changing the audio cable to a shielded one, and clamping ferrite cores on both ends, the hiss was further attenuated
4. separated the power source of the amplifier and the RPi, ....better.....
5. clamped a bigger ferrite core on the microUSB cable, placed it very near the microUSB port, .....much better.....

however, now I use an Audio DAC, connected to a more powerful stereo amplifier (in parallel with several DIY VU meter projects, including ATmega32 based VU meters). Microprocessor based VU meters are known to make the audio line "noisy" with hum and hiss, but not in mine.....
"Don't come to me with 'issues' for I don't know how to deal with those
Come to me with 'problems' and I'll help you find solutions"

Some people be like:
"Help me! Am drowning! But dont you dare touch me nor come near me!"

jdb
Raspberry Pi Engineer & Forum Moderator
Raspberry Pi Engineer & Forum Moderator
Posts: 1820
Joined: Thu Jul 11, 2013 2:37 pm

Re: Audio HISS: disable_audio_dither or audio_pwm_mode???

Wed Jan 16, 2019 4:55 pm

There should be no background hiss with audio_pwm_mode=2 (which is the default on Raspbian). disable_audio_dither will have no effect if audio_pwm_mode=2 is set.

If you do have background noise when playing silence then there's a list of things that need checking:
- If the background noise occurs immediately after boot and before the audio jack is first used by software, then you have a ground loop or external interference.
- If the background noise is only audible after the jack has been used and either silence is being played or playback has been terminated, then in addition to ground loops and external interference the power supply used to power the Pi is also suspect.

If you're using a TRRS (video + audio) 4-ring jack, then it must be of the correct polarity otherwise the TV out signal can end up on one of the audio channels - which sounds like a 50/60Hz buzz.
Rockets are loud.
https://astro-pi.org

Return to “Advanced users”