jeebo
Posts: 69
Joined: Tue Mar 28, 2017 3:55 pm

Unable to access Pi from outside world!

Tue May 16, 2017 9:21 am

Hi Guys,

I have the following setup and arrangement currently in place. I am trying to understand why I cannot access the Pi (specifically the webmin interface).

>Pi is on and sat behind my BT router.
>BT Router is configured to port forward to the Pi on port 10000
>Currently dialled into my Pi via VNC Connect so its on, connected and working
>NO-IP configured and operational, returning from my domain name the correct IP address, confirmed by dialling in and doing an IP check online.

So, I have setup Webmin on my PI and it is actively working. I am however having some strange issues.

The port appears to be open, I have even gone as far as to run a penetration test online, scanning port 10000, which reported : "PORT STATE SERVICE VERSION
10000/tcp open http MiniServ 1.831 (Webmin httpd) "

It also ran a Traceroute:

"HOP RTT ADDRESS
1 3.57 ms router1-lon.linode.com (212.111.33.229)
2 9.62 ms 109.74.207.4
3 5.30 ms 109.74.207.8
4 4.00 ms 80.231.20.2
5 0.85 ms 80.231.20.2
6 14.28 ms core4-te0-0-0-18.faraday.ukcore.bt.net (213.121.193.192)
7 13.89 ms core3-hu0-1-0-3.faraday.ukcore.bt.net (213.121.193.168)
8 ... 9
10 22.52 ms host(MY IP Details)

So, by all accounts, everything seems to be working.

However, I have tried to access the HTTP page of my webmin from outside of my home network on 2 devices....
1) my work PC
2) my mobile phone using 4G

Both of these timeout. In fact my phone using Chrome reported ERR_CONNECTION_REFUSED.

That said, when I look in my router logs, there is nothing there to show the connection has been attempted, but then again these logs are not particularly reliable.

If I VNC onto my Pi, and go to the website mydomain.org:10000, it brings me back to my webmin login page, also the same if I go to My.IP.X.X:10000.

The log then shows:

"N: ACCEPT [57] Connection closed (Port Forwarding: TCP [Ras.Pi.Hom.Ser]:10000 <-​-​> [My.IP.X.X]:10000 -​ -​ -​ "

However trying both of these fails from outside, and doesnt even log an entry, whether I IP to it or use my domain name.

Anybody got any thoughts?

drgeoff
Posts: 9885
Joined: Wed Jan 25, 2012 6:39 pm

Re: Unable to access Pi from outside world!

Tue May 16, 2017 10:30 am

Does your work PC access the internet through a proxy server?

jeebo
Posts: 69
Joined: Tue Mar 28, 2017 3:55 pm

Re: Unable to access Pi from outside world!

Tue May 16, 2017 11:29 am

Hi there,

as far as I know yes it does, but, my phone does not (or at least, not to my knowledge!)

klricks
Posts: 6609
Joined: Sat Jan 12, 2013 3:01 am
Location: Grants Pass, OR, USA
Contact: Website

Re: Unable to access Pi from outside world!

Tue May 16, 2017 12:34 pm

Many 3G/4G providers block non standard ports. Try port 80.
Unless specified otherwise my response is based on the latest and fully updated Raspbian Buster w/ Desktop OS.

RDS
Posts: 721
Joined: Tue Oct 06, 2015 8:17 am
Location: Lancashire, UK

Re: Unable to access Pi from outside world!

Thu May 18, 2017 9:56 pm

Have you been into the VNC Server settings and ticked the check box to allow cloud connections?

jeebo
Posts: 69
Joined: Tue Mar 28, 2017 3:55 pm

Re: Unable to access Pi from outside world!

Thu Jun 08, 2017 12:44 pm

Hi All,

Well, ironically I could, then I could not!

My Pi has been on now for some time, and about half an hour ago I got bored, tried to connect to My,Hostname.org and it connected, I could even browse webmin, and triggered 63 updates!

Sadly, after this, webmin stopped responding. I thought perhaps the service had been updated, and the pi would need a reboot.

I then rebooted the pi, and now all of a sudden, My.Hostname.org no longer responds, and cannot be reached. Even when I go onto VNC (which works by the way, its just the remote connection that fails) I then checked and the webmin service was enabled.

So the only thing which changed, was an updated 63 applications and then the reboot of the Pi. Beyond that though, everything else remains the same and now I am right back to square one!

Return to “Advanced users”