User avatar
kusti8
Posts: 3439
Joined: Sat Dec 21, 2013 5:29 pm
Location: USA

Re: Google Chrome on Raspbian (Failed to open primary graphi

Mon Mar 06, 2017 1:45 am

knuxyl wrote:
kusti8 wrote:BTW I've compiled the latest chromium into a package that has widevine libraries in it so Netflix now works on v56:
viewtopic.php?p=1125013#p1125013
thanks so much! I'm going to use this and mix with the latest libraries and an easy install script, the version i was using is like 45 or something. when I got into the 50's I started getting library version issues (not related to drm and such) and repos didn't have supported versions. have you tested this?
What libraries? This includes the widevine libraries so it works out of the box.
There are 10 types of people: those who understand binary and those who don't.

cjan
Posts: 912
Joined: Sun May 06, 2012 12:00 am

Re: Google Chrome on Raspbian (Failed to open primary graphi

Mon Mar 06, 2017 2:11 am

cjan wrote:how to uninstall? just in case.
ha, i knew it.

User avatar
knuxyl
Posts: 33
Joined: Sun Feb 26, 2017 1:42 am

Re: Google Chrome on Raspbian (Failed to open primary graphi

Mon Mar 06, 2017 3:00 am

kusti8 wrote:
knuxyl wrote:
kusti8 wrote:BTW I've compiled the latest chromium into a package that has widevine libraries in it so Netflix now works on v56:
viewtopic.php?p=1125013#p1125013
thanks so much! I'm going to use this and mix with the latest libraries and an easy install script, the version i was using is like 45 or something. when I got into the 50's I started getting library version issues (not related to drm and such) and repos didn't have supported versions. have you tested this?
What libraries? This includes the widevine libraries so it works out of the box.
the libraries included with rpi-chromium-mods and some others I found in other packages. Turns out though that build isn't 100% so I'm just going to fix my package.

edit - seems as though it was on my side having ethernet and wifi hooked up at same time. Great job!!!!
Last edited by knuxyl on Mon Mar 06, 2017 3:25 am, edited 1 time in total.

User avatar
knuxyl
Posts: 33
Joined: Sun Feb 26, 2017 1:42 am

Re: Google Chrome on Raspbian (Failed to open primary graphi

Mon Mar 06, 2017 3:00 am

cjan wrote:
cjan wrote:how to uninstall? just in case.
ha, i knew it.
to uninstall it, just do this (ill include these instructions on the first post)

sudo rm -R /usr/lib/chromium-browser
sudo apt-get install --reinstall chromium-browser rpi-chromium-mods

User avatar
knuxyl
Posts: 33
Joined: Sun Feb 26, 2017 1:42 am

Re: Google Chrome on Raspbian (Failed to open primary graphi

Mon Mar 06, 2017 4:00 am

I have posted a thread in the Raspbian forum for installing Chromium with Netflix support. The package has been updated and thoroughly tested. Just follow the link on the first post at the top. :D
viewtopic.php?f=66&t=176413&p=1125067#p1125067

cjan
Posts: 912
Joined: Sun May 06, 2012 12:00 am

Re: Google Chrome on Raspbian (Failed to open primary graphi

Mon Mar 06, 2017 10:44 am

installed, chromium about is 51.0.2704.91 not 56.0.2924.110.
btw, does it compiled by armv7 ?

User avatar
knuxyl
Posts: 33
Joined: Sun Feb 26, 2017 1:42 am

Re: Google Chrome on Raspbian (Failed to open primary graphi

Mon Mar 06, 2017 11:00 am

cjan wrote:installed, chromium about is 51.0.2704.91 not 56.0.2924.110.
btw, does it compiled by armv7 ?
the latest package is 56.0.2924.84
you must be installing the older package, or you didn't install it right.

I don't know anything about what goes on during compilation, kusti8 did that. It compiled for armhf which requires at least armv7.

Please post questions about the Chromium build on this page
viewtopic.php?f=66&t=176413

Image
Attachments
raspbian.jpg
raspbian.jpg (57.56 KiB) Viewed 2213 times

User avatar
kusti8
Posts: 3439
Joined: Sat Dec 21, 2013 5:29 pm
Location: USA

Re: Google Chrome on Raspbian (Failed to open primary graphi

Mon Mar 06, 2017 11:13 am

knuxyl wrote:
kusti8 wrote:
knuxyl wrote:
thanks so much! I'm going to use this and mix with the latest libraries and an easy install script, the version i was using is like 45 or something. when I got into the 50's I started getting library version issues (not related to drm and such) and repos didn't have supported versions. have you tested this?
What libraries? This includes the widevine libraries so it works out of the box.
the libraries included with rpi-chromium-mods and some others I found in other packages. Turns out though that build isn't 100% so I'm just going to fix my package.

edit - seems as though it was on my side having ethernet and wifi hooked up at same time. Great job!!!!
I have no idea what you're talking about. It doesn't need any extra libraries and because rpi-chromium-mods is still installed, no need to uninstall because it just overwrites itself.

It's also compiled for ARMv6, it's just that widevine only works on Armv7.
Last edited by kusti8 on Mon Mar 06, 2017 11:47 am, edited 1 time in total.
There are 10 types of people: those who understand binary and those who don't.

cjan
Posts: 912
Joined: Sun May 06, 2012 12:00 am

Re: Google Chrome on Raspbian (Failed to open primary graphi

Mon Mar 06, 2017 11:17 am

knuxyl wrote:
cjan wrote:installed, chromium about is 51.0.2704.91 not 56.0.2924.110.
btw, does it compiled by armv7 ?
the latest package is 56.0.2924.84
you must be installing the older package, or you didn't install it right.

I don't know anything about what goes on during compilation, kusti8 did that. It compiled for armhf which requires at least armv7.
we are talking about your build not Kusti8's in your sub-forum, right?
and, just do ./install.sh.

Return to “Advanced users”