Page 1 of 1

Release the framebuffer

Posted: Thu Nov 24, 2016 8:33 pm
by _Mark_
Hi!
Some years ago I ran a buildroot environment on RPi(2) with Qt5 (eglfs) without X. I was launching omxplayer and it worked flawlessly on the "top" of my QML application (I know there is no a "top" with framebuffer...).

Now I'm doing the same thing with Rasbian Jessie Lite and it doesn't work. When I launch omxplayer I hear the sound but no video. It works only if I start my application without any GUI.

Is there something to do in Rasbian to "release" the fb, or to temporary set it to another application?

Re: Release the framebuffer

Posted: Thu Nov 24, 2016 10:35 pm
by dividuum
You can probably just force omxplayer to use a more foregroundy layer. I don't have a Pi nearby, but I think it's the --layer argument for omxplayer. Use something like 200 and you'll probably see the video layer again. If you're interested in what's going on behind the scenes, you might have a look at a blog post I wrote about the hardware video scaleer. Another option would probably be to acutally release the framebuffer, but the first option seems more sensible to me.

Re: Release the framebuffer

Posted: Fri Nov 25, 2016 8:35 am
by _Mark_
Great! It works. I learned somthing new thankful to your answer.