awneil
Posts: 8
Joined: Wed Dec 10, 2014 4:56 pm
Location: Basingstoke, Hants, UK
Contact: Website

BLE Connection to Nordic UART Service (NUS).

Thu Sep 29, 2016 1:37 pm

Related: viewtopic.php?f=63&t=161352

I'm trying to use an RPi-3 to communicate with a BLE device using Nordic's proprietary UART service ("NUS"):

https://infocenter.nordicsemi.com/index ... _eval.html

Getting there gradually, but if anyone has any hints, tips - or a full working solution - that would be a great help!

Tarcas
Posts: 740
Joined: Thu Jan 09, 2014 5:38 am
Location: USA

Re: BLE Connection to Nordic UART Service (NUS).

Tue Mar 20, 2018 1:48 am

I am trying to do exactly the same thing. Did you manage to make any headway?
I'm using an nRF52832, care of a Fanstel module soldered to a (self-designed) breakout board.
This works great when connected to my smartphone. I'm able to connect, and send serial commands to turn my onboard LEDs on and off.
With the Pi, I'm able to connect, but I'm not able to pair, and I haven't gotten serial to work either. I've attempted numerous tutorials and none of them have worked for me.

I would welcome any suggestions. I'm using an RPi 3 (non-plus) with the 2017-09-07-raspbian-stretch.img image updated after the 3/2018 (3b plus) update, although I was working on this before that update was released as well.

User avatar
Douglas6
Posts: 4440
Joined: Sat Mar 16, 2013 5:34 am
Location: Chicago, IL

Re: BLE Connection to Nordic UART Service (NUS).

Tue Mar 20, 2018 1:06 pm

I wrote some code for communicating with an HM-10 here: viewtopic.php?f=28&t=193923&p=1232385&h ... y#p1214606.

The NUS service will be different, but it might help.

Return to “Advanced users”

Who is online

Users browsing this forum: No registered users and 8 guests