tech_monkey
Posts: 130
Joined: Fri Mar 09, 2012 6:12 pm

ME-TV on RPi

Sat Aug 18, 2012 3:47 pm

Does anyone know if ME TV will work with the PI and if so which distro is the best to use.
https://launchpad.net/me-tv
http://www.casatech.eu

User avatar
redhawk
Posts: 3465
Joined: Sun Mar 04, 2012 2:13 pm
Location: ::1

Re: ME-TV on RPi

Sat Aug 18, 2012 4:04 pm

If it support OpenMax then in theory it should work however you are limited to hardware decoding of h.264 content not mpeg-2.

Richard S.

woi_doi
Posts: 15
Joined: Fri Oct 12, 2012 4:35 pm

Re: ME-TV on RPi

Mon Nov 05, 2012 4:35 pm

While waiting for live-tv playback to be sorted out on XBMC, I managed to install Me-Tv on the pi using the armhf build located here http://packages.debian.org/wheezy/armhf/me-tv/download. I have a Sony PlayTV adapter that can use the Dipcom 7000 drivers so was hopeful.

Surprisingly it worked (poorly). I brought over a channels.conf file I had generated for Ireland (where I am). It scans the muxes and found all the channels available via terrestrial. We have DVB-T here using MPEG-4, but unfortunately the hardware acceleration doesn't kick in so playback is very stuttery on the SD channels and a no go on HD. But at least it shows that it could work if hard acceleration was able to be enabled on it. And in fairness to Me-Tv, it works better than XBMC with MPEG-4 at the moment as it tends to crash it.

It may be an issue for it's libxine-1 dependencies rather than Me-Tv itself. I shall have to investigate further!

robb01
Posts: 1
Joined: Sun Nov 11, 2012 10:51 am

Re: ME-TV on RPi

Sun Nov 11, 2012 11:25 am

Hi
Did you need to use a powered usb hub for this to work or was it plugged in directly to the Pi?
I found the device was recognised but did not load the dvb-usb-dib0700 module nor light the red led. The 7-port powered hub I used was a no-brand chinese (ID 03eb:0902 Atmel Corp. 4-Port Hub 2-off) so I am waiting on a Targus ACH81AU from the http://elinux.org/RPi_VerifiedPeripherals list.
Had big hopes for using the Playtv unit on Xbian but from what you say I won't get too excited.
Me-TV on the laptop works fine with this device though.

woi_doi
Posts: 15
Joined: Fri Oct 12, 2012 4:35 pm

Re: ME-TV on RPi

Fri Dec 14, 2012 2:46 am

robb01 wrote:Hi
Did you need to use a powered usb hub for this to work or was it plugged in directly to the Pi?.
Sorry for the lateness of reply as I mustn't have auto notify on or something, and I'm sure you've sorted this out by now. The PlayTV adapter draws too much power from the Pi so you'll need to go through a powered hub, (I got mine from Maplin)

Still haven't been able to get MeTV to use the GPU for playback. I've been having mixed success with Raspbmc, sometime plays stream correctly, usually not though.

I feel they are getting close to having t stable though!

Return to “Advanced users”