dom
Raspberry Pi Engineer & Forum Moderator
Raspberry Pi Engineer & Forum Moderator
Posts: 5318
Joined: Wed Aug 17, 2011 7:41 pm
Location: Cambridge

Re: Linux kernel is now 4.0

Wed Jan 13, 2016 9:43 pm

PhilE wrote:@jofemodo A change to restore the special uart0 clock-rate behaviour will be in the next rpi-update firmware release. There are a number of other changes waiting to go in so you shouldn't have to wait long.
This is now in rpi-update firmware.

jofemodo
Posts: 8
Joined: Tue Aug 04, 2015 4:01 am

Re: Linux kernel is now 4.0

Thu Jan 14, 2016 1:34 pm

Hi PhilE! It works perfectly!
Thanks !!
dom wrote:
PhilE wrote:@jofemodo A change to restore the special uart0 clock-rate behaviour will be in the next rpi-update firmware release. There are a number of other changes waiting to go in so you shouldn't have to wait long.
This is now in rpi-update firmware.

WebDesZ
Posts: 3
Joined: Sat Feb 20, 2016 12:49 pm

Re: Linux kernel is now 4.0

Sat Feb 20, 2016 12:52 pm

Since the latest update I can not decrypt my volume with dm-crypt
It says that the "aes-xts-plain64-encryption" is not supported.


What has changed?

dom
Raspberry Pi Engineer & Forum Moderator
Raspberry Pi Engineer & Forum Moderator
Posts: 5318
Joined: Wed Aug 17, 2011 7:41 pm
Location: Cambridge

Re: Linux kernel is now 4.0

Sat Feb 20, 2016 3:15 pm

WebDesZ wrote:Since the latest update I can not decrypt my volume with dm-crypt
It says that the "aes-xts-plain64-encryption" is not supported.
Looks like an upstream regression/change. See:
https://github.com/Hexxeh/rpi-firmware/issues/109
https://bugzilla.kernel.org/show_bug.cgi?id=112631

GBee
Posts: 4
Joined: Sat Mar 19, 2016 10:44 am

Re: Linux kernel is now 4.0

Sat Mar 19, 2016 10:47 am

Is anyone able to use the experimental OpenGL driver with the latest kernel on a Raspberry Pi 3? I just get the Rainbow of Death (power supply is 2.5amp, no peripherals attached).

User avatar
bleep42
Posts: 149
Joined: Wed Mar 07, 2012 12:43 pm
Location: Sussex

Re: Linux kernel is now 4.0

Sun Mar 20, 2016 7:00 pm

GBee wrote:Is anyone able to use the experimental OpenGL driver with the latest kernel on a Raspberry Pi 3? I just get the Rainbow of Death (power supply is 2.5amp, no peripherals attached).
Yes I get the same with a Pi3 another machine with a Pi2 still works ok, both were fully updated.
Regards Kevin.

dom
Raspberry Pi Engineer & Forum Moderator
Raspberry Pi Engineer & Forum Moderator
Posts: 5318
Joined: Wed Aug 17, 2011 7:41 pm
Location: Cambridge

Re: Linux kernel is now 4.0

Sun Mar 20, 2016 7:47 pm

GBee wrote:Is anyone able to use the experimental OpenGL driver with the latest kernel on a Raspberry Pi 3? I just get the Rainbow of Death (power supply is 2.5amp, no peripherals attached).
Works fine for me on Pi3 with BRANCH=next firmware/kernel.

Code: Select all

[email protected]:~ $ uname -a
Linux domnfs 4.4.6-v7+ #861 SMP Fri Mar 18 18:45:56 GMT 2016 armv7l GNU/Linux
[email protected]:~ $ vcgencmd version
Mar 18 2016 19:08:46 
Copyright (c) 2012 Broadcom
version d818511982ebad3cf49aa3487880e6e2bd08bee7 (clean) (release)
Running neverball in desktop.

User avatar
bleep42
Posts: 149
Joined: Wed Mar 07, 2012 12:43 pm
Location: Sussex

Re: Linux kernel is now 4.0

Fri Mar 25, 2016 4:08 pm

dom wrote:
GBee wrote:Is anyone able to use the experimental OpenGL driver with the latest kernel on a Raspberry Pi 3? I just get the Rainbow of Death (power supply is 2.5amp, no peripherals attached).
Works fine for me on Pi3 with BRANCH=next firmware/kernel.

Code: Select all

[email protected]:~ $ uname -a
Linux domnfs 4.4.6-v7+ #861 SMP Fri Mar 18 18:45:56 GMT 2016 armv7l GNU/Linux
[email protected]:~ $ vcgencmd version
Mar 18 2016 19:08:46 
Copyright (c) 2012 Broadcom
version d818511982ebad3cf49aa3487880e6e2bd08bee7 (clean) (release)
Running neverball in desktop.
Hi Dom,
At my last post I was running 4.1.19-v7+ #853 March 9
I have done another apt-get upgrade and am now running

Code: Select all

[email protected] ~ $ uname -a
Linux raspberrypi 4.1.19-v7+ #858 SMP Tue Mar 15 15:56:00 GMT 2016 armv7l GNU/Linux
[email protected] ~ $ vcgencmd version
Mar 15 2016 14:47:28 
Copyright (c) 2012 Broadcom
version 1bf9a9a77026af9128a339c82d72e331d3532ee4 (clean) (release)
The Pi is still running, hasn't crashed, as if I do Ctrl-Alt-F2 I can login and do a clean shutdown (blind as there is no display)
But I am still ending up with a completely blank (black) screen, after a boot up.
I initially get the full screen rainbow screen for about 10 seconds, then the screen goes off, there is still disk activity, but the screen stays black, and never comes back.
I am using a HDMI to VGA adaptor on my HDMI port (monitor doesn't have HDMI and I'm using the DVI-D input on the monitor for another computer, so only leaving a VGA input.) Could this be causing a problem? I'm assuming it should not. If I return to normal non accelerated operation the screen returns perfectly.
Regards, Kevin.

Update, it is being caused by the HDMI to VGA adaptor :-( I decided to dig out an HDMI to DVI-D cable and try that and it works, (I'm using it as I type this) so there is something about either having to use VGA mode (1920x1080 60Hz is what the monitor says it's being driven with), or the actual HDMI TO VGA adaptor that the new driver does not like. Kevin.

Return to “Advanced users”