W9RAN
Posts: 40
Joined: Wed Feb 08, 2012 10:39 pm

broken atomic modeset userspace detected, disabling atomic

Sat Sep 19, 2020 4:39 pm

New headless Pi 4, dmesg is filled with this message at the rate of one per second:

broken atomic modeset userspace detected, disabling atomic

How do I make it stop?

Bob

6by9
Raspberry Pi Engineer & Forum Moderator
Raspberry Pi Engineer & Forum Moderator
Posts: 9490
Joined: Wed Dec 04, 2013 11:27 am
Location: ZZ9 Plural Z Alpha, aka just outside Cambridge.

Re: broken atomic modeset userspace detected, disabling atomic

Sun Sep 20, 2020 8:00 am

What distribution are you running? And kernel and firmware versions?

Some application you are running is broken in the way that it is trying to configure the screen. You need to work out which application that is.
Software Engineer at Raspberry Pi Trading. Views expressed are still personal views.
I'm not interested in doing contracts for bespoke functionality - please don't ask.

HBrydon
Posts: 10
Joined: Fri Oct 26, 2012 3:29 pm

Re: broken atomic modeset userspace detected, disabling atomic

Thu Oct 15, 2020 8:27 pm

W9RAN wrote:
Sat Sep 19, 2020 4:39 pm
New headless Pi 4, dmesg is filled with this message at the rate of one per second:

broken atomic modeset userspace detected, disabling atomic

How do I make it stop?

Bob
I have experienced this as well. For my situation, the problem is with VNC.

I am running headless, and have VNC enabled so that I can connect remotely from another system. VNC on the pi expects to interface with either a virtual or a real screen, and seems to be upset if a realistic one does not exist, which will happen if a screen resolution is not set. You will find that if you connect to it with a VNC session, you will get a tiny screen that says "Cannot currently show the desktop" and you can't do anything with the desktop. The /var/log/messages and /var/log/syslog will show plenty of the "broken atomic modeset userspace" messages as you describe.

==> Solution: If you are running it headless and try to connect remotely with VNC, you need to establish a screen resolution. You can do this from the command line interface with raspi-config.

Code: Select all

pi@pi1: $ sudo raspi-config
Select "Advanced options" -> "Resolution" and select a value (any). Exit and reboot. You should now be able to connect via VNC, but the resolution may or may not be the value that you selected with raspi-config. Set it to what you want and reboot again. Setting it the second time should preserve what you want, and the messages in /var/log/messages and /var/log/syslog will go away.


[This is also described correctly with the "raspi-config" option at https://www.tomshardware.com/how-to/fix ... spberry-pi .]

Return to “Advanced users”