gwaines
Posts: 1
Joined: Fri Oct 19, 2018 11:35 am

How to disable auto-configuration of link local address on raspberry pi when no DHCP response

Fri Oct 19, 2018 11:47 am

I am running Kubernetes on raspberry pi.
The raspberry pi is a kube worker.

I was previously using a wired connection and had DHCP disabled.

-----------
But now switching things to wifi.

I am using wifi, configured with rasp-config to use DHCP.
My wireless connection comes up fine.

However when I do my 'kubeadm join ...' which fires up kube-proxy and flannel containers, the flannel container creates a flannel.1 interface and configures an IP Address on that interface ...

HOWEVER dhcpcd on the raspberry tries to DHCP out that interface ... gets no response ... and then a link local address gets configured on that interface as a second IP Address .... and this appears to be causing problems with flannel ... (i.e. saw the same issue when I was using wired connection and disabled DHCP and used static IP Address to get around this issue)

So QUESTIONS:

a) is there a way to disable auto-configuration of link local address on PI when no dhcp response occurs ?

or

b) is it possible to configure static IP address for wireless connection on PI ? (i tried quickly and couldn't get it to work)


Gre.g

Andyroo
Posts: 434
Joined: Sat Jun 16, 2018 12:49 am
Location: Side of the hill in Lincolnshire

Re: How to disable auto-configuration of link local address on raspberry pi when no DHCP response

Fri Oct 19, 2018 12:43 pm

Static IPs for WiFi on the Pi is possible.

One of the best threads for this is https://raspberrypi.stackexchange.com/q ... ip-address as it covers multiple operating system versions :lol:

Basically, to set a static IP address up you add something along the lines of

Code: Select all

       interface wlan0
       static ip_address=10.1.1.31/24
       static routers=10.1.1.1
       static domain_name_servers=10.1.1.1
to /etc/dhcpcd.conf

Note the article also shows you how to disable interface configuration and another way to set statics - neither of which I have tried :twisted: :roll:
Need Pi spray - these things are breeding in my house...

epoch1970
Posts: 2075
Joined: Thu May 05, 2016 9:33 am
Location: Paris, France

Re: How to disable auto-configuration of link local address on raspberry pi when no DHCP response

Fri Oct 19, 2018 2:26 pm

See "man dhcpcd": options denyinterface, noipv4ll, nodhcp...
"S'il n'y a pas de solution, c'est qu'il n'y a pas de problème." Les Shadoks, J. Rouxel

Return to “Advanced users”