torontoraptors
Posts: 5
Joined: Thu Jun 28, 2012 6:44 pm

Black and white Raspberry pi with composite cable

Thu Jun 28, 2012 6:52 pm

Hello comunity,
My pi as just arrived and it's great=)
I managed to create the sd card and try the pi out on a hdmi tv and it worked very well. But.. now I have a problem:
-I tried to connect it to a older tv(without hdmi but actually good too...) and I only get black and white image=(

This is a shame, anybody knows how to fix this?
PS: I already tried writting sdtv_mode=2 in the config.txt like one of them foruns heres suggested=(

bredman
Posts: 1415
Joined: Tue Jan 17, 2012 2:38 pm

Re: Black and white Raspberry pi with composite cable

Fri Jun 29, 2012 8:25 am

This really does look like a PAL/NTSC problem. Setting the SD-TV mode to 2 should have fixed it.

Try the following command to be sure that you have written the config.txt file properly.

cat /boot/config.txt

Also, remember that there must be at least one newline at the end of the file, do not leave the last line hanging without a newline at the end.

User avatar
Burngate
Posts: 4925
Joined: Thu Sep 29, 2011 4:34 pm
Location: Berkshire UK
Contact: Website

Re: Black and white Raspberry pi with composite cable

Fri Jun 29, 2012 3:18 pm

From your name, and knowing from school geography where Toronto is, can I guess that your TV is for the North American continent? In which case don't you want
sdtv_mode=0
0 = NTSC 1 = NTSC (no ped) 2 = PAL 3 = PAL/525/60 default is 0
Or remove that line altogether since the default is NTSC

torontoraptors
Posts: 5
Joined: Thu Jun 28, 2012 6:44 pm

Re: Black and white Raspberry pi with composite cable

Fri Jun 29, 2012 11:22 pm

This is weird...when I went to try your advice when I conected it was with colour( though the image was to far to the left and cut a piece of the screen) I then tried to chance the conector position and it went back to B and W. I revert but it was still black and white, I tried the new line thing and check the spelling and everything was ok, I dunno what I'm doing wrong.. I have already checked that if by acident I misconected the cable, but I didn't, pushing it any deeper will come the other side.
I don't understand how at one point it was so colourfull and now it's so dark=(

PS: even though my names says toronto I'm from , and I'm in Europe:)

torontoraptors
Posts: 5
Joined: Thu Jun 28, 2012 6:44 pm

Re: Black and white Raspberry pi with composite cable

Sat Jun 30, 2012 11:31 am

well, I don't know what I did but without changing anything in the pi itself I managed to make it work --''

Thanks to everyone who took the time to answer my cry for help

User avatar
Burngate
Posts: 4925
Joined: Thu Sep 29, 2011 4:34 pm
Location: Berkshire UK
Contact: Website

Re: Black and white Raspberry pi with composite cable

Sat Jun 30, 2012 12:20 pm

As you say, wierd!
So somehow, the TV managed to mis-time the picture and move it to the left, and found the colour burst* and displayed colour.
Every other time it manages tolock to the syncs correctly, but can't find the colour burst.

Without a 'scope and a screwdriver I couldn't be certain, but it does sound as if the TV is broke. Unless the signal from the Pi is way out of spec.

*a chunk of 10 cycles of the colour subcarrier just after the sync pulse on each line

Return to “Troubleshooting”

Who is online

Users browsing this forum: Daj1 ZiPi, Google [Bot] and 34 guests