dms1978
Posts: 7
Joined: Wed May 23, 2012 9:01 am

Black screen and pointer arrow after typing startX

Thu Jun 28, 2012 7:15 am

Hi everybody,

Running Rpi with debian6-19-04-2012 on a Kingston 4gb SD card.
USB keyboard; USB mouse; HDMI to tv set.

Starts up, I login successfully.
I type startx, I get: xauth: (stdin):2: unknown command "66fbf772258ffba25bff1857c284454f"
then a black screen with a mouse pointer arrow in the middle...the pointer does not move (mouse is correctly plugged into USB).
It stays like that forever, tried to wait an hour, some kind of screensaver comes up but nothing else.
Tried to reboot 3-4 times but nothing changed.

any clue?
(keep in mind that I am an absolute beginner)

thanks Demis

dms1978
Posts: 7
Joined: Wed May 23, 2012 9:01 am

Re: Black screen and pointer arrow after typing startX

Mon Jul 02, 2012 4:57 am

Does anyone have a clue?

I tried formatting and reburning the image on the SD card but nothing changed.

dms1978
Posts: 7
Joined: Wed May 23, 2012 9:01 am

Re: Black screen and pointer arrow after typing startX

Tue Jul 03, 2012 12:48 pm

tried to re burn the debian for the 3rd time...in case something went wrong the first 2 times I tried.

Now my sd card is magically "read only" and I can't format it...great!

I am starting to lose faith guys...I wonder how in the world any non-techie kid of 12 is ever going to be able to use this stuff.
For the moment my experience with the Pi is a complete failure.

Nr90
Posts: 216
Joined: Sat Nov 26, 2011 12:39 pm

Re: Black screen and pointer arrow after typing startX

Tue Jul 03, 2012 1:57 pm

You could give the Debian wheezy beta a go.
It worked very well out of the box for me.

Just to make sure, your sd card isn't switched to read only, is it?

pInvoke
Posts: 3
Joined: Thu Jun 28, 2012 8:05 am

Re: Black screen and pointer arrow after typing startX

Tue Jul 03, 2012 2:54 pm

dms1978 wrote:tried to re burn the debian for the 3rd time...in case something went wrong the first 2 times I tried.

Now my sd card is magically "read only" and I can't format it...great!

I am starting to lose faith guys...I wonder how in the world any non-techie kid of 12 is ever going to be able to use this stuff.
For the moment my experience with the Pi is a complete failure.
Just because you are not able to 'burn' the image onto the sd card, doesn't mean anyone can't do it.
the SD card is not read only, you just copied it wrong.

How did you copy the image to the sd card?

dms1978
Posts: 7
Joined: Wed May 23, 2012 9:01 am

Re: Black screen and pointer arrow after typing startX

Tue Jul 03, 2012 3:54 pm

Nr90 wrote:You could give the Debian wheezy beta a go.
It worked very well out of the box for me.

Just to make sure, your sd card isn't switched to read only, is it?
It wasn't the "read only" switch.
Don't know what it was...I solved the "read only" problem formatting in a Nikon D90 camera :)
I will try "Wheezy" in the 4th image burning attemp.

Thanks for the help.

Steep
Posts: 145
Joined: Fri May 18, 2012 8:03 pm

Re: Black screen and pointer arrow after typing startX

Tue Jul 03, 2012 5:18 pm

I had a similar problem with Squeezy, keyboard worked at the command line but not in X. Wheezy and other distros (I'm running Raspbian now) solved that.

As for burning images, I've got 4 SD cards and keep trying different things so I've probably burned twenty or thirty images now. Once you get a good working installation, keep that safe on an SD card and mess about with another.

dms1978
Posts: 7
Joined: Wed May 23, 2012 9:01 am

Re: Black screen and pointer arrow after typing startX

Wed Jul 04, 2012 7:11 am

Steep wrote:I had a similar problem with Squeezy, keyboard worked at the command line but not in X. Wheezy and other distros (I'm running Raspbian now) solved that.
My problem was that X did not start at all. Just a black screen with a stuck pointer arrow in the middle.

Problem solved now
. I burned the same identical Debian image on the same sd card and what didn't work out the first two times worked the 3rd time around. Funny.

Now I'm trying to solve a couple more snags:
1) mouse is not recognized
2) usb wifi adapter neither (D-Link USB DWL-G132)

Thanks to everyone who got interested.

natebot13
Posts: 4
Joined: Wed Oct 17, 2012 6:54 am

Re: Black screen and pointer arrow after typing startX

Wed Oct 24, 2012 1:08 am

Did you end up getting that Dlink DWL G-132 to work? I have one of those USB adapters, and have tried the instructions at http://wiki.debian.org/ar5523 and I almost got it, but the package wouldn't build halting at applying patches to the build... "Patch does not apply." I am using Raspbian Wheezy on a Raspberry Pi model B rev 2 (512mb version). Do you know of a way to get this wifi adapter to work?
Thanks.

hanna
Posts: 19
Joined: Sat Dec 22, 2012 4:25 pm

Re: Black screen and pointer arrow after typing startX

Wed Jan 02, 2013 1:30 am

also interested if anyone uses this D-Link DWL-G132 dongle...

Return to “Troubleshooting”