nbk7
Posts: 8
Joined: Wed Mar 11, 2015 9:09 am

Re: Analog audio problems? post comments here!

Thu Mar 26, 2015 2:10 pm

Hi all,

Poor analog audio quality:
If I use the analog output, I get a distorted sound which is really noticable once the volume is reduced.

This is what I tried:
- different images such as: raspbmc, osmc, volumio
- different settings including different kernel profiles and basically all audio settings available within the mentioned projects
- different devices: raspberry 1B+ and raspberry 2
- different usb power supplies
- tried it with earphones and with an amplifier

...to no avail. The sound stays distorted. The distortion sounds a bit like if you can't find the perfect frequency for your analog radio station. It doesnt amplify by increasing the volume so its barely/not noticable once you turn the music louder - unless the passage in your song is not loud enough or the song ends. If you mute/pause the song, the distortion is completely gone - probably because the voltage of the analog output is set to 0 at that moment.

So I m a bit surprised that I couldnt find much regarding this problem in the internet because this seems to be a general issue with the audio output...

petel-pi
Posts: 1
Joined: Mon Apr 27, 2015 2:24 pm

Re: Analog audio problems? post comments here!

Mon Apr 27, 2015 3:43 pm

Hi,

I'm hoping someone can help. We are using a Raspberry Pi model 2. We bought it and installed Raspbian via NOOBS in February 2015.

According to earlier posts, this means we should have the latest distro which has solved the clicking problem. But we are still getting a clicking.

Soecifically: the moment we plug in the speakers (using 3.5 mm audio jack) we hear clicking. We know this isn't a problem with the speakers as we tested them with an iPHone and they worked fine.

Is this a known problem? Is there a chance we downloaded an old distro? How can we check the version?

Thank you!!

Claytron
Posts: 11
Joined: Fri Feb 20, 2015 1:49 am

Re: Analog audio problems? post comments here!

Thu May 14, 2015 2:44 am

Check this thread. viewtopic.php?f=38&t=90495&p=758340#p758340

Once you use "disable_audio_dither=1" to config.txt, you will see that that the hiss / white noise differs between distributions for the Pi 2 when sound is played. (Raspian has noise whilst playing Py games, Retropie seems to have no issues) Still not sure what configuration / setting is causing the issue though. We need help from more advanced users.

nbk7 wrote:Hi all,

Poor analog audio quality:
If I use the analog output, I get a distorted sound which is really noticable once the volume is reduced.

This is what I tried:
- different images such as: raspbmc, osmc, volumio
- different settings including different kernel profiles and basically all audio settings available within the mentioned projects
- different devices: raspberry 1B+ and raspberry 2
- different usb power supplies
- tried it with earphones and with an amplifier

...to no avail. The sound stays distorted. The distortion sounds a bit like if you can't find the perfect frequency for your analog radio station. It doesnt amplify by increasing the volume so its barely/not noticable once you turn the music louder - unless the passage in your song is not loud enough or the song ends. If you mute/pause the song, the distortion is completely gone - probably because the voltage of the analog output is set to 0 at that moment.

So I m a bit surprised that I couldnt find much regarding this problem in the internet because this seems to be a general issue with the audio output...

kj5fa
Posts: 2
Joined: Wed May 20, 2015 4:54 am

Re: Analog audio problems? post comments here!

Wed May 20, 2015 5:06 am

I have a new Raspberry Pi2 running Raspbian which I installed from the latest version of Noobs. I am fairly new to Raspberry Pi and Linux but been playing with it for about a year now on/off. I had issues getting wifi setup because wpa_gui didn't show up on the desktop or menu, but finally have that going.

Now I am trying to change the default sound card. I have a little usb sound card I would like to have setup as default but it seems to always stay as the bcm2835. I have tried searching for answers to this but nothing has worked so far. Has anyone ran into this issue?

texy
Forum Moderator
Forum Moderator
Posts: 5119
Joined: Sat Mar 03, 2012 10:59 am
Location: Berkshire, England

Re: Analog audio problems? post comments here!

Wed May 20, 2015 8:51 am

kj5fa wrote:I have a new Raspberry Pi2 running Raspbian which I installed from the latest version of Noobs. I am fairly new to Raspberry Pi and Linux but been playing with it for about a year now on/off. I had issues getting wifi setup because wpa_gui didn't show up on the desktop or menu, but finally have that going.

Now I am trying to change the default sound card. I have a little usb sound card I would like to have setup as default but it seems to always stay as the bcm2835. I have tried searching for answers to this but nothing has worked so far. Has anyone ran into this issue?
Hi and welcome to the forum.
To use a usb sound card over the default bcm2835 you need to edit the file /etc/modprobe.d/alsa-base.conf

See this tutorial
http://computers.tutsplus.com/articles/ ... -mac-55876

hope the helps,
Texy
Various male/female 40- and 26-way GPIO header for sale here ( IDEAL FOR YOUR PiZero ):
https://www.raspberrypi.org/forums/viewtopic.php?f=93&t=147682#p971555

kj5fa
Posts: 2
Joined: Wed May 20, 2015 4:54 am

Re: Analog audio problems? post comments here!

Wed May 20, 2015 12:15 pm

Thanks texy for responding. I had tried doing what this article instructed. But even after the changes, when I run amixer, it has always shown the same with the 'PCM' instead of with speaker. I also tried making it read:
"options snd-usb-audio index=0"
and also with adding the line
"options snd_bcm2835 index=1"

I have even added the /etc/asound.conf which didn't exist or was empty initially. Should I need this file?

There seems to be simething that keeps the PCM card as the default no matter what.

I may have garbled something up that the Pi is defaulted back??? I will re-try again this evening. Hopefully with a clear mind I can see what is wrong. Or at least I can post my results.

Thanks,
Kevin

N8OHU
Posts: 2
Joined: Wed Oct 31, 2012 11:04 pm

Re: Analog audio problems? post comments here!

Sat May 30, 2015 5:19 pm

texy,

I'm having issues with the USB sound card being found by amixer but not by an application I want to use it with; the only thing this application is finding on a consistent basis is the native sound output, but it will not work without some form of audio input configured. This is even after making the change to the alsa-base.conf file and rebooting.

hvanschaick
Posts: 5
Joined: Sun Feb 01, 2015 2:19 pm

alsaaudio problems

Mon Jun 01, 2015 6:43 pm

Hi,

On a previous version of raspian I had the USB audio card working fine, however, is it resisting now.

The X Environment doesn't want to budge from HDMI audio (that doesn't work) to the USB audio card.
Setting audio preferences to in the preferences pane in X doesn;t want to store the newly selected default (pimixer)

I have modified the alsa-base.conf in to "options snd-usb-audio index=0" and the "options snd-bcm2835 index=1".

The alsamixer does not default to the usb-audio...

aplay -L returns this:
[email protected] /etc/modprobe.d $ aplay -L
null
Discard all samples (playback) or generate zero samples (capture)
sysdefault:CARD=Device
USB Audio Device, USB Audio
Default Audio Device
front:CARD=Device,DEV=0
USB Audio Device, USB Audio
Front speakers
surround40:CARD=Device,DEV=0
USB Audio Device, USB Audio
4.0 Surround output to Front and Rear speakers
surround41:CARD=Device,DEV=0
USB Audio Device, USB Audio
4.1 Surround output to Front, Rear and Subwoofer speakers
surround50:CARD=Device,DEV=0
USB Audio Device, USB Audio
5.0 Surround output to Front, Center and Rear speakers
surround51:CARD=Device,DEV=0
USB Audio Device, USB Audio
5.1 Surround output to Front, Center, Rear and Subwoofer speakers
surround71:CARD=Device,DEV=0
USB Audio Device, USB Audio
7.1 Surround output to Front, Center, Side, Rear and Woofer speakers
iec958:CARD=Device,DEV=0
USB Audio Device, USB Audio
IEC958 (S/PDIF) Digital Audio Output
sysdefault:CARD=ALSA
bcm2835 ALSA, bcm2835 ALSA
Default Audio Device

What am I missing here??? I thinks it is odd to have two sysdefault entries, but I have no clue how to correct that...

I am using the latest and greatest: Linux rbpi3 3.18.14-v7+ #792 SMP PREEMPT Sat May 23 16:19:32 BST 2015 armv7l GNU/Linux

on a PI 2...

any comments appreciated

anglerfish96
Posts: 2
Joined: Tue Jun 09, 2015 4:13 am

Re: Analog audio problems? post comments here!

Tue Jun 09, 2015 4:17 am

I'm having the same problem with my RPi2b not allowing me to change the default to my USB snd card.

Anyone figure a fix yet?

*EDIT*

Ubuntu Mate, Audiotechnical USB soundcard. Tried all the fixes listed so far but, as the previous poster states, it always either ends up with the internal as 0 or, worse, there's no sign of the AT2USB at all.
Last edited by anglerfish96 on Tue Jun 09, 2015 8:33 pm, edited 1 time in total.

Niamh
Posts: 13
Joined: Thu Sep 19, 2013 2:32 pm

Re: Analog audio problems? post comments here!

Tue Jun 09, 2015 6:48 pm

I have a Raspberry Pi B+ V1.2

I had trouble getting any sound output. I created a bit of Twinkle Twinkle in Sonic Pi and used that as a test piece. I sorted that with 'raspi-config' and forced the sound through the 3.5 audio jack. That was fine up to a point till I rebooted and had to go through the process again and again as 'sudo alsactl store' did not appear to work.

I then added a usb Creative Soundblaster and after a lot of searching online I got Sonic Pi output to work with that. I have an idea why it may be working but I am not sure if my changes hinder the recording of input into Sonic Pi or into Audacity which I have also installed. I need to record sound. I have a small microphone that I plug into the mic socket on the Creative Soundblaster. On alsamixer the mic shows MM in the box and I have set it to 65. The gain is set to MM which from what I'm reading appears to be correct. I tested this Mic on a PC using Skype this afternoon and it was working fine.

I've listed out information that I think is relevant to this query. If you can give me some pointers on recording sound to the rpi it would be appreciated.



aplay /usr/share/scratch/Media/Sounds/Vocals/Singer1.wav
Playing WAVE '/usr/share/scratch/Media/Sounds/Vocals/Singer1.wav' : Signed 16 bit Little Endian, Rate 11025 Hz, Mono
I did not hear anything

lsusb
Bus 001 Device 002: ID 0424:9514 Standard Microsystems Corp.
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 001 Device 003: ID 0424:ec00 Standard Microsystems Corp.
Bus 001 Device 004: ID 046d:c044 Logitech, Inc. LX3 Optical Mouse
Bus 001 Device 005: ID 041e:30d3 Creative Technology, Ltd Sound Blaster Play!
Bus 001 Device 006: ID 214b:7000
Bus 001 Device 007: ID 413c:2111 Dell Computer Corp.
Bus 001 Device 008: ID 0bda:8176 Realtek Semiconductor Corp. RTL8188CUS 802.11n WLAN Adapter


sudo nano /etc/modprobe.d/alsa-base.conf
# autoloader aliases
install sound-slot-0 /sbin/modprobe snd-card-0
install sound-slot-1 /sbin/modprobe snd-card-1
install sound-slot-2 /sbin/modprobe snd-card-2
install sound-slot-3 /sbin/modprobe snd-card-3
install sound-slot-4 /sbin/modprobe snd-card-4
install sound-slot-5 /sbin/modprobe snd-card-5
install sound-slot-6 /sbin/modprobe snd-card-6
install sound-slot-7 /sbin/modprobe snd-card-7
# Cause optional modules to be loaded above generic modules
install snd /sbin/modprobe --ignore-install snd && { /sbin/modprobe --quiet snd-ioctl32 ; /sbin/modprobe --quiet snd-seq ; : ; }
install snd-rawmidi /sbin/modprobe --ignore-install snd-rawmidi && { /sbin/modprobe --quiet snd-seq-midi ; : ; }
install snd-emu10k1 /sbin/modprobe --ignore-install snd-emu10k1 && { /sbin/modprobe --quiet snd-emu10k1-synth ; : ; }
# Keep snd-pcsp from beeing loaded as first soundcard
options snd-pcsp index=-2
# Keep snd-usb-audio from beeing loaded as first soundcard
options snd-usb-audio index=0
options snd_bcm2835 index=1
# Prevent abnormal drivers from grabbing index 0
options bt87x index=-2
options cx88_alsa index=-2
options snd-atiixp-modem index=-2
options snd-intel8x0m index=-2
options snd-via82xx-modem index=-2

Audacity Audio Device

Default capture device number: 0
Default playback device number: 8
==============================
Device ID: 0
Device name: USB Device 0x41e:0x30d3: USB Audio (hw:0,0)
Host name: ALSA
Input channels: 1
Output channels: 2
Low Input Latency: 0.011610
Low Output Latency: 0.011610
High Input Latency: 0.046440
High Output Latency: 0.046440
Supported Rates:
44100
48000
==============================
Device ID: 1
Device name: bcm2835 ALSA: bcm2835 ALSA (hw:1,0)
Host name: ALSA
Input channels: 0
Output channels: 2
Low Input Latency: -1.000000
Low Output Latency: 0.011610
High Input Latency: -1.000000
High Output Latency: 0.046440
Supported Rates:
8000
9600
11025
12000
15000
16000
22050
24000
32000
44100
48000
==============================
Device ID: 2
Device name: sysdefault
Host name: ALSA
Input channels: 128
Output channels: 128
Low Input Latency: 0.042653
Low Output Latency: 0.042653
High Input Latency: 0.046440
High Output Latency: 0.046440
Supported Rates:
8000
9600
11025
16000
22050
32000
44100
48000
88200
==============================
Device ID: 3
Device name: front
Host name: ALSA
Input channels: 0
Output channels: 2
Low Input Latency: -1.000000
Low Output Latency: 0.011610
High Input Latency: -1.000000
High Output Latency: 0.046440
Supported Rates:
44100
48000
==============================
Device ID: 4
Device name: surround40
Host name: ALSA
Input channels: 0
Output channels: 2
Low Input Latency: -1.000000
Low Output Latency: 0.011610
High Input Latency: -1.000000
High Output Latency: 0.046440
Supported Rates:
44100
48000
==============================
Device ID: 5
Device name: iec958
Host name: ALSA
Input channels: 0
Output channels: 2
Low Input Latency: -1.000000
Low Output Latency: 0.011610
High Input Latency: -1.000000
High Output Latency: 0.046440
Supported Rates:
44100
48000
==============================
Device ID: 6
Device name: spdif
Host name: ALSA
Input channels: 1
Output channels: 2
Low Input Latency: 0.011610
Low Output Latency: 0.011610
High Input Latency: 0.046440
High Output Latency: 0.046440
Supported Rates:
44100
48000
==============================
Device ID: 7
Device name: dmix
Host name: ALSA
Input channels: 0
Output channels: 2
Low Input Latency: -1.000000
Low Output Latency: 0.042667
High Input Latency: -1.000000
High Output Latency: 0.042667
Supported Rates:
48000
==============================
Device ID: 8
Device name: default
Host name: ALSA
Input channels: 0
Output channels: 2
Low Input Latency: -1.000000
Low Output Latency: 0.011610
High Input Latency: -1.000000
High Output Latency: 0.046440
Supported Rates:
8000
9600
11025
12000
15000
16000
22050
24000
32000
44100
48000
==============================
Selected capture device: 0 - USB Device 0x41e:0x30d3: USB Audio (hw:0,0)
Selected playback device: 8 - default
Supported Rates:
44100
48000
==============================
Available mixers:
==============================
Available capture sources:
==============================
Available playback volumes:
0 - Speaker:0
1 - Mic:0
==============================
Capture volume is emulated
Playback volume is emulated

User avatar
ragnarjensen
Posts: 329
Joined: Wed May 15, 2013 6:13 pm
Location: Stockholm, Sweden
Contact: Website

Re: Analog audio problems? post comments here!

Thu Jun 11, 2015 3:46 pm

MM in alsamixer means "Muted". With the input selected, press the M key. It should change to "OO", meaning "Open".
--
Ragnar

Niamh
Posts: 13
Joined: Thu Sep 19, 2013 2:32 pm

Re: Analog audio problems? post comments here!

Mon Jun 15, 2015 8:23 pm

Thank you for that.

I changed it from MM to 00 and set a level of 65 but still no sound in.

I experimented with aplay on the Scratch media sounds and can now hear that output when i remove the creative soundblaster card.

MauHernandez
Posts: 1
Joined: Wed Jun 24, 2015 11:37 pm

Re: Analog audio problems? post comments here!

Wed Jun 24, 2015 11:49 pm

Hey guys I'm using a RBP2 when I do

Code: Select all

aplay sound.wav
says operation not permited, in the file i'm the owner, I'm on the audio group, even changed all permision to 777, when i try with sudo the RBP hangs out! It's driving me crazy!

MohitBagur
Posts: 19
Joined: Wed May 27, 2015 5:47 am
Location: Bangalore,Karnataka,India

Re: Analog audio problems? post comments here!

Fri Jun 26, 2015 2:05 pm

Hello all,
Since I design a lot of webpages, I have some experience in web based audio. So a simple solution. Start an X session, click on any mp3 file, it should open a dialog box which says, "Open With". Navigate to Internet drop down menu, and select Web browser. Make this the default. No omx, no nothing.

bsummer
Posts: 2
Joined: Wed Jun 17, 2015 9:56 pm

Re: Analog audio problems? post comments here!

Wed Jul 01, 2015 1:53 pm

I have a RPI2 B as a music on hold device. It works great except the volume level is very low when plugged into the aux port for phone system. The volume sounds great when plugged into powered speakers. Any suggestions for a inexpensive volume booster?

anglerfish96
Posts: 2
Joined: Tue Jun 09, 2015 4:13 am

Re: Analog audio problems? post comments here!

Wed Jul 01, 2015 5:19 pm

I have an Audio Technica ATR2USB, and it works great. It's about $15. There's cheaper options, though-- down to $2 or $3 if you're not worried too much about quality or speed. Just look on Amazon under "USB sound card". Most should work out of the box...

amcdonley
Posts: 137
Joined: Mon Jan 26, 2015 5:56 pm
Location: Florida, USA

My working config - Pi audio out, USB mic in

Sun Aug 02, 2015 2:11 pm

This is how I configure my audio and it seems to be working (no static on 8k finally)

My hardware:
audio out: using RPi jack (and the RPi Broadcom device)
audio in: using USB microphone (Kinobo Usb 2.0 Microphone - "Akiro" Mic )

1) ==== Check what is available =======
===(check that RPi audio out device driver is loaded)
more /etc/modules

# /etc/modules: kernel modules to load at boot time.
#
# This file contains the names of kernel modules that should be loaded
# at boot time, one per line. Lines beginning with "#" are ignored.
# Parameters can be specified after the module name.

snd-bcm2835

=== Check to be sure USB Mic is noticed (JMTek is USB Microphone )
lsusb

Bus 001 Device 002: ID 0424:9514 Standard Microsystems Corp.
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 001 Device 003: ID 0424:ec00 Standard Microsystems Corp.
Bus 001 Device 004: ID 050d:2103 Belkin Components F7D2102 802.11n N300 Micro Wireless Adapter v3000 [Realtek RTL8192CU]
Bus 001 Device 006: ID 0c76:160a JMTek, LLC.



2) ===== change /etc/modprobe.d/alsa-base.conf

# Keep snd-usb-audio from beeing loaded as first soundcard
options snd-usb-audio index=-2


change to:

# Keep snd-usb-audio from beeing loaded as first soundcard
# options snd-usb-audio index=-2
# Alan: load snd-usb-audio as second sound card
options snd-usb-audio index=1


3) =====change /etc/asound.conf ===============

default file:

pcm.!default {
type hw
card 0
}

ctl.!default {
type hw
card 0
}

For USB mic as audio dev 1 change to:

pcm.!default {
type asym
playback.pcm {
type plug
slave.pcm "hw:0,0"
}
capture.pcm {
type plug
slave.pcm "hw:1,0"
}
}



4) ==========resetting also after changes =======
sudo alsactl init - to reset alsa something
sudo alsa force-reload

5) ===== arecord -l should see USB audio as card 1 device 0
**** List of CAPTURE Hardware Devices ****
card 1: Device [USB Audio Device], device 0: USB Audio [USB Audio]
Subdevices: 1/1
Subdevice #0: subdevice #0

arecord -D hw:1,0 -d 10 -f cd -c 1 testcd.wav




6) ===== check that RPi audio is card 0 device 0 ======
aplay -l

**** List of PLAYBACK Hardware Devices ****
card 0: ALSA [bcm2835 ALSA], device 0: bcm2835 ALSA [bcm2835 ALSA]
Subdevices: 7/8
Subdevice #0: subdevice #0
Subdevice #1: subdevice #1
Subdevice #2: subdevice #2
Subdevice #3: subdevice #3
Subdevice #4: subdevice #4
Subdevice #5: subdevice #5
Subdevice #6: subdevice #6
Subdevice #7: subdevice #7
card 0: ALSA [bcm2835 ALSA], device 1: bcm2835 ALSA [bcm2835 IEC958/HDMI]
Subdevices: 1/1
Subdevice #0: subdevice #0

aplay -D hw:0,0 testcd.wav


7) ========== If audio is soft =======
if soft: alsamixer -> s (select card) -> downarrow to “0 bcm2835 ALSA” ->
enter -> 9 ->ESC

then make setting default:

sudo alsactl store 0

8) ==== create default record rate and format aliases
[create or] add to .bash_aliases
alias arecord48='arecord -f s16_LE -r 48000 '
alias arecord44='arecord -f cd '
alias arecord22='arecord -f s16_LE -r 22050 '
alias arecord11='arecord -f s16_LE -r 11025 '
alias arecord8='arecord -f s16_LE -r 8000 '

and then to pick them up now (auto next login)
source ~/.bashrc

9) ===== testing default play and record
if the default config is correct the following will work:

arecord -d 10 test.wav (records 10s at 8khz 8bit mono)
aplay test.wav (plays back to default audio device)

arecord8 -d 10 test8.wav (records 10s at 8khz 16bit mono)
aplay test8.wav (no static!)


10) ===== see what audio cards asound thinks exist===
more /proc/asound/cards

11) ===== seeing settings for mic and sound out
mixer -card 0 contents (will show settings for sound output)
mixer -card 1 contents (will show settings for mic input)

vallemar
Posts: 1
Joined: Sun Oct 25, 2015 6:15 pm

Re: Analog audio problems? post comments here!

Sun Oct 25, 2015 6:21 pm

I have the same issue. This is a solution:
sudo nano ~/.asoundrc

change to :

pcm.!default {
type asym
playback.pcm {
type plug
slave.pcm "hw:1,0"
}
capture.pcm {
type plug
slave.pcm "hw:1,0"
}
}


Note:leave the empty file /etc/modprobe.d/alsa-base.conf and reboot and wuala!! Sound comes from usb-card, test!

bitbin
Posts: 15
Joined: Tue Dec 01, 2015 6:48 pm

Re: Analog audio problems? post comments here!

Tue Dec 01, 2015 7:40 pm

I have hiss or static from the Raspberry Pi 2 audio. My problem sounds like nbk7's problem at the beginning of page 2 of this thread. However, muting the audio or moving the volume slider all the way down doesn't stop the hiss. If anything is playing, muted or not, there is hiss. I'm using Raspbian with kernel 4.1.7-v7+. I am using an RCA audio video cable with the left and right plugged in to an amplifier. Adding disable_audio_dither=1 to /boot/config.txt didn't eliminate the hiss. That might have made it slightly quieter but didn't fix the problem. Also, now the audio can't be completely muted. I'll undo the change in config.txt. I have a small USB to mic and headphone adapter. The Raspberry Pi 2 recognizes the device but won't play any audio through it.

kazanz
Posts: 1
Joined: Sat Dec 05, 2015 12:39 am

Re: Analog audio problems? post comments here!

Sat Dec 05, 2015 12:57 am

Hello all,

I bought a blue snowball microphone, but I cannot get it to work with the pi.

Here is what I know,

1. When I plug it in it lights up.
2. It is recognized when I run

Code: Select all

lsusb
3. It is not recognized when I run

Code: Select all

arecord -l
Any ideas, how to get it working & how to test it?

Thanks.

tammasarath
Posts: 1
Joined: Sat Dec 05, 2015 12:45 pm

Re: Analog audio problems? post comments here!

Sat Dec 05, 2015 12:58 pm

Hi,

I ordered Raspberry Pi 2 B and received it. I'm amazed to see it working. The only problem i got is, i can't get any volume from the audio jack you provided. I tried plugging in my computer speakers, headphones, earphones, but none of them are actually working. Can you please help me/ let me know if i'm missing something here? i checked in the OS, it's not on mute, i kept it in full volume, but of no use. I tried to play a youtube video, i could see only video(which is not seamless when it's in full screen mode, lot of jerks) and no audio. I ordered the 8gb OS micro sd card as well.

Thanks,
Sarath

312capri
Posts: 5
Joined: Sat Nov 28, 2015 8:00 pm

Re: Analog audio problems? post comments here!

Sun Dec 13, 2015 4:27 am

Just received my RPi2. Have sound from the headphone jack but nothing from my HDMI monitor. Connected the ROKU via the HDMI input and it operates fine. Using the GUI forced the audio to the HDMI, still no results. Also downloaded the latest NOOBS and it has several additional packages that the SD disk shipped with the system... Even after updating the original.

mcpolo
Posts: 1
Joined: Sun Dec 13, 2015 5:01 pm

Re: Analog audio problems? post comments here!

Sun Dec 13, 2015 5:21 pm

EDIT!
NEW INFO: Problem is 99,9% related to my Behringer 1204USB-mixer which seems to have some hw problems. It has stereo inputs which are partially broken and behave with all audio input like with RPI. When connected to working channel, RPI works as expected (a bit low sound level but that is acceptable).

I'm not only one with this problem: http://www.recordingchannel.com/strange ... 66219.html
I have a weird problem with my new RPI 2 B.

No sound from analog output, unless I unplug and then replug 3,5" cord back to RPi. Then it plays 3-4 seconds and mutes.

Through hdmi it works fine. I have 2A pihut power. I have tested raspbian and osmc , both behave same. No sound from hdmi when analog output is selected, as it should be.

I don't know, what to do. Hdmi sound output is not option since I intend to use this mainly as mpd server.

Pa11en
Posts: 1
Joined: Sat Dec 12, 2015 7:34 am
Location: Oregon, USA

Re: Analog audio problems? post comments here!

Thu Dec 17, 2015 8:37 am

I have a new pi 2 with no sound on vizio hdmi tv. I have tried all of the sugestions at http://www.raspberrypi.org/documentatio ... -config.md We have allso tried different audio setting on our tv. I am just a NOOB and not a programer. Many of the posts of which I have read all, go way over my head. I have seen others with this issue as well and saw they were told to try the same options I have already tried. An other tricks a NOOB can try?

shadyhippo
Posts: 1
Joined: Tue Dec 29, 2015 5:22 am

Re: Analog audio problems? post comments here!

Tue Dec 29, 2015 5:51 am

tammasarath wrote:Hi,

I ordered Raspberry Pi 2 B and received it. I'm amazed to see it working. The only problem i got is, i can't get any volume from the audio jack you provided. I tried plugging in my computer speakers, headphones, earphones, but none of them are actually working. Can you please help me/ let me know if i'm missing something here? i checked in the OS, it's not on mute, i kept it in full volume, but of no use. I tried to play a youtube video, i could see only video(which is not seamless when it's in full screen mode, lot of jerks) and no audio. I ordered the 8gb OS micro sd card as well.

Thanks,
Sarath
EDIT: Pa11en, this should work for you too

OK I followed these instructions to make my sound work http://raspberrypi.stackexchange.com/qu ... ot-working

I had to edit /etc/modules file using "sudo nano /etc/modules" and change "snd-bcm2835" to "snd_bcm2835"

That made sound work. Now I have this annoying static ONLY when sound is playing. Does anyone know how to fix this? I also saw this thread viewtopic.php?uid=170865&f=38&t=90495&start=25 relating to the issue. I tried the solutions listed there and still nothing. I am using primarily Raspian, but also got the static on Ubuntu Mate.

Return to “Troubleshooting”

Who is online

Users browsing this forum: saihoufung and 38 guests