User avatar
BorbingoBoy
Posts: 13
Joined: Sun Apr 09, 2017 6:24 am
Location: Croatia
Contact: Website

Re: STICKY: Analog audio problems? post comments here!

Sat Jan 20, 2018 4:43 pm

Is it possible to transmit audio output through LAN? I don't have a TV with speakers, Pi's headphone jack output is horrible, and I use a Bluetooth keyboard, so HDMI, Bluetooth and headphone jack are not the way to go. Do you know the way? :mrgreen:

Thank you in advance!
3.1415926535897932384626433832795028841971693993751058209749445923078164062862089986280348253421170679821480865132823066470938446095505822317253594081284811174502841027019385211055596446229489549303819644288109756659334461284756482337867831652712019091456

User avatar
davidcoton
Posts: 2941
Joined: Mon Sep 01, 2014 2:37 pm
Location: Cambridge, UK

Re: STICKY: Analog audio problems? post comments here!

Sat Jan 20, 2018 10:33 pm

BorbingoBoy wrote:
Sat Jan 20, 2018 4:43 pm
Is it possible to transmit audio output through LAN? I don't have a TV with speakers, Pi's headphone jack output is horrible, and I use a Bluetooth keyboard, so HDMI, Bluetooth and headphone jack are not the way to go. Do you know the way? :mrgreen:

Thank you in advance!
Try this viewtopic.php?f=29&t=195178#p1221618
"Thanks for saving my life." See https://www.raspberrypi.org/forums/viewtopic.php?p=1327656#p1327656
“Raspberry Pi is a trademark of the Raspberry Pi Foundation”

NiggiBS
Posts: 12
Joined: Thu Nov 30, 2017 3:03 pm

Re: STICKY: Analog audio problems? post comments here!

Fri Jan 26, 2018 4:48 pm

I use cheap speakers on my raspberry pi 3 (analog audio). I have sound but there is also an annoying buzz to be heard. When I use headphones there is no buzz.
Why is that?

bigdavoc
Posts: 1
Joined: Fri Feb 16, 2018 2:07 pm

Re: STICKY: Analog audio problems? post comments here!

Fri Feb 16, 2018 2:20 pm

Ok been using audio via HDMI on my old Pi 2's.

I have now set up a Pi3 farm (well only 4 Pi3's t this stage). I have installed the software (including the Alexa code). I have bought a USB mic and installed all the alexa kit on to the pi3.

I have tried several things to get audio to come out of the 3.5 Pi3 jack and have now come to the end of my research and still can not get any sound out if the Oi via the 3.5 headphone jack. I have tried different speakers and different headphones / ear buds but can not get any adio


I have set up the sound options and forced the sound to the headphone jack (amixer cset numid=3 1) I have even run the alsamixer and checked to make sure things are ok. SO I am pretty convinced it seems all set up.

I have done a sudo apt-get update / upgrade so nothing missing there

I have even installed the alsa utils package but still no luck

Any suggestions ??

thanks in advance

Davo

rosalinecullens
Posts: 1
Joined: Tue May 15, 2018 7:44 am
Contact: Website

Re: STICKY: Analog audio problems? post comments here!

Tue May 15, 2018 8:31 am

Will be recommending you and your articles to writing friends.Thank you for your generosity. This was an incredibly wonderful article. Thanks for providing these details.

niwa3836
Posts: 53
Joined: Mon Nov 05, 2012 9:08 pm

Re: STICKY: Analog audio problems? post comments here!

Fri May 25, 2018 11:01 am

I've been chasing this issue down for a few long (long) days and can now 100% reproduce but not sure actually whats causing the issue. This used to work 100% under jessie but not stretch (ive re-checked at I am right it works). Let me explain how to reproduce as it shows what I need to do (mixing tracks at the end for a smooth music transition - part of my project). 2 terminal ssh windows to your stretch raspberry pi 3B+ first window: sudo /usr/bin/mpg123 -q -a hw:0,0 /media/musicfile1.mp3 #(now hear music ok)

second window: sudo /usr/bin/mpg123 -q -a hw:0,0 /media/musicfile2.mp3 #(now hear music ok)

Now stop the first window music and try restarting it. The music jumps, buffers, clicks and basically goes wrong. You could have restarted the 2nd window all day long with no issues. As I say this works really well under jessie. This solution is out of the box (i.e. not changed alsa configurations / asource etc). Can anyone else easily reproduce? Anyone any ideas? I know the issue is also with mplayer so it must be alsa related right (since pulseaudio is not in stretch by default). This is command line PI only (no GUI).

HELP, you could be my hero, I know you are out there!

tcat
Posts: 22
Joined: Wed Oct 18, 2017 11:23 am

Re: STICKY: Analog audio problems? post comments here!

Sun Jun 10, 2018 10:27 pm

Hi,

How do I set analog audio to output stereo on PI3 B?
I use amplified speakers powered from USB.

$ aplay /usr/share/sounds/alsa/Side_Left.wav
$ aplay /usr/share/sounds/alsa/Side_Right.wav

The above plays to both channels on PI3 B, while on PI1 B played left or right.
Many thanks
Tomas

Return to “Troubleshooting”

Who is online

Users browsing this forum: drgeoff, Mettauk and 57 guests