mattanl
Posts: 143
Joined: Thu Jun 14, 2012 10:40 am

Raspberry doesn't start automatically after power outage

Wed Nov 26, 2014 3:35 pm

Hi,

I'm having a strange issue: After power outage, the raspberry pi doesn't start automatically. It means that I see some LEDs but it doesn't start. If I detach and re-attach the power cord from the raspi, it starts.
It looks like a protection mechanism or similar (to avoid frequent start-stops). Are you aware of it? Is there a way to disable it?

Thanks.

DirkS
Posts: 10417
Joined: Tue Jun 19, 2012 9:46 pm
Location: Essex, UK

Re: Raspberry doesn't start automatically after power outage

Wed Nov 26, 2014 3:55 pm

It looks like a protection mechanism or similar (to avoid frequent start-stops).
Not aware of any such mechanism on the Pi.

Are you sure it's not starting or is there just no output on a connected screen?

Gr.
Dirk.

drgeoff
Posts: 11106
Joined: Wed Jan 25, 2012 6:39 pm

Re: Raspberry doesn't start automatically after power outage

Wed Nov 26, 2014 4:25 pm

Is the power outage just a quick blip or sustained for some tens of seconds? If the outage is short there will be some power stored in the PSU that will slowly die away and cause the voltage received by the RPi to fade. This can cause the RPi to enter a mode where it isn't "off" but does does not work properly (eg it appears to freeze or "hang"). When full power is restored the RPi doesn't leave that state.
Quis custodiet ipsos custodes?

dom
Raspberry Pi Engineer & Forum Moderator
Raspberry Pi Engineer & Forum Moderator
Posts: 5592
Joined: Wed Aug 17, 2011 7:41 pm
Location: Cambridge

Re: Raspberry doesn't start automatically after power outage

Wed Nov 26, 2014 5:56 pm

DirkS wrote: Are you sure it's not starting or is there just no output on a connected screen?
That would be my guess. If TV is also powered off and takes longer to boot than Pi it may not be asserting hotplug, so Pi defaults to composite.
That can be forced if we can confirm that is the issue.

adamreisnz
Posts: 10
Joined: Sat Sep 16, 2017 9:29 am

Re: Raspberry doesn't start automatically after power outage

Mon Feb 24, 2020 9:26 pm

drgeoff wrote:
Wed Nov 26, 2014 4:25 pm
Is the power outage just a quick blip or sustained for some tens of seconds? If the outage is short there will be some power stored in the PSU that will slowly die away and cause the voltage received by the RPi to fade. This can cause the RPi to enter a mode where it isn't "off" but does does not work properly (eg it appears to freeze or "hang"). When full power is restored the RPi doesn't leave that state.
I suspect that this was what we experienced with our Pi last week. Is there anything that can be done to prevent this state of non-existence?
The site is quite remote, so going up there to pull the power plug and restore it again is not really an option.

Sounds like the Pi might be better off not running off a backup battery, and just suffer the immediate power cut, which will then at least cause it to reboot when power is restored.

Return to “Troubleshooting”