xiait
Posts: 3
Joined: Fri Nov 07, 2014 5:59 am

B+ Berryterminal no sound

Fri Nov 07, 2014 6:12 am

Putting together a school computer lab using Raspberry Pi B+s running Berryterminal, with Edubuntu 12.04 on the server. I can't get sound out of the headphone jack. We don't have HDMI monitors, so we're using a HDMI-to-VGA adaptors on them. The adaptors also have an audio out port and I can't get sound out of it either.

I ran Raspbian on one of the units and confirmed that I can get sound out of the headphone jack that way. So: there's no hardware problem.

When logged into the server using a Pi, PulseAudio Volume Control (pavucontrol) shows that Pulse Audio thinks the sound is going to a Broadcom card, like it should be.

I've seen forum posts about running amixer commands ("cset numid=3 1" to force headphone output). The problem is, when I'm logged into the server, that command would run on the server, not the Pi. And when I'm not logged into the server (e.g., if I boot up with the network cable disconnected), amixer isn't installed.

What I think I'd like to do is: install amixer onto the Pi, and have it run the cset command before the Pi tries to connect to LTSP. I don't know how to do this.

Can anyone provide instructions for adding packages to the Berryterminal install? Or any other ideas how I can figure out why sound isn't working?

fruitoftheloom
Posts: 25699
Joined: Tue Mar 25, 2014 12:40 pm
Location: Delightful Dorset

Re: B+ Berryterminal no sound

Sat Nov 08, 2014 12:33 pm

Whilst I do not have an answer, it would appear BerryTerminal was released 12 months ago, which is prior to the RPi B+ release.

Maybe take a look at the newer LTSP

http://gbaman.github.io/RaspberryPi-LTSP

http://www.raspberrypi.org/forums/viewt ... 99&t=79831
The information is out there....you just have to let it in.

My other Linux machines are a ChromeBox & Intel CoreDuo Desktop

xiait
Posts: 3
Joined: Fri Nov 07, 2014 5:59 am

Re: B+ Berryterminal no sound

Tue Nov 11, 2014 12:08 pm

Thanks for the suggestion. Pi-LTSP is a very nice system, and the maintainer was really helpful when I got stuck with something, but I've learned that I need a thin client system, so it looks like I'm back to BerryTerminal.

I'll post again if I get it working, and I'll keep watching this thread in case anyone has any advice for this setup.

LakesideRob
Posts: 3
Joined: Thu Jan 01, 2015 12:09 pm

Re: B+ Berryterminal no sound

Thu Jan 01, 2015 12:20 pm

Happy New Year,

Have you found a solution to this? I am getting ready to start a similar project, and in my studies for a HDMI to VGA adapter that would fit the bill, I came across this... http://www.amazon.com /Ableconn-HDMI2VGAD-Converter-1920x1200-1920x1080/dp/B00JLRHMZE/ref=sr_1_6?ie=UTF8&qid=20114604&sr=8-6&keywords=HDMI+to+VGA+CONVERTER which specifically states that it leaves the audio on the source side. Hopefully that helps you out.

User avatar
mahjongg
Forum Moderator
Forum Moderator
Posts: 13678
Joined: Sun Mar 11, 2012 12:19 am
Location: South Holland, The Netherlands

Re: B+ Berryterminal no sound

Thu Jan 01, 2015 2:58 pm

leaving audio on the source side is simply an euphemism for not supporting the conversion of HDMI audio to analog audio, a disadvantage advertised as an advantage... nothing to do with this problem either, as you can simply ignore the availability of HDMI audio conversion in other adapters.

Reeks as advertising, so I disabled the link. we don't want to encourage rampant advertising here. Anyone that still thinks this adapter is anything special can repair the link.

LakesideRob
Posts: 3
Joined: Thu Jan 01, 2015 12:09 pm

Re: B+ Berryterminal no sound

Sun Jan 04, 2015 12:38 pm

I certainly wasn't advertising, and I'm REALLY struggling with this problem right now myself. I've got a Pi B (not plus) hooked up through an HDMI to VGA adapter (not the one that I linked to, just a cheap one I picked up from Amazon) and I can not get sound from headphones. Would love any support or ideas anyone has to solve this!

Thanks.

fruitoftheloom
Posts: 25699
Joined: Tue Mar 25, 2014 12:40 pm
Location: Delightful Dorset

Re: B+ Berryterminal no sound

Sun Jan 04, 2015 12:57 pm

LakesideRob wrote:I certainly wasn't advertising, and I'm REALLY struggling with this problem right now myself. I've got a Pi B (not plus) hooked up through an HDMI to VGA adapter (not the one that I linked to, just a cheap one I picked up from Amazon) and I can not get sound from headphones. Would love any support or ideas anyone has to solve this!

Thanks.
Yes even the £5.00 HDMi to VGA adaptors do not appear to have audio output on the RPi

Best to use a HDMi TV and use the TV Audio Out

It is the Adaptors which are crap not the RPi ;)
The information is out there....you just have to let it in.

My other Linux machines are a ChromeBox & Intel CoreDuo Desktop

LakesideRob
Posts: 3
Joined: Thu Jan 01, 2015 12:09 pm

Re: B+ Berryterminal no sound

Sun Jan 04, 2015 1:14 pm

thanks fruitoftheloom...
So is there really no work around? These piterminals would be going into an existing computer lab with existing vga monitors... swapping out the displays isn't in the cards right now financially. There must be a way to point the sound to the output jack, no? Is there a known good HDMI > VGA + Sound adapter that someone can point me to? Using Berryterminal here, just in case that wasn't clear.

User avatar
DougieLawson
Posts: 40788
Joined: Sun Jun 16, 2013 11:19 pm
Location: A small cave in deepest darkest Basingstoke, UK
Contact: Website Twitter

Re: B+ Berryterminal no sound

Sun Jan 04, 2015 1:19 pm

Two things.
1. If these are A+ or B+ pis how about using Gert's VGA adapter that sits on the GPIO pins.
2. If the monitors are new do they have DVI-D. DVI-D is electrically identical to HDMI with a different connector. A straight through no adapter needed cable costs less than £5.
Any language using left-hand whitespace for syntax is ridiculous

Any DMs sent on Twitter will be answered next month.
Fake doctors - are all on my foes list.

Any requirement to use a crystal ball or mind reading will result in me ignoring your question.

fruitoftheloom
Posts: 25699
Joined: Tue Mar 25, 2014 12:40 pm
Location: Delightful Dorset

Re: B+ Berryterminal no sound

Sun Jan 04, 2015 1:21 pm

LakesideRob wrote:thanks fruitoftheloom...
So is there really no work around? These piterminals would be going into an existing computer lab with existing vga monitors... swapping out the displays isn't in the cards right now financially. There must be a way to point the sound to the output jack, no? Is there a known good HDMI > VGA + Sound adapter that someone can point me to? Using Berryterminal here, just in case that wasn't clear.
As stated you will need to find an Adaptor which works, it is nothing to do with the OS, maybe use a USB Powered Adaptor and see if that makes a difference :?:

http://www.ebay.co.uk/itm/HDMI-to-VGA-R ... 5d52f01f5f
The information is out there....you just have to let it in.

My other Linux machines are a ChromeBox & Intel CoreDuo Desktop

Return to “Troubleshooting”