Page 1 of 1

Ugly rendering with chromium & midori

Posted: Tue Oct 28, 2014 4:19 pm
by eltrasimaco
Hi i'm setting a kiosk, my screen is a samsung 46 tv; the results are far from acceptable, tiny & unreadable Verdana fonts (have d/l m$ ttf fonts already) and blurry images; tried different resolutions . Same web using Windows, appears OK in the screen; I've tried both chromium & midori with same results, any hint?
TIA

Re: Ugly rendering with chromium & midori

Posted: Tue Oct 28, 2014 4:51 pm
by gkreidl
To get good image quality you have to run the RPi in 32Bit (including alpha channel) true color mode.

Re: Ugly rendering with chromium & midori

Posted: Tue Oct 28, 2014 6:56 pm
by jamesh
What resolution is the display? 1080p? Or UHD?

Re: Ugly rendering with chromium & midori

Posted: Wed Oct 29, 2014 7:13 am
by eltrasimaco
Its 1360x768, I've tried bigger ones with similar results

Re: Ugly rendering with chromium & midori

Posted: Thu Oct 30, 2014 9:02 am
by eltrasimaco
In /boot/config.txt:
gpu_mem=128
#framebuffer_ignore_alpha=1
hdmi_ignore_edid=0xa5000080
framebuffer_width=1360
framebuffer_height=768
framebuffer_depth=24

I've tried framebuffer_depth to 32 and gpu_mem to 256, same results, images and fonts show blurry / pixelated
Is there something more I could try ?
Thanks

Re: Ugly rendering with chromium & midori

Posted: Thu Oct 30, 2014 9:31 am
by RaTTuS
can you post a photo [use imgur.com]
have you removed the overscan bits in config
are you editing the correct config file


have you seen
https://github.com/MobilityLab/TransitS ... spberry-Pi
there are other kiosk threads here somewhere
http://www.raspberrypi.org/forums/viewt ... 66&t=40860

Re: Ugly rendering with chromium & midori

Posted: Thu Oct 30, 2014 9:45 am
by gkreidl
Why do you set the framebuffer width and height and ignore CEC (hdmi_ignore_edid)? Let the CEC communication set your resolution and the framebuffer size automatically and you will get a sharp picture on your monitor/TV.

True color mode: It has been reported that only the following does work:
framebuffer_depth=32
framebuffer_ignore_alpha=1

I'm not sure if that's true any more but in the past I got wrong colours when I tried framebuffer_depth=24.

Re: Ugly rendering with chromium & midori

Posted: Thu Oct 30, 2014 10:47 am
by Matt_F
Have you tried reducing the 'Sharpness' setting on your TV (under picture settings / picture mode).

I switched from testing with an LG 42" TV where everything looked fine to a JVC 40" TV and suddenly all text looked pixelated / jagged and colours were completely off.

I reduced sharpness and adjusted RGB values and managed to get output to look correct.

Re: Ugly rendering with chromium & midori

Posted: Thu Oct 30, 2014 11:27 am
by eltrasimaco
[img]http://i.imgur.com/VTE4OLq.jpg[/img]

Same image in windows shows perfectly
Im trying now with kweb, fonts look slightly better than in chromium (where they are quite small)
With framebuffer_depth=32 & removealpha I get same results as in 24, tried several gpu_mem without results
Some screens are full 1360 jpg image, other are just html. both show badly
I set the framebuffer because the native res is 1920 and screens are crafted for 1360, but if I remove all the fb stuff, screens are smaller but graphics & fonts don't look better
BTW this is an old samsung 46 monitor (460 dx)