ceriox
Posts: 1
Joined: Tue Sep 30, 2014 8:22 am

How to install raspbian kernel source 3.12.28+

Tue Sep 30, 2014 8:29 am

Hello,
I need to install the kernel source 3.12.28+ but i don't know how to do it.

i try with:

Code: Select all

root@raspberrypi:/# apt-get install -y linux-headers-`uname -r`
Reading package lists... Done
Building dependency tree
Reading state information... Done
E: Unable to locate package linux-headers-3.12.28
E: Couldn't find any package by regex 'linux-headers-3.12.28'
but it dosn't work ... :(

User avatar
pluggy
Posts: 3635
Joined: Thu May 31, 2012 3:52 pm
Location: Barnoldswick, Lancashire,UK
Contact: Website

Re: How to install raspbian kernel source 3.12.28+

Tue Sep 30, 2014 10:49 am

3.12.28+ is the current kernel in Raspbian, so I'd do

Code: Select all

apt-get update
apt-get upgrade
apt-get install linux-source
Don't judge Linux by the Pi.......
I must not tread on too many sacred cows......

User avatar
DougieLawson
Posts: 38774
Joined: Sun Jun 16, 2013 11:19 pm
Location: A small cave in deepest darkest Basingstoke, UK
Contact: Website Twitter

Re: How to install raspbian kernel source 3.12.28+

Tue Sep 30, 2014 9:17 pm

I'd do it by git clone https://github.com/raspberrypi/linux or by pulling the kernel tarball from there.
Note: Any requirement to use a crystal ball or mind reading will result in me ignoring your question.

Criticising any questions is banned on this forum.

Any DMs sent on Twitter will be answered next month.
All non-medical doctors are on my foes list.

User avatar
limewax
Posts: 8
Joined: Fri Jan 04, 2013 8:50 pm
Location: Poland

Re: How to install raspbian kernel source 3.12.28+

Mon Oct 13, 2014 12:44 pm

I couldn't be able to install the kernel source. For EVERY single package avaliable on official repo, there was a version mismatch. It installed headers for all the kernels except the one i needed.

I found this somewhere on the web:
http://www.niksula.hut.fi/~mhiienka/Rpi ... _armhf.deb
It works for me, after installing it with dpkg -i, then wifi driver compiles without problem.

However i don't know the source of above package, so I can't guarantee its harmless, install at your own risk.

Return to “Troubleshooting”