rdohmen
Posts: 5
Joined: Thu Jan 09, 2014 1:27 pm

problem installing Lazarus

Thu Sep 18, 2014 5:16 pm

Hi,

I used to install Lazrus with:

Code: Select all

sudo apt-get install fpc lazarus libfbclient2
But since a week or so the following message occures:

Code: Select all

fpc : Depends: fpc-2.6.0 (= 2.6.0-9+rpi1) but it is not going to be installed
lazarus : Depends: lazarus-0.9.30.4 (= 0.9.30.4-6) but it is not goning to be installed

E: unable to correct problem, you have broken packages
I have no idea how to solve or work around this.

thanks for any help,

René

arnoldb
Posts: 1
Joined: Fri Sep 19, 2014 4:23 pm

Re: problem installing Lazarus

Fri Sep 19, 2014 5:30 pm

I ran into the same problem today (just got my B+ this morning), and after digging through things, found it's because the binutils-gold dependency for fpc is not satisfied after I did an apt-get update and apt-get upgrade.

The fpc package is looking for an older version than is now on the Pi...

For now, I forced a roll-back to the required version of binutils-gold and got fpc/lazarus to run - but that won't play well with other things in future, so someone must look at the fpc package dependencies and sort it out.

Kind regards, Arnold

rdohmen
Posts: 5
Joined: Thu Jan 09, 2014 1:27 pm

Re: problem installing Lazarus

Sat Sep 20, 2014 11:05 am

Thanks Arnold,

Can you give me some instruction on how to do that?
I guess 'sudo aptitude' with some parameters?

thank in advance,

René


rdohmen
Posts: 5
Joined: Thu Jan 09, 2014 1:27 pm

Re: problem installing Lazarus

Sat Oct 25, 2014 7:02 pm

Thank you, this works!

After adding

deb http://plugwash.raspbian.org/wsf wheezy-wsf main

to

/etc/apt/sources.list

with

sudo nano /etc/apt/sources.list

I updated and upgraded with:

sudo apt-get update
sudo apt-get upgrade

After this a usual install was possible with:

sudo apt-get install fpc lazarus libfbclient2

Kind regards,

Rene

hkemsw
Posts: 2
Joined: Thu Jan 22, 2015 3:53 am

Re: problem installing Lazarus

Thu Jan 22, 2015 3:56 am

Hi

I tried all of the above but I still get the broken packages error.

Are there any updated suggestions?

Thanks

plugwash
Forum Moderator
Forum Moderator
Posts: 3225
Joined: Wed Dec 28, 2011 11:45 pm

Re: problem installing Lazarus

Thu Jan 22, 2015 4:30 pm

can you post the complete output of

apt-get install lazarus fp-compiler binutils

and

apt-cache policy fp-compiler

otani
Posts: 23
Joined: Fri Dec 13, 2013 4:18 am

Re: problem installing Lazarus

Thu Jan 22, 2015 7:28 pm

Don't use "apt-get install". Just try as follows:

$sudo aptitude install fpc
----fpc not installed ---
---leave the following dependencies unresolved----
Accept this solutions [Y/n/q] n [Enter] == Important==

The following actions will resolve these dependencies:
Downgrade the following packages:
binutils 2.24.5 --> 2.22.8
Accept this solution [Y/n/q] y [Enter]
Start to download and install..

BlaiseP
Posts: 8
Joined: Tue Feb 10, 2015 9:11 pm

Re: problem installing Lazarus

Tue Feb 10, 2015 10:38 pm

I tried
http://www.raspberrypi.org/forums/viewt ... 48&t=88145
first but no success...this worked, thanks.

hkemsw
Posts: 2
Joined: Thu Jan 22, 2015 3:53 am

Re: problem installing Lazarus

Mon Feb 23, 2015 1:11 am

Many thanks - I apologise for my incredibly slow response. I got dragged into working on other things.

I just followed your instructions and all went well.

Return to “Troubleshooting”

Who is online

Users browsing this forum: in3vrr, pabarber, Rudestlink and 84 guests