Page 1 of 1

apt-get update fails with GPG error: vontaene.de NO_PUBKEY

Posted: Tue Sep 16, 2014 3:35 pm
by jbeale
Not sure what this means, haven't seen it before:

Code: Select all

[email protected] ~ $ sudo apt-get update
Hit http://raspberrypi.collabora.com wheezy Release.gpg
Hit http://archive.raspberrypi.org wheezy Release.gpg
Hit http://mirrordirector.raspbian.org wheezy Release.gpg
Hit http://raspberrypi.collabora.com wheezy Release
Get:1 http://vontaene.de . Release.gpg [198 B]
Hit http://archive.raspberrypi.org wheezy Release
Hit http://mirrordirector.raspbian.org wheezy Release
Hit http://vontaene.de . Release
Ign http://vontaene.de . Release
Hit http://raspberrypi.collabora.com wheezy/rpi armhf Packages
Hit http://archive.raspberrypi.org wheezy/main armhf Packages
Hit http://mirrordirector.raspbian.org wheezy/main armhf Packages
Hit http://mirrordirector.raspbian.org wheezy/contrib armhf Packages
Hit http://mirrordirector.raspbian.org wheezy/non-free armhf Packages
Hit http://mirrordirector.raspbian.org wheezy/rpi armhf Packages
Ign http://raspberrypi.collabora.com wheezy/rpi Translation-en_US
Ign http://archive.raspberrypi.org wheezy/main Translation-en_US
Ign http://raspberrypi.collabora.com wheezy/rpi Translation-en
Ign http://archive.raspberrypi.org wheezy/main Translation-en
Hit http://vontaene.de ./main armhf Packages
Ign http://vontaene.de ./main Translation-en_US
Ign http://vontaene.de ./main Translation-en
Ign http://mirrordirector.raspbian.org wheezy/contrib Translation-en_US
Ign http://mirrordirector.raspbian.org wheezy/contrib Translation-en
Ign http://mirrordirector.raspbian.org wheezy/main Translation-en_US
Ign http://mirrordirector.raspbian.org wheezy/main Translation-en
Ign http://mirrordirector.raspbian.org wheezy/non-free Translation-en_US
Ign http://mirrordirector.raspbian.org wheezy/non-free Translation-en
Ign http://mirrordirector.raspbian.org wheezy/rpi Translation-en_US
Ign http://mirrordirector.raspbian.org wheezy/rpi Translation-en
Fetched 198 B in 8s (22 B/s)
Reading package lists... Done
W: GPG error: http://vontaene.de . Release: The following signatures couldn't be verified because the public key is not available: NO_PUBKEY F0DAA5410C667A3E
Maybe this is related to this note about gstreamer(?) http://www.raspberrypi.org/forums/viewt ... 25#p600512

Re: apt-get update fails with GPG error: vontaene.de NO_PUBK

Posted: Wed Sep 17, 2014 5:40 pm
by Defiant
This is a mechanism to prevent man-in-the-middle attacks, like the NSA or GHCQ redirecting the traffic from your rpi to their own server, downloading a package from them. You read about it here: https://wiki.debian.org/SecureApt

Re: apt-get update fails with GPG error: vontaene.de NO_PUBK

Posted: Sat Dec 06, 2014 10:35 pm
by moddieTR
I just started receiving this message as well. Thank you first answerer now I'm aware that it has something to do with apt-secure but doesn't help me fix it, but thank you for the info as I believe it has pointed me to an approximate answer/fix. Question to original poster...did you happen to just compile open frameworks on your RPi? I run apt-get update a lot and got this message after doing one of three things. A)compiling of openFrameworks, B) installing kdenlive and gimp, or C) installing arduino and arduino-core . Thank you.

Re: apt-get update fails with GPG error: vontaene.de NO_PUBK

Posted: Sun Dec 07, 2014 2:36 am
by jbeale
I don't remember now, but it may indeed have been an attempt to compile openframeworks.

Re: apt-get update fails with GPG error: vontaene.de NO_PUBK

Posted: Mon Feb 16, 2015 7:47 pm
by DetlevSchm
I have got the same error and fixed it by following this procedure: (see the first answer)

Summary:

Code: Select all

apt-get install debian-keyring
gpg --keyserver pgp.mit.edu --recv-keys 0C667A3E
gpg --armor --export 0C667A3E | apt-key add -
After that, 'apt-get update' did not issue the above error anymore.

Re: apt-get update fails with GPG error: vontaene.de NO_PUBK

Posted: Mon Feb 16, 2015 8:22 pm
by Defiant
Please no longer use my repository since nowadays raspbian already contains all gstreamer/omx packages.

Re: apt-get update fails with GPG error: vontaene.de NO_PUBK

Posted: Wed Apr 20, 2016 10:41 am
by chrisham
Defiant wrote:Please no longer use my repository since nowadays raspbian already contains all gstreamer/omx packages.
The problem is that the rPi repo has a very old version of gstreamer and I have no idea how to even start updateing it to the latest version 1.8 that will solve some of the issues I am having with the distro version. In particulat Videomixer can only cope with 320x240 video streams.

I have searched and searched but I cannot find a way to upgrade my RPi to use gstreamer v1.8.0

Can any one help a newby with instructions on how to get v1.8 on a RPi3 please

Thanks

Re: apt-get update fails with GPG error: vontaene.de NO_PUBK

Posted: Tue Apr 04, 2017 12:56 am
by pjuett
I get the same issue apt-get update and tried various fixes, suggested above and elsewhere - key seems to have expired a couple of weeks ago. I am not aware of how this got on my pi ,or what it is for. I note the comment it should not be used. How do I remove or solve this please? Many thanks.

Reading package lists... Done
W: GPG error: http://vontaene.de . Release: The following signatures were invalid: KEYEXPIRED 1489690519 KEYEXPIRED 1489690519 KEYEXPIRED 1489690519

[email protected]:~ $ sudo apt-key list | grep expired
pub 1024D/0C667A3E 2006-03-04 [expired: 2017-03-16]
[email protected]:~ $

Re: apt-get update fails with GPG error: vontaene.de NO_PUBK

Posted: Tue Apr 04, 2017 5:17 am
by Defiant
Open /etc/apt/sources.list and remove the line containing "http://vontaene.de"