ergerodr
Posts: 1
Joined: Fri Sep 05, 2014 5:51 pm

Connecting to eduroam wifi network

Fri Sep 05, 2014 6:21 pm

I am attempting to connect to my university's eduroam network using a wpa_supplicant.conf file but can't seem to get it to work properly. I am on raspbian GNU/Linux 7 and I am using the EDIMAX EW-7811Un wifi adapter.

Straight from my university's website, I need to configure my device using these settings:

- Security: WPA2 Enterprise / 802.1xEAP
- EAP method: PEAP
- Phase 2 authentication: MSCHAPV2
- Download CA certificate
- Identity (username):
- Anonymous Identity:
- Password:

I have used the following two guides
Guide1: http://www.savagehomeautomation.com/pro ... dapte.html
Guide2: http://www.willprice.org/2014/03/17/edu ... ry-pi.html

to create the wpa_supplicant file which looks as follows.

Code: Select all

network={
identity="my_identity"
password="my_password"
ca_cert="/etc/ssl/certs/my-cert-name"
eap=PEAP
anonymous_identity="[email protected]_uni.edu"
phase2="auth=MSCHAPV2"
priority=999
disabled=0
ssid="eduroam"
scan_ssid=0
mode=0
auth_alg=OPEN
proto=WPA RSN
pairwise=CCMP TKIP
key_mgmt=WPA-EAP
proactive_key_caching=1
}
when I run wpa supplicant with the command "sudo wpa_supplicant -i wlan0 -c /path/to/wpa_supplicant.conf -B" I get the following error messages.

Code: Select all

rfkill: cannot open RFKILL control device
ioctl[SIOCSIWAP]: Operation not permitted
ioctl[SIOCSIWENCODEEXT]: invalid argument
ioctl[SIOCSIWENCODEEXT]: invalid argument
What exactly does this mean and what can I do to fix it? I am at a loss.

Andresen
Posts: 29
Joined: Tue Aug 14, 2012 10:25 pm

Re: Connecting to eduroam wifi network

Mon Oct 06, 2014 11:37 pm

Hi ergerodr

Have you tried to change the line:

Code: Select all

proto=WPA RSN
to:

Code: Select all

proto=WPA2
?

If that does not solve it, try to put this in your /etc/wpa_supplicant/wpa_supplicant.conf:

Code: Select all

ctrl_interface=DIR=/var/run/wpa_supplicant GROUP=netdev
update_config=1
and then use

Code: Select all

wpa_gui
to configure wpa_supplicant.

Regards,
Andresen

jm3220
Posts: 6
Joined: Mon Jul 15, 2013 9:05 pm

Re: Connecting to eduroam wifi network

Tue Oct 07, 2014 2:27 pm

Some eduroam sites have set up an automatic configuration tool for a variety of operating systems including Linux. See https://cat.eduroam.org/ for a list of Universities that have done this.

The Linux version downloads a shell script to configure various settings for specific institutions. I don't know if this will work with your o/s, but even if it doesn't, the script may give you some pointers as to how the config files should look.

Hope this is of some use.

Sruc
Posts: 1
Joined: Fri Mar 31, 2017 9:46 am

Re: Connecting to eduroam wifi network

Fri Mar 31, 2017 9:57 am

A bit late to respond, but here's how I connected to eduroam, in case anyone finds this. Add this lines of code to /etc/wpa_supplicant/wpa_supplicant.conf:

Code: Select all

network={
        ssid="eduroam"
        scan_ssid=1
        key_mgmt=WPA-EAP
        eap=PEAP
        identity="[email protected]"
        password="yourpassword"
        phase1="peaplabel=0"
        phase2="auth=MSCHAPV2"
}
Substitute youridentity with your student username and youridentitydomain with the domain used by your university group of users (mine was @student.[universitydomain].edu). Substitute yourpassword with your university password.

hannespi
Posts: 3
Joined: Sun Apr 30, 2017 12:04 pm

Re: Connecting to eduroam wifi network

Sun Apr 30, 2017 12:09 pm

Hej,
I study in Umeå, a University which makes it extremely difficult to install eduroam, even on Win/Mac.
For Ubuntu there is a tutorial online:
http://support.its.umu.se/entry.jspa?ex ... goryID=251
but it doesn't work for Raspbian (Pixel) as I can't get the GUI-promt...

The settings above didn't work for me either, I think there are more certificates than usual, but I'm really no expert in this. Do you find a solution from what they use in the Ubuntu tutorial?

Image

hannespi
Posts: 3
Joined: Sun Apr 30, 2017 12:04 pm

Re: Connecting to eduroam wifi network

Thu May 04, 2017 6:16 pm

No idea? :/ Then I guess I stick to the cable.. :lol:

Return to “Troubleshooting”