thefailinghero
Posts: 7
Joined: Thu Aug 28, 2014 6:08 am

UltraSlim issues

Thu Aug 28, 2014 6:14 am

So I had flashed UltraSlim to a microSD card, and upon first boot everything seemed to be working fine. Unfortunately the keyboard I was using at the time was not being recognized, so I pulled the power. After that it would not boot. My noobs card that came with the pi still works like a charm. I have since formatted and re flashed the image to the other sd card and nothing happens (green light flickers on and promptly turns off). I was able to format the SD card and flash openELEC and it ran flawlessly. Why can I not get UltraSlim to work again? It is the one image I have seen that I desperately want on my pi, and I have been working on it for about 3 hours but cannot even get it to boot.

tl;dr UltraSlim doesn't boot, but did boot at first. Am able to flash other images to same sd card and they work. Re-flashing UltraSlim doesn't work.

DirkS
Posts: 10127
Joined: Tue Jun 19, 2012 9:46 pm
Location: Essex, UK

Re: UltraSlim issues

Thu Aug 28, 2014 11:02 am

What model Pi are you using?

User avatar
RaTTuS
Posts: 10531
Joined: Tue Nov 29, 2011 11:12 am
Location: North West UK
Contact: Twitter YouTube

Re: UltraSlim issues

Thu Aug 28, 2014 11:12 am

you will need the latest boot files on the Fat partition to boot with network and usb on a model B+
How To ask Questions :- http://www.catb.org/esr/faqs/smart-questions.html
WARNING - some parts of this post may be erroneous YMMV

1QC43qbL5FySu2Pi51vGqKqxy3UiJgukSX
Covfefe

whe
Posts: 1
Joined: Thu Aug 28, 2014 11:56 am

Re: UltraSlim issues

Thu Aug 28, 2014 12:45 pm

I'm fighting with a similar Problem.
I'm trying to Flash an existing img ( obviously from an older model ) on my new B+.
but it doesn't work. other Images from my own Raspberry PI are working properly.

are there Hardware dependenties ?

thefailinghero
Posts: 7
Joined: Thu Aug 28, 2014 6:08 am

Re: UltraSlim issues

Thu Aug 28, 2014 2:31 pm

I am using a b+. The thing that was weird to me is rhat it booted properly on my first attempt.

User avatar
RaTTuS
Posts: 10531
Joined: Tue Nov 29, 2011 11:12 am
Location: North West UK
Contact: Twitter YouTube

Re: UltraSlim issues

Thu Aug 28, 2014 3:48 pm

whe wrote:I'm fighting with a similar Problem.
I'm trying to Flash an existing img ( obviously from an older model ) on my new B+.
but it doesn't work. other Images from my own Raspberry PI are working properly.

are there Hardware dependenties ?
you need to stick the old SD card into a B not B+ and update it all
i.e.
sudo apt-get update && sudo apt-get upgrade -y
sudo rpi-update
and then reboot
this will then work in the B+
How To ask Questions :- http://www.catb.org/esr/faqs/smart-questions.html
WARNING - some parts of this post may be erroneous YMMV

1QC43qbL5FySu2Pi51vGqKqxy3UiJgukSX
Covfefe

thefailinghero
Posts: 7
Joined: Thu Aug 28, 2014 6:08 am

Re: UltraSlim issues

Fri Aug 29, 2014 1:40 am

Alright, so after adding the sd card to a camera, snapping a few pictures(read somewhere to give it a shot) doing a complete format (overwrite) I now got it to boot again. Unfortunately the keyboard I was using with noobs seems to not work with UltraSlim (???) as in it seems to not even be powering it. Earlier I could get the lights for num lock, etc to turn on, but not since using UltraSlim. Suggestions?

drgeoff
Posts: 10208
Joined: Wed Jan 25, 2012 6:39 pm

Re: UltraSlim issues

Fri Aug 29, 2014 8:32 am

thefailinghero wrote:Alright, so after adding the sd card to a camera, snapping a few pictures(read somewhere to give it a shot) doing a complete format (overwrite) I now got it to boot again. Unfortunately the keyboard I was using with noobs seems to not work with UltraSlim (???) as in it seems to not even be powering it. Earlier I could get the lights for num lock, etc to turn on, but not since using UltraSlim. Suggestions?
Did you understand the first reply from RaTTuS and do what he said in his second one? (Put the card with Ultraslim in a B and run the commands, then put the card in your B+.)

thefailinghero
Posts: 7
Joined: Thu Aug 28, 2014 6:08 am

Re: UltraSlim issues

Fri Aug 29, 2014 2:56 pm

drgeoff wrote: Did you understand the first reply from RaTTuS and do what he said in his second one? (Put the card with Ultraslim in a B and run the commands, then put the card in your B+.)
Yes I understood the first, but am unable to do the second as the b+ is my first pi

Edit: this probably completely doesn't work but just a though. Could I put UltraSlim on a usb, boot it on my desktop and run the update. Then use win32diskimager to read that image and flash it to the sd?
Last edited by thefailinghero on Fri Aug 29, 2014 3:55 pm, edited 1 time in total.

User avatar
Mortimer
Posts: 924
Joined: Sun Jun 10, 2012 3:57 pm

Re: UltraSlim issues

Fri Aug 29, 2014 3:08 pm

Sounds like the answer would be for some kindly soul to download the image you are using. Run it on a B and update it and create a new image for you.
--------------
The purpose of a little toe is to ensure you keep your furniture in the right place.

User avatar
AndrewS
Posts: 3625
Joined: Sun Apr 22, 2012 4:50 pm
Location: Cambridge, UK
Contact: Website

Re: UltraSlim issues

Wed Sep 03, 2014 3:10 am

I googled and found http://www.raspberrypi.org/forums/viewt ... &start=400
(other people also waiting for UltraSlim to be updated to be B+ compatible)

BMS Doug
Posts: 3824
Joined: Thu Mar 27, 2014 2:42 pm
Location: London, UK

Re: UltraSlim issues

Wed Sep 03, 2014 10:59 am

thefailinghero wrote:
drgeoff wrote: Did you understand the first reply from RaTTuS and do what he said in his second one? (Put the card with Ultraslim in a B and run the commands, then put the card in your B+.)
Yes I understood the first, but am unable to do the second as the b+ is my first pi

Edit: this probably completely doesn't work but just a though. Could I put UltraSlim on a usb, boot it on my desktop and run the update. Then use win32diskimager to read that image and flash it to the sd?
The problem (not explicitly stated earlier) is that a hardware change between the B and B+ versions has made the B+ USB and LAN chip not work with earlier operating systems, this is why the keyboard wasn't recognized and once updated to the latest version everything should work OK for you.

Takenover83 (who made the Ultraslim) last posted in July and seems to be working on Ultraslim 2.0, so he may not be focusing on fixing the old version to work with the B+ at the moment (But he does still look at the forums, his last visit was on Monday).
Doug.
Building Management Systems Engineer.

Return to “Troubleshooting”