Tany3450
Posts: 15
Joined: Fri Aug 22, 2014 12:32 pm

Omxplayer not starting

Mon Aug 25, 2014 5:30 pm

I want to play a video with xming on my pc. When I run the command, nothing happens.

Code: Select all

pi@raspberrypi / $ omxplayer ellie.mp4
have a nice day ;)
What might be the error ? I gave 128mb to GPU. And I dont understand how it can play 1080p videos while it barely open a webpage ?

Do I need to install codecs seperately for all formats ?

User avatar
redhawk
Posts: 3465
Joined: Sun Mar 04, 2012 2:13 pm
Location: ::1

Re: Omxplayer not starting

Mon Aug 25, 2014 5:49 pm

Are you sure the file isn't corrupt??

Out of the box the Raspberry Pi can play h.264 @ 1080p, h.263 and with purchased codecs you can add mpg-2 / mpeg-1 and vc-1 to the list.

Unfortunately having an mp4 doesn't always guarantee successful playback this is just a container file it may have a totally different codec that omxplayer doesn't support.
If you have VLC for Windows could you select "Tools", "Codec information" and report back it's findings.

To get started try the following video from Dailymotion this should be playable on your Raspberry Pi unless your internet is slow.

omxplayer http://www.dailymotion.com/cdn/H264-1280x720/video/x24fho2.mp4?auth=1409161677-2562-3awedrq6-b9d01c509c2428f56e002874e167f567
or
omxplayer http://www.dailymotion.com/cdn/H264-848x480/video/x24fho2.mp4?auth=1409161677-2562-ubrybkd0-98ca821c1fbdc0a48a9e8794c9c29c42

Richard S.

Tany3450
Posts: 15
Joined: Fri Aug 22, 2014 12:32 pm

Re: Omxplayer not starting

Mon Aug 25, 2014 6:46 pm

Hi thanks for answer. Here is the codec details of the video ;

Code: Select all

H264 - MPEG-4 AVC (part 10) (avc1)
Dailymotion videos are not working too, still "have a nice day" and nothing happens. :?

Those links are not working in my browser though, are they working for you ? http://www.dailymotion.com/cdn/H264-128 ... 74e167f567

gkreidl
Posts: 6355
Joined: Thu Jan 26, 2012 1:07 pm
Location: Germany

Re: Omxplayer not starting

Mon Aug 25, 2014 7:22 pm

According to the codec version it should work. Where is the video file in your file system?

And what do you mean by
I want to play a video with xming on my pc
?
Minimal Kiosk Browser (kweb)
Slim, fast webkit browser with support for audio+video+playlists+youtube+pdf+download
Optional fullscreen kiosk mode and command interface for embedded applications
Includes omxplayerGUI, an X front end for omxplayer

Tany3450
Posts: 15
Joined: Fri Aug 22, 2014 12:32 pm

Re: Omxplayer not starting

Mon Aug 25, 2014 7:40 pm

gkreidl wrote:According to the codec version it should work. Where is the video file in your file system?

And what do you mean by
I want to play a video with xming on my pc
?
File is in the root, I dont think there is a problem about it.

I am connecting to my RasPi with the help of Putty, and Xming is providing GUI.

User avatar
redhawk
Posts: 3465
Joined: Sun Mar 04, 2012 2:13 pm
Location: ::1

Re: Omxplayer not starting

Mon Aug 25, 2014 8:17 pm

I want to play a video with xming on my pc
I should have spotted this earlier but anyway what you're attempting is not possible.
The video buffer isn't accessible by X11 so you cannot redirect omxplayer's screen only X11 apps can be redirected remotely with Xming.
That of course doesn't explain omxplayer's behaviour because it usually prints a load of info during playback i.e.
Video codec omx-h264 width 1280 height 720 profile 100 fps 24.000000
Audio codec aac channels 2 samplerate 44100 bitspersample 16
Subtitle count: 0, state: off, index: 1, delay: 0

What distro are you using, have you updated it recently??

Could you run the following and report back the results:
/opt/vc/bin/vcgencmd version
uname -a


Richard S.

Tany3450
Posts: 15
Joined: Fri Aug 22, 2014 12:32 pm

Re: Omxplayer not starting

Mon Aug 25, 2014 8:54 pm

redhawk wrote:
I want to play a video with xming on my pc
I should have spotted this earlier but anyway what you're attempting is not possible.
The video buffer isn't accessible by X11 so you cannot redirect omxplayer's screen only X11 apps can be redirected remotely with Xming.
That of course doesn't explain omxplayer's behaviour because it usually prints a load of info during playback i.e.
Video codec omx-h264 width 1280 height 720 profile 100 fps 24.000000
Audio codec aac channels 2 samplerate 44100 bitspersample 16
Subtitle count: 0, state: off, index: 1, delay: 0

What distro are you using, have you updated it recently??

Could you run the following and report back the results:
/opt/vc/bin/vcgencmd version
uname -a


Richard S.
RASPBIAN. Yes, its up to date.

Code: Select all

~ $ /opt/vc/bin/vcgencmd version
Aug 20 2014 22:50:27
Copyright (c) 2012 Broadcom
version daf2c8c0795066867ef863d938bbbcc7391f1b4a (tainted) (release)

Code: Select all

uname -a
Linux raspberrypi 3.12.26+ #704 PREEMPT Wed Aug 20 22:35:11 BST 2014 armv6l GNU/Linux

gkreidl
Posts: 6355
Joined: Thu Jan 26, 2012 1:07 pm
Location: Germany

Re: Omxplayer not starting

Tue Aug 26, 2014 5:35 am

Is the RPi connected to a monitor / TV?
Minimal Kiosk Browser (kweb)
Slim, fast webkit browser with support for audio+video+playlists+youtube+pdf+download
Optional fullscreen kiosk mode and command interface for embedded applications
Includes omxplayerGUI, an X front end for omxplayer

Tany3450
Posts: 15
Joined: Fri Aug 22, 2014 12:32 pm

Re: Omxplayer not starting

Tue Aug 26, 2014 9:07 am

gkreidl wrote:Is the RPi connected to a monitor / TV?
RPi is connected to my laptop with network cable.

gkreidl
Posts: 6355
Joined: Thu Jan 26, 2012 1:07 pm
Location: Germany

Re: Omxplayer not starting

Tue Aug 26, 2014 1:42 pm

Then omxplayer cannot work. As already has been said, it doesn't use X and cannot be forwarded across the network. And it needs information about the video display which it doesn't get if no monitor is connected.
Minimal Kiosk Browser (kweb)
Slim, fast webkit browser with support for audio+video+playlists+youtube+pdf+download
Optional fullscreen kiosk mode and command interface for embedded applications
Includes omxplayerGUI, an X front end for omxplayer

User avatar
rpdom
Posts: 17984
Joined: Sun May 06, 2012 5:17 am
Location: Chelmsford, Essex, UK

Re: Omxplayer not starting

Tue Aug 26, 2014 4:09 pm

gkreidl wrote:Then omxplayer cannot work. As already has been said, it doesn't use X and cannot be forwarded across the network. And it needs information about the video display which it doesn't get if no monitor is connected.
Not necessarily true.
Depends on the setup. Default Raspbian image will try HDMI and if it isn't connected it will default to composite even with out a monitor connected. omxplayer will still play, just the signal won't be used by anything.

I think that in the case of a NOOBS install, either HDMIor composite will be forced and the same situation will apply.

Obviously without a screen you won't see the output, but I don't think that is enough to make omxplayer fail like this.

gkreidl
Posts: 6355
Joined: Thu Jan 26, 2012 1:07 pm
Location: Germany

Re: Omxplayer not starting

Tue Aug 26, 2014 4:25 pm

Thanks for the info. I had hoped that the missing monitor would explain why it doesn't run.
Minimal Kiosk Browser (kweb)
Slim, fast webkit browser with support for audio+video+playlists+youtube+pdf+download
Optional fullscreen kiosk mode and command interface for embedded applications
Includes omxplayerGUI, an X front end for omxplayer

User avatar
redhawk
Posts: 3465
Joined: Sun Mar 04, 2012 2:13 pm
Location: ::1

Re: Omxplayer not starting

Tue Aug 26, 2014 4:39 pm

What version of omxplayer are you using?? i.e. omxplayer --version

Despite the odd setup and lack of screen this shouldn't stop omxplayer running since no HDMI would mean the Pi uses Composite video output instead.
As for the LAN connection with the laptop it's possible the Pi doesn't have full internet access and so cannot play then Dailymotion videos.

What happens when you run omxplayer /opt/vc/src/hello_pi/hello_video/test.h264 ??

Richard S.

Tany3450
Posts: 15
Joined: Fri Aug 22, 2014 12:32 pm

Re: Omxplayer not starting

Thu Aug 28, 2014 5:40 pm

redhawk wrote:What version of omxplayer are you using?? i.e. omxplayer --version

Despite the odd setup and lack of screen this shouldn't stop omxplayer running since no HDMI would mean the Pi uses Composite video output instead.
As for the LAN connection with the laptop it's possible the Pi doesn't have full internet access and so cannot play then Dailymotion videos.

What happens when you run omxplayer /opt/vc/src/hello_pi/hello_video/test.h264 ??

Richard S.
This test video is working with hdmi connected. But still my ellie.mp4 is not starting.

Code: Select all

omxplayer --version
omxplayer - Commandline multimedia player for the Raspberry Pi
        Build date: Sat, 22 Mar 2014 20:58:15 +0000
        Version   : 39e6342 [master]
        Repository: https://github.com/popcornmix/omxplayer.git
Anyway, my purpose was to see any video working with omxplayer. Thanks for help and letting me know I cant run it with Xming.

jimjamz
Posts: 39
Joined: Sun Feb 09, 2014 12:37 am

Re: Omxplayer not starting

Mon Nov 10, 2014 11:39 am

What is the best way to watch video over SSH? Is there a player that supports X Window?

I have Xming installed and ran into the same error when trying to view a video using omxplayer.

gkreidl
Posts: 6355
Joined: Thu Jan 26, 2012 1:07 pm
Location: Germany

Re: Omxplayer not starting

Mon Nov 10, 2014 11:50 am

jimjamz wrote:What is the best way to watch video over SSH? Is there a player that supports X Window?

I have Xming installed and ran into the same error when trying to view a video using omxplayer.
No way. All hardware accelerated players go directly to the video hardware (overlay) and so the videos can only be viewed on a monitor connected to the RPi. Copying the video back to the X-Windows framebuffer (and transferring that across the network in your case) would be so slow that it simply can't work.
Minimal Kiosk Browser (kweb)
Slim, fast webkit browser with support for audio+video+playlists+youtube+pdf+download
Optional fullscreen kiosk mode and command interface for embedded applications
Includes omxplayerGUI, an X front end for omxplayer

Return to “Troubleshooting”