User avatar
DigitalLumberjack
Posts: 336
Joined: Thu May 22, 2014 8:55 am
Location: France
Contact: Website

RPi and microSD ext4-fs error

Fri Aug 22, 2014 8:45 am

Hi everybody !

I have an issue with two models of samsung micro sd cards.

I tested the cards on both B and B+ revision, with both a noob install and an raspbian image.

An ext4-fs error shows up when i try to apt-get upgrade my system, always when unpackaging some package...

The sd card models are :
- microSD samsung 32g : MMCTR32GUBCJ-VK
- microSD samsung evo 32g : MB-MP32D
Both class 10

As my RPi doesnt responds anymore, i had to take a picture of my tv, sorry for that.

Image

My question are : is it a compatibility issue ? Why does this happen ? And can it be reported as a bug in order to fix it ?

Thanks

kylewashburn
Posts: 1
Joined: Sat Aug 23, 2014 12:27 pm

Re: RPi and microSD ext4-fs error

Sat Aug 23, 2014 12:33 pm

Getting the exact same issue on a fresh install of rasbian on 16gb samsung evo microsd with B+. Boots fine the first time but I start getting these errors after apt-get update / apt-get upgrade

User avatar
DigitalLumberjack
Posts: 336
Joined: Thu May 22, 2014 8:55 am
Location: France
Contact: Website

Re: RPi and microSD ext4-fs error

Sun Aug 24, 2014 4:57 pm

So maybe it is caused by some samsung micro sd models. I have a 64gb samsung micro sd that works very well then...

DirkS
Posts: 10347
Joined: Tue Jun 19, 2012 9:46 pm
Location: Essex, UK

Re: RPi and microSD ext4-fs error

Sun Aug 24, 2014 5:06 pm

Maybe you should check if it's a fake. See e.g. http://www.ebay.co.uk/gds/Testing-flash ... 870/g.html

fezpi
Posts: 10
Joined: Thu Aug 14, 2014 12:38 am

Re: RPi and microSD ext4-fs error

Tue Aug 26, 2014 6:27 pm

I'm having the same issue with a Samsung MB-MPAGA 16 GB micro sd. The issue appears every time I use apt-get upgrade or apt-get to install something new, and prevents me from inputting anything on the console.

As suggested, I tried verifying for corrupted sectors (or to determine if it's a fake) using F3. It was reported that there seems to be nothing wrong with the card (no bad sectors, speed as expected).

Could this be firmware related?

User avatar
AndrewS
Posts: 3625
Joined: Sun Apr 22, 2012 4:50 pm
Location: Cambridge, UK
Contact: Website

Re: RPi and microSD ext4-fs error

Tue Aug 26, 2014 6:47 pm

See this thread http://www.raspberrypi.org/forums/viewt ... 28&t=85210

Especially the last post ;)

Return to “Troubleshooting”