fs007
Posts: 14
Joined: Mon Aug 18, 2014 6:34 am

Need help - 3G USB Dongle on Model A

Mon Aug 18, 2014 6:48 am

Hello,

i have a Problem, that is going to drive me grazy and need help:
My Project is a 3G Webcam, so i attached a picam and a Huawei e169 3G dongle to a Pi Model B (Raspbian). Everything worked fine. Then i moved the SD-Card and the dongle to a Model A. Again everything worked fine.

A few days ago, i did a sudo update, sudo upgrade on that Model A.

After that, the 3G Dongle is not recognized any more: It is not even listed in lsusb at all, while dmesg shows no errors. Any other USB device works on that USB port (e.g. wifi, keyboard,...)
When i move the SD Card and the same dongle back to the model B, it works !.
When i connect the 3G dongle over an un(!)powered hub to the Model A, it works also !
But it doesn't work if it is directly connectet to the Model A's USB port.

My question:
Do i have to reconfigure something when i move an SD-Card from a Model B to Model A ? I know, that USB support on those models is slightly different.

fs007
Posts: 14
Joined: Mon Aug 18, 2014 6:34 am

Re: Need help - 3G USB Dongle on Model A

Mon Aug 18, 2014 8:47 pm

Meanwhile i have set up a completely new sd-card just pure from the 3.12.22+ image in the download section.
The problem still remains: A Huawei e169 3G dongle is not recognized when it is plugged into the USB port of a model A.
It is recognized, if it is connected over a hub (even unpowered).
If I downgrade back to 3.10. , everything works fine.
I'm convinced now, that 3.12.22+ has a real big bug in respect to USB support of Model A.

Can anyone confirm this, or try out another 3G modem on model A with 3.12.22+ ?

MattF
Posts: 55
Joined: Tue Feb 12, 2013 10:01 am

Re: Need help - 3G USB Dongle on Model A

Tue Aug 19, 2014 3:16 pm

Chances are there just isn't enough power on the USB port directly on the Pi to reliably drive a 3G dongle.
I've always used powered hubs.

Not sure if there is a current difference between the A and B, but my guess is you are on the cusp of it working at all when directly connected.

fs007
Posts: 14
Joined: Mon Aug 18, 2014 6:34 am

Re: Need help - 3G USB Dongle on Model A

Tue Aug 19, 2014 5:22 pm

power is surely not the issue:
1. I source the pi via pin connector with 3A PSU.
2. With Raspian 3.10, the 3G Dongle works fine and reliably on model A without a powered hub.
3. If i Iook at the electrical diagram, i can see no difference in USB power between model A and B.

It would be very helpfull, if some one else would try a 3G dongle on a model a under 3.12.22+ without hub.
Perhaps another type than my Huawei e169 works. Then i would buy that type.

fs007
Posts: 14
Joined: Mon Aug 18, 2014 6:34 am

Re: Need help - 3G USB Dongle on Model A

Sun Aug 24, 2014 7:15 am

OK, rpi-upgrade to 3.12.26+ solved the problem.
I would advise anyone who uses Model A and has problems with USB to do this upgrade.

Return to “Troubleshooting”