Midori won't connect to internet

47 posts   Page 2 of 2   1, 2
by bryan_smyth » Mon Jun 25, 2012 8:46 am
I had the Logitech Unifying Receiver plugged directly into my Raspberry Pi for a M510 wireless mouse. I found that web pages were taking a very long time to load. The response time to ping my router ranged from 100ms to several seconds. I found this forum page and tried a wired mouse. Web pages are loading fine now and the ping time from my router is around 2ms. I'm not using a USB hub at all.
Posts: 3
Joined: Fri Jun 22, 2012 10:39 pm
by Shiloa » Mon Jun 25, 2012 6:09 pm
I'm having the same issue.

Wired USB mouse and keyboard which interrupts ethernet access.

I did think getting a powered USB hub would fix it, but from these replies that isn't enough.

This is a pretty big issue for me.
Posts: 1
Joined: Mon Jun 25, 2012 5:59 pm
by jeffhaddow » Mon Jun 25, 2012 6:24 pm

It's just a hunch but, the set up I have has a 10 meter Ethernet cable between my RPi and my router. Could this be a contributory factor in this fault?

All the best
Posts: 118
Joined: Thu Jun 14, 2012 1:50 pm
by Fumbles » Thu Jun 28, 2012 12:20 pm
Did anyone ever find a solution to this?

I have exactly the same problem =(
Posts: 9
Joined: Wed Jun 20, 2012 5:10 pm
by jeffhaddow » Thu Jun 28, 2012 12:36 pm

No solution yet but I did ask liz the question

Have you any news about “the madwoman in the attic”?

I’m talking about the problem with the USB drivers. I cannot use my USB hub, restricting me to just the mouse and keyboard. So cannot use extra memory to store files on. When I try to use the hub the ethernet cable connection is “killed”.

And Liz' reply was

They’re being worked on (see the forums) – those drivers, sadly, weren’t written by our guys, who are super-duper engineering heroes. And we, like you, discovered that you can *kind of tell* when something has not been written by a super-duper engineering hero. Said S-DEHs are currently working on getting the drivers sorted, but it’s not a small job.

All the best
Posts: 118
Joined: Thu Jun 14, 2012 1:50 pm
by Niclas » Thu Jun 28, 2012 8:11 pm
Received my Pi today and I have the same issue.

Logitech M215 Wireless, no USB-hub.
Old Apple keyboard.

Never tried to unplug it in X, but worked fine in the console before i started it.
Now I only have PSU and Ethernet cable, works fine with SSH.
MyPi.se - Raspberry Pi webshop (atm swedish language and delivery only)
Posts: 7
Joined: Thu Jun 28, 2012 8:04 pm
Location: Stockholm, Sweden
by KcajBR » Sat Jul 07, 2012 10:53 am
I had the same problem, I was using a wireless mouse (Logitech M310) & a wireless keyboard (Logitech K360) They were both connected directly to the Raspberry Pi, so no usb hub. With both of them connected at the same time, I could not connect to the internet, so I remove the mouse and reload the page and it worked with just the keyboard. Then I remove the keyboard and kept the mouse and again it worked. Then I got an old usb wired Microsoft mouse and had both the wireless keyboard and the wired mouse connected, and now it works.
Posts: 1
Joined: Sat Jul 07, 2012 10:42 am
by marsman2020 » Mon Jul 09, 2012 4:43 pm
Still no response from anyone involved with the Pi kernel on my bug, it's been over a month.

Still new cases of similar issues popping up.
Posts: 70
Joined: Sun May 20, 2012 11:26 pm
by El_Presidente » Wed Jul 18, 2012 6:18 pm
I agree fully that, while there may well be bad power supply/bad hub issues for a number of users, there are a growing number of examples where the high power/low power usb device mix is the most likely cause of pi user problems, my own included.

I'm seeing almost exactly the same issue as Marsman2020 and it is my biggest headache using the Pi. I for one really appreciate that he has produced some top notch diagnostic evidence on Github #29 to support his conclusions and remove the hub/power supply from the equation.

For my part I have a no-name 7 port powered hub with decent quality supply, I am connecting a wired kb, wired mouse and a 16GB USB pen drive. I have wired Ethernet.
I have taken measurements on the board between TP1 and TP2 with a multi-meter as well as checking the stability generally of my power supplies.

Firstly the connections used and the issue I see:
Kb, mouse, pendrive connected to powered hub, Pi powered from hub, the usb uplink wire has had the 'cut the red wire' treatment, so is data only.
In console, I can see the pendrive, the kb works and I get reasonable internet connection.
Start LXDE and the network connection drops, then occasionally comes back up. The pendrive volume will also drop off, then reappear as if inserted. Most of the time I have neither the 16GB volume nor a working net connection.

Things tried:
So far I have tried Logitech mouse, Fujitsu Mouse and even an old wireless mouse from Dabs own range. Same issues seen each time (actually one of the mice didn't seem to want to work much at all).
I have tried an FJ Siemens keyboard and a Bakker S-board (portable USB kb). Same problem manifests again after starting LXDE. I borrowed a kb with two USB ports built in but this seemed to cause kernel panic when all connected with the powered hub (effectively resulting in three hubs being present).
Power supplies, I started with Kindle PS 700ma to Pi and no hub. All stable. TP1-TP2 remained between 4.93v and 4.90v.
Added hub on a working 1A supply, put kb and mouse on it, powered Pi from Kindle PS, uplink from hub to Pi (no red wire). All OK, LXDE/Midori OK. Multimeter had similar ratings to last, occasional drop by up to 0.05v.
Put the pendrive in hub, then restarted, All seemed OK but no network after starting LXDE, restarted and checked network back in console (it was), then start LXDE and it's gone again. Pendrive seemed to remain at this stage.
Swapped to a known (and stable) 2A supply for hub & changed to power Pi from hub (removing Kindle PS). Same issue each time, without X all seems to work, add in LXDE and no network. Also, at about this time the pendrive seemed to corrupt, it appeared then disappeared, then appeared then I saw an I/O error dialogue and hasn't been mounting since.

My personal thoughts (from a rank amateur) - the mouse drivers aren't needed in the console, so they aren't loaded - USB/network combo works. The kb and the pendrive (low/high power?) seem to work together. When X starts that causes the mouse drivers to kick in, conflicting with the network drivers actually causing USB instabilities across the whole Pi. The mouse/network combination seems to be most toxic, but have the ability to then kill any other attached USB device - particularly one that is high powered.

I vote for kernel/driver instability being the root cause and one needing urgent attention by the Foundation and some of these eminent and excellent supporters we have on the site. Within my limited expertise I will assist by testing any new build or patch that becomes available.
Never trust a man, who when left alone with a tea cosey, doesn't try it on.
Posts: 36
Joined: Tue Apr 03, 2012 7:02 am
Location: Bolton, UK
by AlbertJHookman » Wed Jul 18, 2012 6:43 pm
Perhaps there is an IRQ conflict between USB hubs/mice and the ethernet controller in some cases
Posts: 2
Joined: Sun Jul 15, 2012 8:54 pm
by El_Presidente » Wed Jul 18, 2012 8:47 pm
Something like that yes. But the issue appears more likely to be in the kernel or the USB drivers than with hardware, even if some people have managed to make it go away by changing their hardware and splitting up high and low power USB devices.
Never trust a man, who when left alone with a tea cosey, doesn't try it on.
Posts: 36
Joined: Tue Apr 03, 2012 7:02 am
Location: Bolton, UK
by zoeterpi » Fri Jul 20, 2012 10:05 pm
I have done the following:
1. No connection using a usb hub but just a plain Trust Keyboard and old Dell mouse and it works.
2. When connecting a USB hub the network was lost.
3. Connected the keyboard and mouse without the hub and it works again

No idea at the moment why this conflict happens.
Next test would be if an X session can be created remotely then no need of keyboard/mouse.
Posts: 2
Joined: Fri Jul 20, 2012 9:48 pm
by greenalien » Sat Jul 21, 2012 2:06 pm
Same problem, also resolved by disconnecting the USB hub and connecting keyboard and mouse directly to the R-Pi. Oddly, my Microsoft Wheel Mouse Optical doesn't work when plugged directly into the R-Pi, but works OK through the hub, so I had to use a different mouse (Octigen - cheapo chinese model, works fine). Hub is a 7-port silver-cased Ebay 'bargain' that works fine with Windows PC. I experimented a bit further - connecting the keyboard directly, but the Microsoft mouse through the hub - original problem recurs. Swapping to the second mouse in the hub, but still with the keyboard connected directly, the same problem, but it takes longer to display the error message. Connecting the mouse directly, but the keyboard through the hub, the problem still occurs. Somewhere, there's a conflict between USB stack and Ethernet...
Importantly, there is nothing wrong with Midori - which, incidentally, is now running noticably faster with the latest Raspian distro.
Posts: 2
Joined: Sat Jul 21, 2012 1:30 pm
by fredjam » Sat Jul 21, 2012 2:38 pm
You probably have the usb keyboard problem. disconnect your keyboard
and fire up your web browser, it should now work fine. Of course you can
only test this by going to bookmarked sites. If you plug your keyboard in
it will take down eth0 again.

You can watch this happening by opening a terminal window and typing
'sudo tail -f /var/log/messages'

Then disconnect your keyboard, you should get a usb disconnect messages
Wait a few seconds and plug your keyboard back in, you should get a usb
connect messages. If you also get a stream of error messages for eth0
then your keyboard has brought down your network connection. If you
disconnect your keyboard the error messages will stop.

I don't know if all usb keyboards do this, I am trying to find out. Mice
and trackballs don't cause any problem so yo can browse the internet
without a keyboard attached but only by going to bookmarked sites.
Posts: 83
Joined: Thu Jul 19, 2012 3:19 am
Location: London UK
by jeffhaddow » Sun Aug 19, 2012 8:39 pm
Good News - A solution to this problem. :)

See page 13 of the posts under Troubleshooting - Elephant in our room

All the best
Posts: 118
Joined: Thu Jun 14, 2012 1:50 pm
by El_Presidente » Mon Aug 20, 2012 3:47 pm
Good news indeed - looks very promising.

Now I'll have to talk to the Berryboot developer to see if he can converge his Wheezy kernel build to pick up these changes. I decided to go Berryboot as it seemed to perk up my Pi no end - much better boot speed, general performance is good and stability is improved.

Berry boot together with swiching turbo mode off, plus these 'Elephant hunting' tweaks on firmware and build and I could be one happy, happy chappie.
Never trust a man, who when left alone with a tea cosey, doesn't try it on.
Posts: 36
Joined: Tue Apr 03, 2012 7:02 am
Location: Bolton, UK
by cjw » Sat Nov 03, 2012 12:12 pm
[quote="TallTUK"]Hi Folks

The final hypothesis is that it can't handle splitting the usb into so many ports. The two straight off the Pi are already split from a single connection to the board. Splitting them multiple times more may mess with it to much.

I have the same problem in November, scanning the responses, I've seen no message from a Raspberry Pi wizard.
My keyboard and mouse, both tailed, connect through a hub.
Dillo works reasonably well, but there are some DNS problems to address. Names in Canada are not being resolved.

Colin W.
Posts: 7
Joined: Mon Mar 05, 2012 5:38 pm
by Mobius » Thu Nov 22, 2012 11:22 pm
I'm having the same problem but without a USB hub and with just a USB mouse and USB keyboard plugged directly into the Pi. I even unplugged the mouse but cannot get the ethernet connection back. Maybe it's the keyboard. It's a Dell full sized one. My power supply is a 1 amp USB wall wart. Any thoughts?
Posts: 238
Joined: Thu Aug 30, 2012 1:07 am
Location: San Angelo, Texas USA
by Mobius » Fri Nov 23, 2012 12:34 am
I think the mystery may be solved. I tried a different USB power supply and it appears to be working consistently now. Haven't measured the input voltages under load yet to see what is different but apparently the Pi (or at least my Pi) is a bit finicky regarding operating voltage. I have two supplies that are identical and they both have the issue with losing the ethernet connection. The third supply appears to be stable. All three are rated at 5 volts +/- 5% and 1000 ma.
Posts: 238
Joined: Thu Aug 30, 2012 1:07 am
Location: San Angelo, Texas USA
by kevano » Mon Dec 31, 2012 2:37 pm
Hi ,
Just got a Raspberry Pi for Christmas & looking forward to putting it to good use .
I am a novice to this but as per previous logs I am having problems connecting to the internet.
I am connected to a TV monitor via HDMI port and trying to connect to the internet via a wireless
By scanning it finds my network provider & then I type in my PSK password .
When I try to connect to the internet I get the following error message :
http://www.google.com/ the page could'nt be loaded , cannot resolve hostname (http://www.google.com)
I have tried to ping http://www.google.com but the feedback is that this is an "unknown host" .
I have also noticed a message flagging up in the bottom right hand corner :
wpa_gui - disconnected from network .
Any advice on how to resolve would be gratefully received .
Thanks Kevin : :D :roll:
Posts: 1
Joined: Mon Dec 31, 2012 2:04 pm
by elliottrob » Mon Dec 31, 2012 7:46 pm
I too am having problems connecting. I am connected to my network, using scan and entering my password, but I can not see the internet. It is not a problem with the network as other devices can see the internet. Any assistance would be gratefully received.

When I use the file manager to see the network I get an error message saying the specified location is not mounted

I also am having problems loading pygames3 - do I need an internet connection for this, or is the software already loaded on the PI from the Wheezy image.

Posts: 1
Joined: Sat Dec 29, 2012 3:32 pm
by speckk » Thu Jan 17, 2013 6:38 pm
On Raspbian I downloaded last week, I disconnected my USB network device (my Samsung Transform phone), and now Midori won't resolve hostnames, nor go to IP addresses.

Cannot resolve hostname (gmail.com)

Cannot connect to destination (

I'm writing this post from Dillo on my pi with ping times of 55ms, so there's no issue with my network, power, hubs or X misbehaving. This is all Midori, and I had an important session running that I don't want to reboot. Any way to get Midori reconnected again? It seems like Midori has a stability issue.
Any other lightweight browsers I should consider for important connections?

$ ping google.com
PING google.com ( 56(84) bytes of data.
64 bytes from den03s05-in-f0.1e100.net ( icmp_req=1 ttl=56 time=71.6 ms
64 bytes from den03s05-in-f0.1e100.net ( icmp_req=2 ttl=56 time=52.4 ms
Posts: 1
Joined: Thu Jan 17, 2013 6:15 pm